Thread Tools Search this Thread Display Modes
Old 08-01-2015, 04:10 PM   #1
2 Rivet Member
Bee Cave , Texas
Join Date: Apr 2015
Posts: 21
9 Volts out of Univolt? Failing?

Trying to hook up a new car stereo. It wouldn't power up. Diagnosed it down to the voltage available up in the console. It's only 9 Volts. Is this a sign of a failing univolt? It have the AS plugged in, the Univolt is humming, the fuses are all fine. If I hook the stereo directly up to a 12 volt source, it works fine.

I just don't know enough about univolts to know if the 9 volt problem is due to the univolt or something else.


BluesClues is offline   Reply With Quote
Old 08-01-2015, 04:30 PM   #2
Rivet Master
Al and Missy's Avatar

2002 30' Classic S/O
Melbourne Beach , Florida
Join Date: Nov 2013
Posts: 1,476
Measure the voltage at the univolt. If it is 12V then the problem is somewhere else. If it is 9 volts, then the univolt may be bad. Disconnect everything from it and measure the voltage again. If 9 volts, the univolt is bad. If it is 12 volts, measure the voltage on the wires you disconnected. If 12V the univolt is bad. IF 9 volts, you have a battery or wiring problem.



"You cannot reason someone out of a position they have not been reasoned into"

Al, K5TAN and Missy, N4RGO
2002 Classic 30 Slideout
2001 Safari 25 RB Twin (Gone, but not forgotten)
2013 Dodge 2500 Laramie 4x4 Megacab Cummins
WBCCI 1322, TAC FL-39, AIR 82265

Al and Missy is offline   Reply With Quote
Old 08-01-2015, 05:50 PM   #3

2003 25' Classic
Zanadude Nebula , WNY
Join Date: Jun 2007
Posts: 10,802
Images: 1
Thumbs up

Do you have a battery in the loop? If not the Uni may be toast, it likes/requires a bit of resistance.

IIWY....I'd retire it regardless, and get a modern multi, (3 or 4) stage converter.

Give Randy a call for the straight scoop

ROBERT CROSS is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Univolt is only putting out 6.3 volts jack9443 Batteries, Univolts, Converters & Inverters 7 04-14-2015 08:23 AM
My Exhaust Fan Keeps Failing, 2012 J5MM 2011 - 2015 International 34 06-10-2014 11:01 AM
AC Thermostat failing? VeggieBullet Electrical - Systems, Generators, Batteries & Solar 6 11-27-2011 08:45 AM
AC Failing???? VeggieBullet Furnaces, Heaters, Fireplaces & Air Conditioning 11 11-21-2011 08:39 PM
Steering Gear Leaking/Failing? swebster Mechanics Corner - Engines, Transmission & More... 6 03-19-2006 04:23 AM

Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:10 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.