Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-17-2007, 07:01 PM   #1
New Member
 
1969 23' Safari
Sebastopol , California
Join Date: Jul 2007
Posts: 1
'69 Safari 110v system not working

Hello, new to the community and first post.

In February we bought a ’69 Safari Land Yacht. It’s in good condition everything was working…until just before our trip last week I noticed the red light at the panel was not on (it was on when shoreline is plugged in). Then I found none of the 110v outlets were working (with shoreline connected). We went camping anyway because all of the 12v system works.

In trying to troubleshoot I found no blown fuses in these locations: rear compartment right side bus bar (12v system I believe), Univolt 2 fuses not blown and no 110v power to the Univolt system, circuit breakers in the front panel (by the gauges) not tripped (but reset anyway with no change). I thought it weird that there is no power to the Univolt.

Am I missing a fuse anywhere? The shoreline enters the trailer on the left rear to the left of the black water dump. Then as far as I can tell heads toward the front of the trailer between the external and internal skin. The only manual I have is for the Globetrotter, which doesn’t match our layout.

Any help would be great!
__________________

__________________
Skiffy is offline   Reply With Quote
Old 07-17-2007, 07:31 PM   #2
Ham KI4HJX
 
1982 27' Excella
1970 23' Safari
Franklin , 28734
Join Date: Jul 2007
Posts: 126
Start at the source (shoreline outlet) and check with a voltmeter or a test light. If it has power move to the power cord where it comes into the breaker box and check for power there. If you have power coming out of the breaker box try runing the air conditioner. Then check it at the univolt.
__________________
Ramp is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
in the process of getting water system working wavemaster Plumbing - Systems & Fixtures 5 11-16-2006 03:21 PM
Water filter system 53flyingcloud Our Community 2 07-05-2002 04:43 PM
Problem with electrical system (1965 safari) rslaymaker Electrical - Systems, Generators, Batteries & Solar 4 06-13-2002 05:49 PM
25' Safari movement swest22 Our Community 10 05-03-2002 08:11 AM
1960 Safari DanLyle 1960 Safari 0 03-26-2002 07:13 PM


Airstream Classifieds



Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

RV & Travel Trailer Communities

Our RV & Travel Trailer sites encompasses virtually all types of Recreational Vehicles, from brand-specific to general RV communities.

» More about our RV Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:34 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.

Airstream News Delivered to your Email!

Stay up-to-date with Airstream news in your inbox!

unsusbcribe at anytime with one click

Close [X]