Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-17-2011, 01:19 PM   #1
New Member
 
Ottawa , Ontario
Join Date: Apr 2010
Posts: 2
Running light won't turn off

We have a 25CCD International and the umbilical cord ended up falling during our travels and rubbing along the road. Most of the wires ended up burning apart due to the friction. I was able to temporarily tape them back together, color to color, and get everything working again. The only problem is with the rear right running light which won't turn off. The only way the light turns off is when I disconnect the battery or disconnect and remove the light. Any advice or shared experiences will be appreciated.
__________________

__________________
terryd is offline   Reply With Quote
Old 07-17-2011, 01:34 PM   #2
Rivet Master
Airstream Dealer
 
Inland RV Center, In's Avatar
 
Corona , California
Join Date: Feb 2002
Posts: 16,499
Images: 1
Quote:
Originally Posted by terryd View Post
We have a 25CCD International and the umbilical cord ended up falling during our travels and rubbing along the road. Most of the wires ended up burning apart due to the friction. I was able to temporarily tape them back together, color to color, and get everything working again. The only problem is with the rear right running light which won't turn off. The only way the light turns off is when I disconnect the battery or disconnect and remove the light. Any advice or shared experiences will be appreciated.
A strand of that tail light wire is touching a 12 volt source.

Andy
__________________

__________________
Inland RV Center, In is offline   Reply With Quote
Old 07-17-2011, 01:37 PM   #3
Rivet Master
 
RickDavis's Avatar

 
1961 24' Tradewind
1969 29' Ambassador
1970 21' Globetrotter
Jamestown , Tennessee
Join Date: Jul 2008
Posts: 1,781
Are you sure it is a running light. All running lights should come on under those conditions. It would more likely be the right brake/turn light.
Regardless the most likely problem would be a short between the battery lead and the running light lead. Basically black wire(bat) and brown wire (light)

It is also possible that you have crossed brown and black in your splice, particularly if the repair was under low light conditions.

Less likely is a problem in the connector itself unless it was also damaged

Hope that helps
__________________
Rick Davis 1602 K8DOC
61 tradewind, plus a few others
13 Ram 2500 TD
99 Dodge TD 577K miles

RickDavis is offline   Reply With Quote
Old 07-20-2011, 08:09 PM   #4
New Member
 
Ottawa , Ontario
Join Date: Apr 2010
Posts: 2
Thanks for the feedback Andy and Rick. I need to replace the umbilical cord in any event. It is currently being held with electrical tape. Do you think my replacing the umbilical cord should solve the problem? and is this a difficult thing to do? I find it very hard to find a dealer who will work on our trailer. Thanks very much for your help and advice, Terry
__________________
terryd is offline   Reply With Quote
Old 07-20-2011, 08:41 PM   #5
CLOUDSPLITTER "Tahawas"
 
ROBERT CROSS's Avatar

 
2003 25' Classic
Zanadude Nebula , WNY
Join Date: Jun 2007
Posts: 11,153
Images: 1
Welcome Aboard....

I know it's after the fact....but I use zip-ties to hold the plug in.

Not difficult to replace the cord, did it on our first AS.

Good Luck

Bob
Attached Thumbnails
Click image for larger version

Name:	06 BURB SHAKEDOWN TRIP 018.jpg
Views:	83
Size:	149.3 KB
ID:	135489  
__________________
PFC.....

“After all these years the reason I continue to love Thanksgiving.....I still sit at the kids table.”
RLC

Sandra wanted to go to Cleveland on vacation,
but I’m the Husband, so we went to Cleveland.
RLC
ROBERT CROSS is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LED light kit for the Monarch stop tail and turn light Dan@LED4RV Commercial Listings 5 05-12-2014 06:05 AM
Street side brake light not working w/ running lights on NicheVintage Lights - Interior & Exterior 7 08-23-2011 06:54 AM
1988 Running Light Exposed Wire vhariable Lights - Interior & Exterior 2 06-25-2011 09:56 PM
Running light issue solved! Phrunes Lights - Interior & Exterior 0 06-12-2011 10:30 PM
Confusing turn and brake light problem mikeandnora Lights - Interior & Exterior 13 05-29-2011 08:30 AM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:45 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.