Thread Tools Search this Thread Display Modes
Old 06-15-2015, 04:55 PM   #1
2 Rivet Member
1990 29' Excella
baltimore , Maryland
Join Date: Jan 2015
Posts: 31
Rear red side marker light not working..

... Its got voltage there, its just that the fixture is so corroded
it is not making contact. In fact one of the contacts just fell out
in my hands a couple of minutes ago.

I have the trailer inspection on Thursday!

I must pass because I don't want to have to drag the trailer all the way
down to the inspection place just to prove that the one light works.

Any ideer where I can get some innards for one of these side lamps?
Or can I buy a different one and pull the innards and put them in my
lamp fixture?

I have a 90 excella.


groundhogy is offline   Reply With Quote
Old 06-15-2015, 05:19 PM   #2
Rivet Master
HowieE's Avatar

1991 34' Excella
Princeton , New Jersey
Join Date: Aug 2003
Posts: 6,316
Images: 12
If you can measure voltage and you have tested the bulb it is a bad ground. You can clean the surfaces between fixture and the trailer body itself.

2004 Excursion 4x4
1991 34 ft. Excella +220,000 miles, new laminated flooring, new upholstery, new 3200 lbs axles

HowieE is offline   Reply With Quote
Old 06-15-2015, 05:47 PM   #3
2 Rivet Member
1990 29' Excella
baltimore , Maryland
Join Date: Jan 2015
Posts: 31
Ok, I came up with a solution.
I had some of those LED panel lights with the sticky back.
I just connected that in and viola. I pass inspection.
It actually may be a better simpler solution to the dual 194 bulbs
that were in there.

the other option was that I was just going to buy two sockets at the auto store and fasten them in there somehow.

anyway case solved.
groundhogy is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacing side marker light RAH Lights - Interior & Exterior 2 06-19-2015 07:59 PM
Red! Red! Red! Can Anyone Tell Me What This is About Now? Fly at Night Batteries, Univolts, Converters & Inverters 23 11-06-2011 01:18 PM
light not working in 1962 Bambi (only 110 side) female.nomad Lights - Interior & Exterior 1 09-15-2011 12:53 PM
Street side brake light not working w/ running lights on NicheVintage Lights - Interior & Exterior 7 08-23-2011 05:54 AM
Rear right side turn signal not working s4misfaction Argosy Motorhomes 4 05-27-2010 03:39 AM

Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:50 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.