Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-08-2013, 04:33 PM   #1
cwf
Rivet Master
 
cwf's Avatar
 
1999 34' Excella
Currently Looking...
Hillsboro , Texas
Join Date: Feb 2013
Posts: 5,928
Images: 2
Any one care to offer thoughts?

We camped with no issues several days.. In spite we had over an hour of a single rainbow, when arriving home and plugging in, I had two failures.

Failure #1
GFCI tripped and won't stay "on"

Failure #2
Sharp MW convection oven panel fried. The bottom component on the board exploded. Well, smoked and blistered real bad. Can't even tell what it was... Looks like an old button cap..

Location, Pecan Park RV Also the cable didn't work.
__________________

__________________
Peace and Blessings..
Channing
WBCCI# 30676
cwf is offline   Reply With Quote
Old 09-08-2013, 04:38 PM   #2
3 Rivet Member
 
kmaggard's Avatar
 
1994 21' Sovereign
Paradise Valley , Arizona
Join Date: Jun 2013
Posts: 135
Do you know if a GFCI does not have power it will not stay on? Check your breakers.
__________________

__________________
WBCCI# 2520
AIR# 77458
Ken and Ben the Saint
Paradise Valley, Arizona
kmaggard is offline   Reply With Quote
Old 09-08-2013, 04:42 PM   #3
cwf
Rivet Master
 
cwf's Avatar
 
1999 34' Excella
Currently Looking...
Hillsboro , Texas
Join Date: Feb 2013
Posts: 5,928
Images: 2
Quote:
Originally Posted by kmaggard View Post
Do you know if a GFCI does not have power it will not stay on? Check your breakers.
Yessir, all other circuits running cool.
__________________
Peace and Blessings..
Channing
WBCCI# 30676
cwf is offline   Reply With Quote
Old 09-08-2013, 08:28 PM   #4
cwf
Rivet Master
 
cwf's Avatar
 
1999 34' Excella
Currently Looking...
Hillsboro , Texas
Join Date: Feb 2013
Posts: 5,928
Images: 2
Ok. Here is fried MW board

Click image for larger version

Name:	image-1599348149.jpg
Views:	72
Size:	335.2 KB
ID:	195296


Click image for larger version

Name:	image-3959355555.jpg
Views:	73
Size:	510.4 KB
ID:	195297


Also replaced GFCI. All power restored.

Got recommendations on cause and possible protective action?
__________________
Peace and Blessings..
Channing
WBCCI# 30676
cwf is offline   Reply With Quote
Old 09-08-2013, 08:37 PM   #5
Rivet Master
 
garry's Avatar
 
1969 31' Sovereign
Broken Arrow , Oklahoma
Join Date: Jan 2003
Posts: 1,362
Images: 7
Have you checked the incoming voltage with a meter?

A GFCI trips when it detects voltage on the ground wire you may have an open neutral caused when you unplugged from the CG pedestal or plugged in at home.
__________________
Garry
garry is offline   Reply With Quote
Old 09-08-2013, 08:52 PM   #6
cwf
Rivet Master
 
cwf's Avatar
 
1999 34' Excella
Currently Looking...
Hillsboro , Texas
Join Date: Feb 2013
Posts: 5,928
Images: 2
It may have been at home. Someone else plugged in then we discovered problems.... Things worked at RV park until I shut off the main inside then disconnected at pedestal. Same procedure I always used.

Voltage is 122-121!!! Solid neutral and grounds.
__________________

__________________
Peace and Blessings..
Channing
WBCCI# 30676
cwf is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:15 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.