Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-22-2012, 07:52 PM   #1
pickpick
 
1966 28' Ambassador
Jonesboro , Arkansas
Join Date: Apr 2012
Posts: 17
'66 Ambassador center interior lights quit

The center row of interior lights, front gaucho reading lights and vent fan stopped working over night. All of the other lights, AC, and receptacles work fine. I used a test light at the fuse panel after checking/replacing the 30 amp fuses. I only found one fuse that had fire to it. So, I went to the converter with the test light. My two blue wires have fire, one feeds the hot fuse and the other runs to the battery pos+. I have a white wire and a red wire coming from the converter that do not have current. Are these supposed to feed the other 3 fuses? Is it possible that my old converter partially quit on me over night while not plugged in? Thanks for any info.
__________________

__________________
lizpickering is offline   Reply With Quote
Old 08-25-2012, 11:06 PM   #2
pickpick
 
1966 28' Ambassador
Jonesboro , Arkansas
Join Date: Apr 2012
Posts: 17
Anyone ever had part of their lights quit working? If so what was wrong with them. Thanks.
__________________

__________________
lizpickering is offline   Reply With Quote
Old 08-26-2012, 06:29 AM   #3
Rivet Master
 
rideair's Avatar
 
Join Date: Sep 2004
Posts: 1,223
Check the main fuse inside of the conv. door. It's either that or you need a new conv.

Enjoy,
__________________
Paul Waddell
rideair is offline   Reply With Quote
Old 09-03-2012, 09:22 PM   #4
pickpick
 
1966 28' Ambassador
Jonesboro , Arkansas
Join Date: Apr 2012
Posts: 17
I have an old intellipower that doesn't have fuses in it. I've had the cover off and looked all over it. I tried to jump power from the light over the sink(that does work) to the over head kitchen light today and no dice. I used a jumper wire from the sink light power wire and and a jumper wire from the sink ground rivet to the kitchen overhead light fixture. I could get some sparks but no light. If there is a dead short in the overhead wiring, how in the world would I get to it to chase it or repair it? And if it were a short wouldn't it have or still blow a fuse? I feel like the problem will be at one point and they are wired in a series so to speak. Thanks for any hep.
__________________
lizpickering is offline   Reply With Quote
Old 09-03-2012, 09:26 PM   #5
pickpick
 
1966 28' Ambassador
Jonesboro , Arkansas
Join Date: Apr 2012
Posts: 17
Oh by the way, I checked my voltage at the intellipower again today and I'm only getting 11.77 volts. Could not enough volts cause part of the lights to work? And do ya'll think all of the 12volt lights are on the same fuse circuit? Thanks.
__________________
lizpickering is offline   Reply With Quote
Old 09-03-2012, 11:18 PM   #6
Rivet Master
 
TouringDan's Avatar

 
1966 24' Tradewind
1995 34' Excella
Lynchburg , Virginia
Join Date: Sep 2009
Posts: 2,472
Converter/battery voltage should be over 13 volts. Sounds like your battery is way low since your converter is not getting power in (120v ac).

I tried to post photos of an electrical diagram, but I could not down load the photos.

Dan
__________________
TouringDan is offline   Reply With Quote
Old 09-04-2012, 09:12 PM   #7
pickpick
 
1966 28' Ambassador
Jonesboro , Arkansas
Join Date: Apr 2012
Posts: 17
Quote:
Originally Posted by TouringDan View Post
Converter/battery voltage should be over 13 volts. Sounds like your battery is way low since your converter is not getting power in (120v ac).

I tried to post photos of an electrical diagram, but I could not down load the photos.

Dan
Here is my hang up on that. I've never had a battery hooked up in it yet. All I've ever done is hook it to 120v service while we've worked on it for the past 9 months. Is it possible I have a short in the pos line of the center row? I assumed if the row that isn't working had a short, it would have blown the fuse that feeds the whole circuit. But if not, maybe that's where my difference in 11.75 volts and 13.?volts is going. Thanks for the trouble shooting suggestions. Keep them coming, I need help.
__________________

__________________
lizpickering is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:39 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.