Thread Tools Search this Thread Display Modes
Old 07-30-2010, 09:25 AM   #1
3 Rivet Member
ole81's Avatar
1981 31' Excella II
Richmond , Texas
Join Date: Jun 2007
Posts: 127
Images: 17
12V lights and water pump

Our 12v ceiling lights flickere when we turn on the water pump. Is this normal, or do we have a problem?

Bob (K5RPS) and Gail (MAAAA)

31' 1981 Excella II
2001 F-250 7.3D Crew w/8'bed and Pullrite 180degree

"Ask the Man Who Owns One" (Packard, Of Course)
"Ask the Woman who lives with one...or more!" (Gail)
ole81 is offline   Reply With Quote
Old 07-30-2010, 09:29 AM   #2
Rivet Master
Dave Park's Avatar
2005 22' Safari
Hyde Park Place , Ohio
Join Date: Jul 2010
Posts: 972
It's an Airstream, so both

Dave Park is offline   Reply With Quote
Old 07-30-2010, 10:08 AM   #3
Maniacal Engineer
barts's Avatar
1971 25' Tradewind
Menlo Park , California
Join Date: Jan 2010
Posts: 1,210
Images: 1
Blog Entries: 4
The start current on the 12V water pump is large; this causes voltage fluctuations on the line and the resulting light flicker. This is normal and expected; you can see the same effect at home with loads w/ high in-rush currents such as circular saws, etc.

If it bothers you, you may be able to reduce the problem with one of those $20 2F capacitors used by the car stereo nuts to provide more drive for their woofers; attach this at the pump to the power supply line (BEFORE the switch) and to the local ground. Personally, I don't feel it is worth worrying about...

- Bart
Bart Smaalders
Menlo Park, CA
barts is offline   Reply With Quote
Old 07-30-2010, 01:21 PM   #4
4 Rivet Member
2008 16' Safari
Destrehan , Louisiana
Join Date: May 2009
Posts: 395
You could have a little corrosion on any (or all) of the wires in the DC circuit. I'd check all of the battery terminals, binding post and all of the wire terminations in the DC distribution panel. The lights are flickering because of a voltage drop. The water pump should not draw enough current to load the DC buss and make the lights dim.
Neither of my AS trailers ever had this problem when the DC buss, water pump, batteries and charger were all working correctly.
dlb435 is offline   Reply With Quote
Old 07-30-2010, 01:39 PM   #5
Rivet Master
garry's Avatar
1969 31' Sovereign
Broken Arrow , Oklahoma
Join Date: Jan 2003
Posts: 1,331
Images: 7
I agree with dlb435 sounds like a bad ground or weak battery.
garry is offline   Reply With Quote
Old 08-03-2010, 02:24 PM   #6
3 Rivet Member
1978 31' Excella 500
Currently Looking...
Join Date: Sep 2009
Posts: 103
Blog Entries: 1
electrical issue

Originally Posted by dave park View Post
it's an airstream, so both
i have a 1975 argosy and the following all worked and now do not ????????? They are as follows the range hood fan
light over the sink
galley fan
fresh water pump
light in bed room
all other light work ????
I think it is a blown fuse , but can not find the fuse panel in this 1975 argosy ?????? Any ideas ????
Gosman is offline   Reply With Quote
Old 01-27-2013, 09:49 PM   #7
3 Rivet Member
mtbguy's Avatar
Dunwoody , Georgia
Join Date: Nov 2012
Posts: 153
I have this problem now also!

Reviving an old post here. I just brought home my new (to me) 1976 Argosy 26. Have been replacing plumbing with PEX and working on all kinds of small projects. My 12V lights (and everything else) worked when I put in fresh, new charged battery. I noticed the TV antenna no longer worked and was leaking a bit, so I removed it and installed a cover on the roof. The insulation was a bit damp around the hole so I ran a hair dryer on it for awhile.

The next day, my overhead lights, and water pump no longer function. Does this sound like damp insulation still or a blown fuse in converter? I looked at fuses but did not test them.



mtbguy is offline   Reply With Quote


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Freaky 12v lights flickering and fading out RichHog Batteries, Univolts, Converters & Inverters 15 12-13-2011 10:19 AM
I want my water pump switch to light up... Friday Electrical - Systems, Generators, Batteries & Solar 18 09-18-2011 10:03 PM
'08 Safari water heater only staying lit for 3 mins... bonginator Water Heaters, Filters & Pumps 3 08-21-2011 07:51 PM
Another @!#*& water heater pilot that goes out! Aage Water Heaters, Filters & Pumps 36 08-11-2011 10:51 PM
Water pump wiring question pageclot Water Heaters, Filters & Pumps 6 04-26-2011 07:11 PM

Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:45 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.