Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-21-2014, 08:50 PM   #1
1 Rivet Member
 
Supertwin1's Avatar
 
1972 27' Overlander
Austin , Texas
Join Date: Aug 2013
Posts: 12
Water pump wiring and proper wiring

I have a 1972 Overlander that has a Peter & Russell water pump that constantly runs whenever I turn the switch on. When the faucets are closed the pump continues to run and begins to leak thru the case. I've rebuilt the pump and it pumps fine whenever a faucet is open but if you shut the faucet the pump begins to slow and pressurize causing the leak. My understanding is you should be able to turn the pump on(via switch)& the pump should only cycle when a faucet it open, then cycle off when faucet is closed. Am I correct. Do I have a bad pressure regulator & if so, is there 1 to be had? Also is there a wiring diagram for the pump. Mine has a red(orange)fused wire from the console switch "on", a white wire(ground ?)&the 2 wires that go to the pump. Can someone look at theirs and tell me which wires go where? Any help you can provide would be greatly appreciated!
__________________

__________________
Supertwin1 is offline   Reply With Quote
Old 05-21-2014, 09:47 PM   #2
Rivet Master

 
1972 31' Sovereign
1975 31' Excella 500
Currently Looking...
Benton , Arkansas
Join Date: Mar 2013
Posts: 1,749
If the pump leaks that is why it runs constantly.

When the power switch is on, the pump turns on until a predetermined water pressure is reached then it switches off until pressure is relieved in the system.

In normal operation the pump stays off til a faucet is opened and the pressure drops, in your case the pressure is bleeding off via the leak so the pump never reaches its turn off pressure.
__________________

__________________
J. Morgan is online now   Reply With Quote
Old 05-21-2014, 09:51 PM   #3
Rivet Master

 
1972 31' Sovereign
1975 31' Excella 500
Currently Looking...
Benton , Arkansas
Join Date: Mar 2013
Posts: 1,749
If you have rebuilt the pump, you might look over the pump case for freeze damage.

My 72 came with an original pump that pumped water great, but the pump had frozen at one point so it is essentially junk.

Strange I haven't been able to bring myself to throw it away yet.... it rests in a parts bin for the time being...
__________________
J. Morgan is online now   Reply With Quote
Old 05-21-2014, 11:31 PM   #4
Rivet Master

 
1972 31' Sovereign
1975 31' Excella 500
Currently Looking...
Benton , Arkansas
Join Date: Mar 2013
Posts: 1,749
Water pump wiring and proper wiring

Now wait...

It just occurred to me that maybe your pump isn't properly wired through the pressure switch, or that maybe the pressure switch won't open.

If this is the case my previous answer is wrong, or at least incomplete.

If you have the original pump, and it is like mine, it will have a red box on the side with three terminals for wires.

The positive wire must pass through this switch before proceeding to the electric motor or it will over pressure and well, probably leak at the housing gaskets or blow out the diaphragm.

I can't remember which terminal is which, I figured it out by tracing the wires.

I will look at mine tomorrow ( if I don't forget) and add a picture on here explaining what wire goes where.
__________________
J. Morgan is online now   Reply With Quote
Old 05-22-2014, 10:48 AM   #5
1 Rivet Member
 
Supertwin1's Avatar
 
1972 27' Overlander
Austin , Texas
Join Date: Aug 2013
Posts: 12
Regulator doesn't "cut out" & pump keeps running

I have the red pressure regulator on my PAR pump and have the positive (+) switch wire connected to the far left terminal, the center terminal is left opened & a wire to the motor at number 3 terminal(far right). The ground(-) wire from the motor is connected to the white ground wire from the trailers wiring harness.
The problem I'm having is the pump won't cycle off when peak pressure is achieved. Is there an adjustment I can make to the regulator in order to make it cycle off? I see 2 allen head screws under the regulators cover. Any help is appreciated.
__________________
Supertwin1 is offline   Reply With Quote
Old 05-22-2014, 06:31 PM   #6
Rivet Master

 
1972 31' Sovereign
1975 31' Excella 500
Currently Looking...
Benton , Arkansas
Join Date: Mar 2013
Posts: 1,749
Man I am sorry, I forgot to look at my pump for you today.

I had to take the cover off of mine to figure it out.

Best I remember one of the terminals was a ground where negative from the trailer connected on the same screw as the negative for the pump motor, one terminal is for power into the pressure switch, and one terminal is runs from the pressure switch to the positive motor wire.

If the connections are right, and the pump will not switch off, the points in the pressure switch may be fused .

If this is the case it is often possible to separate the points and clean them up with a small file. Worst case you may need a new pressure switch. You could probably find one a Grainger or a similar store, or if you aren't in a huge hurry I will mail you my good used switch.
__________________
J. Morgan is online now   Reply With Quote
Old 05-22-2014, 08:11 PM   #7
1 Rivet Member
 
Supertwin1's Avatar
 
1972 27' Overlander
Austin , Texas
Join Date: Aug 2013
Posts: 12
@ J. Morgan.......if you are certain you will not be using or need this switch I would gladly make you and offer & pay for freight. Let me know-
__________________
Supertwin1 is offline   Reply With Quote
Old 05-22-2014, 08:17 PM   #8
Rivet Master

 
1972 31' Sovereign
1975 31' Excella 500
Currently Looking...
Benton , Arkansas
Join Date: Mar 2013
Posts: 1,749
Water pump wiring and proper wiring

No, I doubt I won't need it, the pump it is on is shot, I already replaced the pump with what I feel is an inferior new pump.

If the switch can restore your old pump I am happy to see that happen, besides, I have almost thrown the pump away several times, pressure switch and all...

PM me your address and I will mail it to you. I will let you take care of postage after you get the switch.
__________________
J. Morgan is online now   Reply With Quote
Old 05-23-2014, 07:05 AM   #9
1 Rivet Member
 
Supertwin1's Avatar
 
1972 27' Overlander
Austin , Texas
Join Date: Aug 2013
Posts: 12
Gracias, amigo!
__________________

__________________
Supertwin1 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't get proper sound through Sony receiver and TV Anna girl Audio, Video & TV 5 11-02-2013 10:28 PM
Pump doesn't turn off and it doesn't pump water either. I don't know what to do! Melimelo Fresh Water Systems 9 10-02-2013 10:55 PM
Please help me understand proper venting and is there a typical toilet flange set bac Tony S Sinks, Showers & Toilets 11 03-10-2013 09:32 PM
Proper City Water Fill, 30A inlet, etc. Placement? worldinchaos General Repair Forum 5 08-16-2011 02:39 PM
68 water pump-should the pump cycle? Boondocker Water Heaters, Filters & Pumps 8 08-06-2006 10:11 AM





All times are GMT -6. The time now is 10:13 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.
Modal Click