Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-21-2011, 07:34 PM   #1
2 Rivet Member
 
2011 25' FB International
Toronto , Ontario
Join Date: Jul 2008
Posts: 57
Water pump Issue.

Hi everyone,

We recently upgraded our 23' Safari SE to a 25' International Serenity Edition. We took it on a maiden voyage the other weekend, and one or two issues came up. Yes, they are covered under warranty, but my dealership is a 3.5 hour round trip from home.

I'm hoping someone can offer me some advice regarding the water pump. It's simply not working at all. Yes, I know where the "on" switch is on the sensor panel. I've also checked the fuse box and the in line fuse on the power line that feeds directly to the pump.

When I switch the pump on, nothing happens. The water tank is full. On my previous AS, I'd always hear the pump run for a second or two when I switched it on. With the new one, it doesn't make a sound and pumps no water when I open a tap.

Other than the fuses, which I checked already, could there be something simple that I overlooked? Or something that the dealership overlooked? Is there a by pass valve for the pump that may have been left open when the dealership was prepping it for us?

Any help would be appreciated. We're planning a two week trip to Fort Wilderness in October, and I'm not sure I'll be able to fit in a trip to the dealership prior to then. The water pump is the only issue with the AS that I can't just live with until after our vacation.

Cheers.
__________________

__________________
Toronto_Guy is offline   Reply With Quote
Old 09-21-2011, 07:54 PM   #2
CLOUDSPLITTER "Tahawas"
 
ROBERT CROSS's Avatar

 
2003 25' Classic
Zanadude Nebula , WNY
Join Date: Jun 2007
Posts: 11,153
Images: 1
TG

deja vu all over again...

Ours failed the second time it was turned on....first camping trip.

Spent half the first day with the WP on the picnic table fixing a separated wire where it enters the pump body. Had to cut back the insulation right at the pump
to expose enough wire to make a splice. Got lucky. But not a happy camper.

Don't know if yours is the same brand, but it's worth a look-see.

You might try several solid taps on the housing while flipping on/off.

Good Luck...eah

Bob
__________________

__________________
PFC.....

“After all these years the reason I continue to love Thanksgiving.....I still sit at the kids table.”
RLC

Sandra wanted to go to Cleveland on vacation,
but I’m the Husband, so we went to Cleveland.
RLC
ROBERT CROSS is offline   Reply With Quote
Old 09-22-2011, 06:36 PM   #3
2 Rivet Member
 
2011 25' FB International
Toronto , Ontario
Join Date: Jul 2008
Posts: 57
Thanks! I'll check the wire the next time I drive out to my AS. I'd rather spend a few hours fixing it before my vacation than during my vacation. ;-)


Quote:
Originally Posted by ROBERT CROSS View Post
TG

deja vu all over again...

Ours failed the second time it was turned on....first camping trip.

Spent half the first day with the WP on the picnic table fixing a separated wire where it enters the pump body. Had to cut back the insulation right at the pump
to expose enough wire to make a splice. Got lucky. But not a happy camper.

Don't know if yours is the same brand, but it's worth a look-see.

You might try several solid taps on the housing while flipping on/off.

Good Luck...eah

Bob
__________________
Toronto_Guy is offline   Reply With Quote
Old 09-22-2011, 07:36 PM   #4
Rivet Master
 
Silver Goose's Avatar
 
2008 27' Classic FB
Burkburnett , Texas
Join Date: Jul 2010
Posts: 955
Do you have a basic voltmeter or a 12v test light? Check for 12v at the pump with the switch on. It could be as simple as a disconnected wire.
__________________
AIR 47751
Air Safe Hitch, Reese Dual Cam 800#, Centramatics
Silver Goose is offline   Reply With Quote
Old 09-22-2011, 09:22 PM   #5
Site Team
 
Aage's Avatar
 
1974 31' Sovereign
Ottawa , ON
Join Date: May 2008
Posts: 11,204
Images: 25
Why not at least call Can-Am? Ask for Andy Thomson (the Boss), and see what he can suggest.

If all else fails, it really isn't that far to London, is it? I mean, not to a rootin'-tootin' Airstreamer?
__________________
“Courage is being scared to death, but saddling up anyway.”
...John Wayne...........................
Aage is offline   Reply With Quote
Old 09-23-2011, 05:46 AM   #6
Rivet Master
 
Lily&Me's Avatar

 
2006 22' Interstate
Normal , Illinois
Join Date: Jan 2009
Posts: 13,563
Might also call the service department where you bought it, they may be able to help you over the phone.

We didn't have the luxury of hookups at the dealer, figured a lot of things out on the road and sometimes with Eric-the-service-guy on the cell phone.

Maggie
__________________
🏡 🚐 Cherish and appreciate those you love. This moment could be your last.🌹🐚❤️
Lily&Me is offline   Reply With Quote
Old 09-23-2011, 07:45 AM   #7
Rivet Master
 
Wingeezer's Avatar
 
2005 30' Classic
Burlington , Ontario
Join Date: Sep 2008
Posts: 2,708
If you have checked that you are getting 12vdc at the pump, and if there is not a problem with the motor itself - which could be the case, I wonder if there might be a problem with the pressure switch (I assume it is built into the pump).

If the switch is not closing when pressure in the system isn't up to the required level, the motor won't see 12v and won't run.

Just a thought.

Brian.
__________________

__________________
Brian & Connie Mitchell

2005 Classic 30'
Hensley Arrow / Centramatics
2008 GMC Sierra SLT 2500HD,4x4,Crew Cab, Diesel, Leer cap.
Wingeezer is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Interstate coach water pump problems solar-guy Sprinter and B-van Forum 10 06-03-2015 03:51 PM
Water pump running with no water! Michigander Fresh Water Systems 11 07-25-2011 04:04 PM
Water pump leaking between head and motor Ezmoneybcs Water Heaters, Filters & Pumps 4 03-20-2011 07:32 AM
Is it a water pump or an electrical problem? Taj MaHaul Water Heaters, Filters & Pumps 7 01-23-2011 08:20 AM
Panel indicator light for water pump and Water heater DJW Water Heaters, Filters & Pumps 3 01-05-2011 08:01 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:23 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.