Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-05-2007, 11:18 AM   #1
moman
 
2004 25' Safari
stuart , Florida
Join Date: Aug 2006
Posts: 4
Water pump

The Sureflow water pump on my 04 Safari keeps running. Its not cycling on & off, but just continues to run. At first I thought it was filling the hot water heater, but I looked at the see-through part of the pump & its only half filled. Any help would be welcomed.
eddie
__________________

__________________
moman is offline   Reply With Quote
Old 05-05-2007, 12:43 PM   #2
3 Rivet Member
 
Killo1's Avatar
 
2005 22' Safari
Santa Ana , California
Join Date: May 2006
Posts: 167
Quote:
Originally Posted by moman
The Sureflow water pump on my 04 Safari keeps running. Its not cycling on & off, but just continues to run. At first I thought it was filling the hot water heater, but I looked at the see-through part of the pump & its only half filled. Any help would be welcomed.
eddie
Sounds like what happened to me when I ran out of water. Try checking your water level.
__________________

__________________
Alan
2005 22ft Safari
2003 Chevrolet Suburban Z71 5.3l
"Life is like a box of chocolates..." Forrest Gump
Killo1 is offline   Reply With Quote
Old 05-05-2007, 12:56 PM   #3
4 Rivet Member
 
2007 25' Safari FB SE
Blaine , Washington
Join Date: Jan 2007
Posts: 291
Have you checked for leaks in the system? Start by looking in the toilet bowl.

John
__________________
Relentless is offline   Reply With Quote
Old 05-05-2007, 01:43 PM   #4
Rivet Master
 
2002 19' Bambi
Lafayette , California
Join Date: May 2005
Posts: 708
The other suggested reasons for the water pump to keep running are good ones. There are a couple more. Air in the system is one. Another is if the pump, due to some mechanical problem, is unable to bring the water pressure up to its automatic shutoff level. The latter can be checked by turning the pump off and then hooking up to external, well-pressured water so that the RV's water system is at a pressure higher than the pump's shutoff pressure. Then turn off the external water and turn the pump on. If it does not start running again, open a tap until the pump does run, turn off the tap, and see if the pump continues to run on. If so, the pump could well be faulty. Obviously, we have had this experience!
__________________
Tim A. is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pump not working... Chuck Water Heaters, Filters & Pumps 23 05-16-2007 10:44 AM
Water Leak jcanavera Leaks - Weatherstrips, Gaskets, Caulks & Sealants 9 06-03-2005 09:28 AM
1978 Minuet 6.0 Metre Gray Water Tank overlander64 All Argosy Trailers 6 11-15-2002 07:11 AM
Water Drip uwe Fresh Water Systems 6 07-11-2002 09:39 AM
Water filter system 53flyingcloud Our Community 2 07-05-2002 05:43 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:26 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.