Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-23-2011, 02:27 PM   #1
New Member
 
2007 19' Safari
lakeville , Minnesota
Join Date: May 2011
Posts: 3
Water heater quits running

I have an atwood water heater in my 2007 19' safari after not using for a week or more when I start it it shuts down after about 10 minutes. After restarting a number of times it will finally kick in and run without problem. Anyway to get it to work correctly on first try?
__________________

__________________
2007 safari is offline   Reply With Quote
Old 10-23-2011, 04:05 PM   #2
Rivet Master
Commercial Member
 
lewster's Avatar
 
Vintage Kin Owner
Naples, FL , Hood River, OR
Join Date: Dec 2005
Posts: 7,279
Quote:
Originally Posted by 2007 safari View Post
I have an atwood water heater in my 2007 19' safari after not using for a week or more when I start it it shuts down after about 10 minutes. After restarting a number of times it will finally kick in and run without problem. Anyway to get it to work correctly on first try?
Could be one of 3 things:

Thermostat
ECO (energy cut-off, the little thing with the bent wire encased in a plastic tube)
Igniter board.

Difficult to say without being there when it fails.

At the failure point, test for continuity at the ECO and t/stat. If they are both OK, it's the igniter board. Replace with a Dinosaur UIB-S board and you're good to go.
__________________

__________________
Lew Farber...ABYC Certified Master Marine Electrician...RVIA Certified Master Tech ...AM Solar Authorized Installation Center...AIRSTREAM Solar & Electrical Specialist...Micro Air 'Easy Start' Sales and Installations
lewster is offline   Reply With Quote
Old 10-23-2011, 05:40 PM   #3
2 Rivet Member
 
2012 25' FB International
Evanston , Illinois
Join Date: May 2007
Posts: 99
Images: 5
We had the same problem. It turned out that the connector that attached several wires to the circuit board was loose. I simply unplugged the connector from the board and replugged it. Problem solved!!!
__________________
Hi-Ho Silver!!
JerryMcMunn is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacing Water Heater in Argosy 24ft '75 HELP!! eyelashsoup Water Heaters, Filters & Pumps 10 08-23-2011 08:56 PM
Atwood water heater fast cycling Skater Water Heaters, Filters & Pumps 4 07-22-2011 08:02 PM
Water heater won't lite aswbe Water Heaters, Filters & Pumps 6 06-06-2011 10:18 PM
Water Heater Calcium Deposits -- What to do? Wilmington Water Heaters, Filters & Pumps 7 05-18-2011 04:11 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:08 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.