Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-31-2010, 08:04 PM   #1
Rivet Master
 
silverback's Avatar
 
2006 28' Safari SE
Currently Looking...
Sierra Vista , United States
Join Date: Jun 2003
Posts: 702
Trailer Atwood Water Heater not working?

First, here's what happened today. I noticed water dripping from the street side wheel well and upon investigation it looked like the pressure reducer valve was leaking. We unscrewed the city water hookup and from the outside and looked closer and indeed the SUREflo pressure reducer was leaking (and because it is a holiday I couldn't get a new pressure reducing valve), especially when the hot water heater was running. I understand now that the water heater really pressurizes the system (possible cause of pressure reducer failure?) up to 140 PSI per the manual. Anyway during this troubleshooting the water heater was turned off at the bathroom remote. When it was turned on I noticed that the red light didn't come on. A few hours later I have not heard the water heater start and subsequent on/off sequences still do not have a red light on the remote. Now, the funny thing is we still seem to have plenty of hot water. Maybe I'm imagining the whole thing. I'm pretty sure we're not out of propane but I can't really see a lit pilot either. Any ideas?

Thanks,
Ken
__________________

__________________
4CU Charter Member
silverback is offline   Reply With Quote
Old 05-31-2010, 08:25 PM   #2
Rivet Master
Commercial Member
 
lewster's Avatar
 
Vintage Kin Owner
Naples, FL , Hood River, OR
Join Date: Dec 2005
Posts: 7,279
What model Atwood do you have? Is it an LP only or an LP/120VDC unit. Does it have a pilot or direct spark ignition (DSI)?

These questions make a big difference in troubleshooting.
__________________

__________________
Lew Farber...ABYC Certified Master Marine Electrician...RVIA Certified Master Tech ...AM Solar Authorized Installation Center...AIRSTREAM Solar & Electrical Specialist...Micro Air 'Easy Start' Sales and Installations
lewster is offline   Reply With Quote
Old 06-01-2010, 09:52 AM   #3
Rivet Master
 
silverback's Avatar
 
2006 28' Safari SE
Currently Looking...
Sierra Vista , United States
Join Date: Jun 2003
Posts: 702
Red face False alarm...

My apologies. To many coincidences (systems seemingly not working) yesterday.

Lew,
It is the DSI model and only runs on LP.

Thanks,
Ken
__________________
4CU Charter Member
silverback is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atwood Water Heater wingfoot321 Water Heaters, Filters & Pumps 11 10-05-2010 05:52 AM
Atwood Water Heater Okiegent Water Heaters, Filters & Pumps 1 12-27-2009 04:16 PM
Atwood water heater uwe Water Heaters, Filters & Pumps 5 10-03-2009 02:58 AM
Atwood Water Heater SilverGate Water Heaters, Filters & Pumps 2 04-15-2007 07:00 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:53 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.