Thread Tools Search this Thread Display Modes
Old 12-03-2004, 07:36 AM   #15
2 Rivet Member
Mike76251's Avatar
Join Date: Sep 2003
Posts: 52
I had the same problem and found the ECO had shot.
Mine is a Atwood gas/electric 10 gal model and the first time I used both 120v and gas at the same time the ECO blew.
I called Atwood and asked if there was a higher temp rated ECO avalible and they,of course, said send the water heater back in or take it to a dealer.
Their stance is "make as much as you can off the consumer".
If I had done what they said I would have been out $150+ and the darn ECO would just blow again as soon as I used the 120/gas combo 'cause they only make them to blow at 180 degrees plus or minus 20 DEGREES.

Flame me or not........I bypassed the thing and it has been working great for 5 years..........after all it does have a pressure valve on it.

Mike76251 is offline   Reply With Quote
Old 03-26-2005, 12:56 PM   #16
New Member
Join Date: Nov 2004
Posts: 3
I am back again and I am pleased to say that my pilot light will now stay lit. Thank you all for your help and suggestions. I have not been living in the trailor because I moved into my new house. I winterized the trailor and forgot about it for a few months except for when I had to remove snow off it. Thank God for the Snow Hoe.
I replaced the whole assembly including the thermocouple and pilot supply tubing from Atwood. That did the trick. I am glad that I didn't have to replace the control. That would have been a pain. It seems that the pilot supply has a microscopic pinhole that gets clogged after a while. It cost me about 23 dollars and two trips to Reno.


Mike Callaha is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pilot light in Frig niftypkg Refrigerators 9 04-10-2005 12:04 PM
Ref pilot Dbraw Refrigerators 2 08-27-2002 04:43 PM
Where to stay - Berkeley, CA pjtaia On The Road... 2 08-17-2002 11:56 AM
Furnace won't light /stay lit Don Furnaces, Heaters, Fireplaces & Air Conditioning 9 06-29-2002 03:37 AM
Clearance light wiring Bob Evans Lights - Interior & Exterior 6 05-27-2002 11:03 AM

Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:32 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.