Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-07-2010, 11:39 AM   #1
3 Rivet Member
 
PhiDor's Avatar
 
2007 34' Classic S/O
The Villages , Florida
Join Date: Dec 2005
Posts: 119
Black tank flush

The black tank flush on my 94 Excella is not working. Any thoughts on how to get it working? Could it be the vacuum breaker or check valve needs replacing?
__________________

__________________
Phil & Doris Drugge
[COLOR="Red"]WBCCI #4941

"Jerry and our Amazing Dream Stream"
PhiDor is offline   Reply With Quote
Old 09-15-2010, 11:10 PM   #2
2 Rivet Member
 
DesertStream's Avatar
 
2008 30' Classic
Montrose , Colorado
Join Date: May 2007
Posts: 33
Images: 10
Did you ever figure this out? We are purchasing a 1994 30' Limited with the same problem.
__________________

__________________
-Virgil and Sheila

It is not down in any map; true places never are. ~Herman Melville
DesertStream is offline   Reply With Quote
Old 09-15-2010, 11:47 PM   #3
3 Rivet Member
 
2007 25' Safari FB SE
Eureka Springs , Arkansas
Join Date: Oct 2009
Posts: 177
Mine is not working either.
Acts like a valve is closed, no water gets thru system.
Bob
__________________
triplenet is offline   Reply With Quote
Old 09-16-2010, 12:32 AM   #4
Rivet Master
 
SilverGate's Avatar

 
2007 23' Safari SE
San Diego , California
Join Date: Apr 2006
Posts: 1,490
Whenever I see a thread about black tank flush problems, I think back to the thread, "Black Tank Flush" started by JmesDean in 2006.

When he attached the water hose and turned on the water, he heard a "pop". He thought something popped off and reduced his water pressure. One possibility is that if you attach a hose and turn on the water with too high pressure you might damage the check valve or something else in this "No-fuss flushing system".

So whenever I attach a water hose to my black tank flushing system, I feel the hose as I gradually increase the water pressure to the point where I can see that it is adequately flushing the tank without blasting out the system.
__________________
SilverGate is offline   Reply With Quote
Old 09-17-2010, 09:58 AM   #5
3 Rivet Member
 
PhiDor's Avatar
 
2007 34' Classic S/O
The Villages , Florida
Join Date: Dec 2005
Posts: 119
Smile Need more info

It seems like many of us have this problem. Now if we could figure out how to fix it.....
__________________
Phil & Doris Drugge
[COLOR="Red"]WBCCI #4941

"Jerry and our Amazing Dream Stream"
PhiDor is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Black tank flush uh-oh silversnail 2007 Safari SE 7 07-26-2010 08:48 AM
Black Tank Flush JmesDean Waste Systems, Tanks & Totes 34 04-03-2006 05:34 PM
Black Tank Flush Repair AirMax Waste Systems, Tanks & Totes 2 08-26-2005 02:05 PM
Black tank flush.... drboyd Waste Systems, Tanks & Totes 11 08-01-2003 08:40 AM
Black Tank Flush System Ed & Nancy Our Community 6 02-19-2003 09:36 AM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:35 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.