Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-22-2014, 11:25 AM   #43
3 Rivet Member
 
mtbguy's Avatar
 
Dunwoody , Georgia
Join Date: Nov 2012
Posts: 153
I am reading this thread trying to figure out if my Regulator has gone bad. I winterized system last month before a hard freeze that lasted a week. I drained the lines pretty well, but did not drain metal Watts (original factory installed) regulator.

When we went camping this weekend, I filled my fresh water tank and when I turned on the pump, water shot out the side of the trailer where city water hooks up (relief valve I guess). I then hooked up city water to that pipe and used it and the water system worked fine. I forgot to recheck the valve before leaving campsite to see if valve was still stuck open.

Could a hard freeze have ruined the valve, or do they sometime just randomly get stuck?

Thanks

Rick
__________________

__________________
mtbguy is offline   Reply With Quote
Old 01-22-2014, 11:29 AM   #44
Figment of My Imagination
 
Protagonist's Avatar
 
2012 Interstate Coach
From All Over , More Than Anywhere Else
Join Date: Dec 2011
Posts: 10,300
Quote:
Originally Posted by mtbguy View Post
I am reading this thread trying to figure out if my Regulator has gone bad. I winterized system last month before a hard freeze that lasted a week. I drained the lines pretty well, but did not drain metal Watts (original factory installed) regulator.

When we went camping this weekend, I filled my fresh water tank and when I turned on the pump, water shot out the side of the trailer where city water hooks up (relief valve I guess). I then hooked up city water to that pipe and used it and the water system worked fine. I forgot to recheck the valve before leaving campsite to see if valve was still stuck open.

Could a hard freeze have ruined the valve, or do they sometime just randomly get stuck?

Thanks

Rick
Not the regulator. The check valve, which is supposed to prevent backflow, isn't preventing backflow anymore.
__________________

__________________
WBCCI #1105
TAC LA-4

My Google-Fu is strong today.
Protagonist is offline   Reply With Quote
Old 01-22-2014, 11:44 AM   #45
Moderator
 
DKB_SATX's Avatar

 
2017 26' Flying Cloud
1976 Argosy 28
Alamo Heights , Texas
Join Date: Aug 2006
Posts: 6,401
Images: 1
Blog Entries: 7
Quote:
Originally Posted by mtbguy View Post
I am reading this thread trying to figure out if my Regulator has gone bad. I winterized system last month before a hard freeze that lasted a week. I drained the lines pretty well, but did not drain metal Watts (original factory installed) regulator.

When we went camping this weekend, I filled my fresh water tank and when I turned on the pump, water shot out the side of the trailer where city water hooks up (relief valve I guess). I then hooked up city water to that pipe and used it and the water system worked fine. I forgot to recheck the valve before leaving campsite to see if valve was still stuck open.

Could a hard freeze have ruined the valve, or do they sometime just randomly get stuck?

Thanks

Rick
For a quick fix, if your checkvalve is still sticking open, you can put garden-hose style valve like this Orbit one or this Dramm one. I use one like the Orbit one (from Lowe's or Home Depot) when I discovered the same problem with my '75 Argosy after I fixed a leak in the tank and pressurized the system with the pump the first time instead of hooking up to city water.

It's not automatic, but it's been working for me for 2 years so far.
__________________
David

Zero Gravitas 2017 Flying Cloud 26U | Il Progetto 1976 Argosy 28 Center Bath | WBCCI# 15566

He has all of the virtues I dislike and none of the vices I admire. Sir Winston Churchill
DKB_SATX is offline   Reply With Quote
Old 01-23-2014, 07:06 AM   #46
3 Rivet Member
 
mtbguy's Avatar
 
Dunwoody , Georgia
Join Date: Nov 2012
Posts: 153
I found an extra check valve in a box of random parts previous owner gave me. Will install it, (there is not one in system). Previous owners removed some of the copper pipes, I replaced all with PEX so it looks like I need that valve in place.

I also will use the part that DKB SATX recommends for now. Thanks guys!
__________________

__________________
mtbguy is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:27 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.