Thread Tools Search this Thread Display Modes
Old 10-06-2010, 08:56 PM   #1
3 Rivet Member
mhilley's Avatar
2000 23' Safari
Vero Beach , Florida
Join Date: Jul 2010
Posts: 180
Tank monitor system on the fritz

I am having a problem with my tank monitor indicator gizmo. The fresh water tank always shows empty, the grey shows half full and the black shows empty regardless of their actual level. The battery monitor lights seem to show correctly. I have tried to recalibate by using the manual that came with the trailer to no avail. Like when my computer fails, I tried kicking the indicator panel (very difficult reach!) but it didn't help either. Does anyone have any suggestions? It is a 2006 model with the newer panel. Thanks in advance.

mhilley is offline   Reply With Quote
Old 10-06-2010, 09:25 PM   #2
. , .
Join Date: Dec 2004
Posts: 8,812
hi 'hilley

contact the manufacture of the sensors and display.

sometimes the display is faulty and often the tank sensors go wacky...

the company has been pretty good about replacing sensors OR the display under warranty...

as i recall these bits are covered for 5 years.

replacing the display isn't difficult....

the tank sensors are easy to replace (screw in, plug in wire) AFTER gaining access to them.

IF MP is given the model/size stream, the display unit can be sent out PREcalibrated...

which seems like a great idea and time saver, IF the calibration works.

the PRE settings didn't help in my unit, so i still had to run through the REcal' process.

several times


all of the true things that i am about to tell you are shameless lies. l.b.j.

we are here on earth to fart around. don't let anybody tell you any different. k.v.
2airishuman is offline   Reply With Quote
Old 10-06-2010, 10:55 PM   #3
3 Rivet Member
JDL's Avatar
2005 19' International CCD
T , Oregon
Join Date: Oct 2005
Posts: 197
Hello mhilley,

I also had issues with mine at first. I was able to recalibrate. It took a few times but I finally got it . It becomes easier after you do it a few times.

Realize that the sensors are temperature sensitive. So if you are in a warm environment they will indicate higher levels than in a cold environment.

I also had to replace my panel. You might want to give Steve at Catcon a call. He is the manufacturer. Very nice guy.

CATCON Products | Home
JDL is offline   Reply With Quote
Old 10-07-2010, 06:13 AM   #4
4 Rivet Member
2008 16' Safari
Destrehan , Louisiana
Join Date: May 2009
Posts: 395
Is this the Micro Pulse unit? I've had nothing but trouble with mine. Most problems were with the black water sensor. I finally gave up on the black water sensor and just diconnected it. All other functions have worked since then.
dlb435 is offline   Reply With Quote
Old 08-31-2011, 10:14 AM   #5
North Providence , Rhode Island
Join Date: Aug 2007
Posts: 44
Black water on micro pulse sensor panel just started blinking red all the time. Other sensors appear ok. Have had this 2008 International 2 years and use it nearly 5 months per year full time. Any thoughts?
mok is offline   Reply With Quote
Old 09-01-2011, 05:05 PM   #6
3 Rivet Member
mhilley's Avatar
2000 23' Safari
Vero Beach , Florida
Join Date: Jul 2010
Posts: 180
Yup, either sensor is bad or telephone type connection is bad.. Black water sensor is easy to replace. Clean connection first.
mhilley is offline   Reply With Quote
Old 09-10-2011, 01:19 PM   #7
3 Rivet Member
billberk's Avatar
2007 20' Safari SE
Springfield , Missouri
Join Date: Jun 2007
Posts: 218
I gave up after most of the day trying to recalibrate my Micro Pulse. It acted like it was doing it's thing according to the manual but still didn't read grey or black tanks after I was finished. Fresh sensor started blinking red almost as soon as I turned on water.

How do you tell if it's a sensor or the panel that's bad?
billberk is offline   Reply With Quote
Old 11-27-2011, 08:57 AM   #8
1 Rivet Member
2008 19' Bambi
Miami , Florida
Join Date: Feb 2008
Posts: 13
Closing wardrobe makes lights flash then off

Had a wonderful Thanksgiving with the family in our 2008 Bambi. I noticed the sensor lights were completely off. Strange since that is one of my "jobs" once we get to our campsite. It was on, turned it off and back on, felt a little warn. Started to go thru normal calibration then they all flashed and went off. Looked in wardrobe to see of anything was going on. Closed door and lights went back on. Thoughts? Maybe lose connection? We did have to recalibrate black tank about a year ago, but has been fine since.

MamaTRC is offline   Reply With Quote

quite diffucult reach)

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tank Monitor replacement - digital Zeppelinium Fresh Water Systems 63 04-11-2015 06:32 AM
Micro Pulse Tank monitor calibration Silvertwinkie Plumbing - Systems & Fixtures 98 11-03-2014 01:09 PM
looking for tank monitor replacement parts rec Plumbing - Systems & Fixtures 3 08-04-2008 08:18 AM
Upgrade to a new system monitor? GoNomad Electrical - Systems, Generators, Batteries & Solar 7 10-27-2006 07:02 AM
Tank Monitor Help pmclemore Electrical - Systems, Generators, Batteries & Solar 4 01-31-2006 12:41 PM

Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:36 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.