Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-24-2015, 08:06 AM   #29
1 Rivet Member
 
1968 28' Ambassador
Mckinney , Texas
Join Date: Aug 2014
Posts: 19
Bringing this topic back seeing if anyone has solved the cyclo haze issue. I've been polishing mine forever and looks amazing till I use the cyclo with nuvite s. It leaves a haze or the polish mud still sticks in the tiny pitting from the horrible oxidation I had. Any advice is greatly appreciated my ocd for perfect finish is going to kill me on this project
__________________

__________________
Smokincj5 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cloudy finish bwaysteve Cleaning, Stripping & Polishing 2 06-01-2010 09:33 PM
Can't get rid of Cloudy alu on a 1961 Safari mscott Cleaning, Stripping & Polishing 5 07-13-2007 11:02 PM
When is a Cyclo not a Cyclo? RichardT Cleaning, Stripping & Polishing 11 01-29-2006 04:05 PM
Compounding -just cloudy, not shiny--help! Bobo12 Cleaning, Stripping & Polishing 6 07-24-2005 03:57 PM
cloudy water maznblu Fresh Water Systems 2 07-27-2003 10:51 AM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:35 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.