Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-10-2012, 06:11 AM   #1
1 Rivet Member
 
1994 34' Limited
Oakland Twp. , Michigan
Join Date: Jan 2012
Posts: 10
radio not working

Hello to all. I am a newby, my radio has been working, but now that I have unhooked the batteries and my kids have probably hit the converter shutoff switch, I cannot seem to get it to come back on. Help
__________________

__________________
Hardenburgh is offline   Reply With Quote
Old 06-10-2012, 06:56 AM   #2
Rivet Master
 
Ganglin's Avatar
 
1971 27' Overlander
Central , Ohio
Join Date: Jun 2006
Posts: 2,365
Images: 13
Check the fuse behind the radio in the power line. It may have blown. Ours does that sometimes after sitting several weeks without use. My fuse never blows but unhooking the fuse line for a few seconds seems to reset it.
__________________
Ganglin is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:08 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.