Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-12-2012, 10:40 AM   #1
2 Rivet Member
 
AirEPotter's Avatar
 
2011 27 FB International
Lubbock , Texas
Join Date: Nov 2010
Posts: 65
Help! On the road and fridge isn't cooling

Between Texas and New Mexico and fridge isn't cooling. Two year old Dometic fridge. I have good power (fuse is good and Led display is working). Last night plugged into shore power on "auto" fridge setting and this morning fridge was 57. Switched it to LP and still isnt cooling. Full bottle of gas so that's not issue. What's weird is that even plugged into shore power and setting on "auto", the display still has LP light on. It's never done this before. Not sure how that factors in. Any help would be appreciated as theres no RV repair anywhere around. I apologize for cryptic post but I'm doing this from a cell phone. Thanks.
__________________

__________________
AirEPotter is offline   Reply With Quote
Old 03-12-2012, 10:43 AM   #2
65th Anniversary CLIPPER
 
masseyfarm's Avatar

 
1996 36' Clipper Bus
Tub City , British Columbia
Join Date: May 2009
Posts: 3,271
Images: 55
Try disconnecting the power, (shut fridge off) for a few minutes and then try again to see if panel display is correct.

LPG should be the most efficient energy for the fridge, but will take some time to cool this style of fridge.

Dave
__________________

__________________
masseyfarm is offline   Reply With Quote
Old 03-12-2012, 10:48 AM   #3
Rivet Master
 
1974 Argosy 20
2014 20' Flying Cloud
Kooskia , Idaho
Join Date: Jul 2009
Posts: 4,591
Also, if you still have campground power, be sure that you are getting power to the refrigerator outlet. When the light stays on LP it could be not switching due to lack of 120 volt power, but that does not explain the lack of cooling on LP.
__________________
idroba is offline   Reply With Quote
Old 03-12-2012, 10:54 AM   #4
Rivet Master
 
1974 Argosy 20
2014 20' Flying Cloud
Kooskia , Idaho
Join Date: Jul 2009
Posts: 4,591
Also, remember that it takes a couple of hours to notice that the cooling is working, once you make a switch over. RV refrigerators are slow to cool.

If you can, check to see that the "chimney" (about a 4" diameter tube on the right side from the back) is warm or hot. If not, something is not working. Can you see a flame when on propane?

Just things to look for and report back.
__________________
idroba is offline   Reply With Quote
Old 03-12-2012, 10:59 AM   #5
Rivet Master
 
TouringDan's Avatar

 
1966 24' Tradewind
1995 34' Excella
Lynchburg , Virginia
Join Date: Sep 2009
Posts: 2,471
Bummer. What model number is the fridge?

Is there a rear access panel? If so, remove this and see if the chimney is hot. If it is working the chimney will be hot either from the propane burning or the electrical element heating.

Dan
__________________
TouringDan is offline   Reply With Quote
Old 03-12-2012, 12:05 PM   #6
2 Rivet Member
 
AirEPotter's Avatar
 
2011 27 FB International
Lubbock , Texas
Join Date: Nov 2010
Posts: 65
Thanks for all the quick responses. This site never ceases to amaze me with all the friendly and helpful people. Good news is it seems to have healed itself!! Its now down to 45. My guess is the power off back on did the trick. Thanks again.
__________________
AirEPotter is offline   Reply With Quote
Old 03-12-2012, 06:58 PM   #7
2 Rivet Member
 
AirEPotter's Avatar
 
2011 27 FB International
Lubbock , Texas
Join Date: Nov 2010
Posts: 65
Ok, the plot thickens. Just pulled into the RV Park in Taos and for some reason even when I'm hooked to shore power my trailer is not powered. I'm plugged to 30amp but no power to any outlets inside. I'm certain there is power to the outside because my 30amp plug has a blue light and it's on. What would cause there to be no power to outlets? In sure its something simple. Help please?
__________________
AirEPotter is offline   Reply With Quote
Old 03-12-2012, 07:02 PM   #8
Rivet Master
 
1974 Argosy 20
2014 20' Flying Cloud
Kooskia , Idaho
Join Date: Jul 2009
Posts: 4,591
Have you checked the circuit breakers inside the trailer to be sure they are all on?
__________________
idroba is offline   Reply With Quote
Old 03-12-2012, 07:22 PM   #9
2 Rivet Member
 
AirEPotter's Avatar
 
2011 27 FB International
Lubbock , Texas
Join Date: Nov 2010
Posts: 65
it was a breaker. Thanks.
__________________

__________________
AirEPotter is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Belly skin and Banana Wrap Alloy perryg114 Belly Pans & Banana Wraps 16 03-03-2014 06:12 AM
It's Monday and I love my Airstream because..... THEPILL Off Topic Forum 4 03-13-2012 12:10 AM
Help! On the road and fridge isn't cooling AirEPotter General Repair Forum 8 03-12-2012 07:22 PM
restore emblem-help goshawks00 General Repair Forum 6 03-12-2012 05:23 PM
PINK, VINTAGE and READY! 1967 Concession Airstream Trailer eBay Watch Airstreams on eBay 0 03-12-2012 03:40 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:04 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.