Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-23-2014, 06:16 PM   #1
2 Rivet Member
 
Currently Looking...
Longview , Texas
Join Date: Mar 2013
Posts: 41
2014 EB tail lights not working

Hi all. Click image for larger version

Name:	ImageUploadedByAirstream Forums1411513769.301591.jpg
Views:	100
Size:	598.4 KB
ID:	222674Click image for larger version

Name:	ImageUploadedByAirstream Forums1411513784.897437.jpg
Views:	89
Size:	583.0 KB
ID:	222675Click image for larger version

Name:	ImageUploadedByAirstream Forums1411513799.088361.jpg
Views:	104
Size:	754.3 KB
ID:	222676

See the pics below..first and 2nd pic is just with the tail lights turned on. They were taken just a few minutes apart. 3rd pic is with the brake pedal depressed. Definitely a problem somewhere.

I removed the 4 screws in the housing but could not get it off to get to the tail lights.

I know these use just a modular plugin so if I could get the housing off, I think I can install the lights myself.

Any advice on how to repair would be greatly appreciated.

I know this would be covered under warranty but it's a 3 hour drive and they always keep my AS for at least 3 weeks


Sent from my iPad using Airstream Forums
__________________

__________________
Aggie90 is offline   Reply With Quote
Old 09-23-2014, 06:22 PM   #2
3 Rivet Member
Commercial Member
 
Greg@AirLA's Avatar
 
1960 24' Tradewind
Riverside , United States
Join Date: Feb 2007
Posts: 112
The chrome ring just snaps off exposing screws holding the light assembly to the cast housing.

Greg
__________________

__________________
Greg Paulsen
Greg@AirLA is offline   Reply With Quote
Old 09-23-2014, 07:15 PM   #3
2 Rivet Member
 
Currently Looking...
Longview , Texas
Join Date: Mar 2013
Posts: 41
So Greg. I should "force" the housing off and it will not hurt anything?


Sent from my iPad using Airstream Forums
__________________
Aggie90 is offline   Reply With Quote
Old 09-24-2014, 06:34 PM   #4
2 Rivet Member
 
2011 23' FB Flying Cloud
2008 19' Safari SE
Brossard , Quebec
Join Date: Jan 2013
Posts: 65
Additional information required

Quote:
Originally Posted by Greg@AirLA View Post
The chrome ring just snaps off exposing screws holding the light assembly to the cast housing.

Greg
It is possible to get a picture of the back of the chrome ring to understand the proper way to remove it.
Should I use a small screwdriver or a small scraper?
The picture will guide me where I have to put pressure with the proper tool at the back of the ring.

Many thanks

Michel
__________________
Papou is offline   Reply With Quote
Old 09-24-2014, 06:37 PM   #5
3 Rivet Member
Commercial Member
 
Greg@AirLA's Avatar
 
1960 24' Tradewind
Riverside , United States
Join Date: Feb 2007
Posts: 112
We just us a stiff plastic scraper so's not to scratch the aluminum.

Greg
__________________
Greg Paulsen
Greg@AirLA is offline   Reply With Quote
Old 09-24-2014, 06:49 PM   #6
3 Rivet Member
Commercial Member
 
Greg@AirLA's Avatar
 
1960 24' Tradewind
Riverside , United States
Join Date: Feb 2007
Posts: 112
Click image for larger version

Name:	light.jpg
Views:	92
Size:	41.6 KB
ID:	222777 Hope this works
__________________
Greg Paulsen
Greg@AirLA is offline   Reply With Quote
Old 09-24-2014, 07:44 PM   #7
2 Rivet Member
 
2011 23' FB Flying Cloud
2008 19' Safari SE
Brossard , Quebec
Join Date: Jan 2013
Posts: 65
Dear Greg,
Many thanks for these pictures. You "save my life" and prevent damage on these plastic covers!
The cast housing (both of them) suffer of bad clear coating. My dealer send me 2 new ones to replace but I was scary to break the plastic covers.

Michel
__________________
Papou is offline   Reply With Quote
Old 10-12-2014, 09:33 AM   #8
TahoeStream'n
 
subfan1's Avatar
 
2012 20' Flying Cloud
La Habra , California
Join Date: Jul 2007
Posts: 832
Images: 3
Hi Greg, we bought our 2012 20ft FC from you in May of 2012 when you opened. Our plastic chrome tail light rings are becoming discolored. Do you have 4 in stock so I can replace them?
Thanks, BTW the solar panel you installed works great!


Sent from my iPhone using Airstream Forums
__________________

__________________
subfan1 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Leak near tail light, but it's not the tail light adwriter73 Leaks - Weatherstrips, Gaskets, Caulks & Sealants 7 03-31-2013 12:34 PM
1976 Argosy 28 Brake lights, turn signals, running lights not working!!! Argosy1976 Batteries, Univolts, Converters & Inverters 6 06-22-2012 06:20 AM
Tail lights, brake lights, turn signals on '75 22' mendosoft All Argosy Trailers 3 06-01-2008 09:46 PM
Tail, running, clearance lights not working dufferin Lights - Interior & Exterior 14 07-09-2007 02:53 PM
Tail Lights Stopped Working dpope 2003 Safari 8 04-05-2003 01:22 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:15 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.