Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-28-2015, 06:03 PM   #1
1 Rivet Member
 
1976 31' Sovereign
Lost somewhere in , Canada
Join Date: Jul 2015
Posts: 11
Brake magnets all dead?

Hey folks,

I just picked up a 76 sovereign. In going over the wiring a noticed that it did not have a breakaway switch at all. Then in testing the brakes I'm finding that the brake magnets all seem to be dead?

Is this common? I've tested the brakes with the battery wired direct to each brake (not solid wired of course) and none of the magnets will engage.

After hub removal the magnet wont even hold a screw driver when power applied.

Thanks
Chris
__________________

__________________
quicker is offline   Reply With Quote
Old 07-28-2015, 06:16 PM   #2
Rivet Master
 
AWCHIEF's Avatar
 
2006 23' Safari SE
Biloxi , Mississippi
Join Date: Nov 2011
Posts: 8,138
Images: 33
When I got my 64 Bambi II. Same problem. I was getting a new axle, hubs and brakes anyway so no big deal. Foley Airstream totally rewired the brake system and installed a brake away switch.
__________________

__________________
MICHAEL

Do you know what a learning experience is? A learning experience is one of those things that says "You know that thing that you just did? Don't do that."
AWCHIEF is offline   Reply With Quote
Old 07-28-2015, 06:32 PM   #3
Rivet Master
 
bwoodtx's Avatar
 
1997 30' Excella
1961 26' Overlander
1954 22' Flying Cloud
1981 28' Airstream 280
San Antonio , Texas
Join Date: Jul 2009
Posts: 1,365
If you have supplied 12v and the magnets are not energizing then they are bad. Install a new breakaway switch, new magnets and go on for a temp fix if you are getting a new axle which probably needed. Magnets are around $25ea and breakaway switch about $20.
__________________
Bruce
WBCCI# 9259 AIR# 38927 TAC-TX 14
Stop Littering-Spay & Neuter-- Adopt From Rescue
He is your friend, your partner, your defender, your dog. You owe it to him to be worthy of such devotion.
bwoodtx is offline   Reply With Quote
Old 07-28-2015, 06:34 PM   #4
1 Rivet Member
 
1976 31' Sovereign
Lost somewhere in , Canada
Join Date: Jul 2015
Posts: 11
thanks guys. new breakaway already installed. Getting magnets tomorrow. Do the new oval magnets fit right in even though the center hole is no longer round in the magnet like mine are?

Yes planning on new axles this winter so just trying to go temp fix for now.

Thanks
__________________
quicker is offline   Reply With Quote
Old 07-28-2015, 07:10 PM   #5
Rivet Master
 
bwoodtx's Avatar
 
1997 30' Excella
1961 26' Overlander
1954 22' Flying Cloud
1981 28' Airstream 280
San Antonio , Texas
Join Date: Jul 2009
Posts: 1,365
Yes, that is correct. Take some emory cloth(sandpaper and clean the rust/dirt off the inside of the brake drum. Check your wiring-older trailers will not match up with today's connectors. Diagrams are available on here if you do a search.
__________________
Bruce
WBCCI# 9259 AIR# 38927 TAC-TX 14
Stop Littering-Spay & Neuter-- Adopt From Rescue
He is your friend, your partner, your defender, your dog. You owe it to him to be worthy of such devotion.
bwoodtx is offline   Reply With Quote
Old 07-28-2015, 07:11 PM   #6
Rivet Master
 
bwoodtx's Avatar
 
1997 30' Excella
1961 26' Overlander
1954 22' Flying Cloud
1981 28' Airstream 280
San Antonio , Texas
Join Date: Jul 2009
Posts: 1,365
Oh and welcome to the forums and airstreaming.
__________________
Bruce
WBCCI# 9259 AIR# 38927 TAC-TX 14
Stop Littering-Spay & Neuter-- Adopt From Rescue
He is your friend, your partner, your defender, your dog. You owe it to him to be worthy of such devotion.
bwoodtx is offline   Reply With Quote
Old 07-28-2015, 09:24 PM   #7
1 Rivet Member
 
1976 31' Sovereign
Lost somewhere in , Canada
Join Date: Jul 2015
Posts: 11
Quote:
Originally Posted by bwoodtx View Post
Oh and welcome to the forums and airstreaming.
Thanks. All re-wired to new configuration.
__________________
quicker is offline   Reply With Quote
Old 07-28-2015, 10:06 PM   #8
2 Rivet Member
 
AlbertaBound's Avatar
 
1975 Argosy 28
1975 Argosy 22
1978 Argosy Minuet 6.0 Metre
Camrose , Alberta
Join Date: Aug 2013
Posts: 74
i had the same issue with my 1975 argosy. the magnets seemed dead until you spun the drum and then they grabbed right away. doesn't really make much sense to me but stops the trailer fine.
__________________
AlbertaBound is offline   Reply With Quote
Old 08-24-2015, 08:38 PM   #9
3 Rivet Member
 
joqin's Avatar
 
1965 17' Caravel
brooklyn park , Minnesota
Join Date: Jan 2007
Posts: 121
brake wiring

thanks for noting that vintage plug wiring is different than modern setups! I had problems because when I changed my trailer plug wiring to match a 2006 suv plug, I had problems in both running lites and brakes. I had to go under the 65 caravel, take off a small panel and match the wire to the function . the biggest problem is that the brake wires are YELLOW IN THE FRONT OF THE TRAILER AND GREEN GOING INTO THE REAR BRAKES! the BLACK WIRE turned out to be the back-up lites. When I tried to find out if the charge line was the LITE BLUE WIRE OR THE DARK BLUE WIRE, I traced them to to the jumble of wires inside that passes for the conjuntion box and found that the factory had carefully painted them ALL zolatone white!!
other than that, everything works fine. joe in minnesnowda
__________________
joqin is offline   Reply With Quote
Old 08-24-2015, 09:11 PM   #10
Rivet Master
 
1974 Argosy 20
2014 20' Flying Cloud
Kooskia , Idaho
Join Date: Jul 2009
Posts: 4,591
Ah, the joys of working on an old Airstream. Factory funny's or PO fun or just plain different. Glad you got it worked out.
__________________

__________________
idroba is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Testing brake magnets goshawks00 Brakes & Brake Controllers 2 11-21-2011 08:48 AM
Brake magnets kingfisher24 Brakes & Brake Controllers 11 05-18-2011 11:22 AM
Brake magnets 1976 Sovereign Splitrock Brakes & Brake Controllers 2 07-31-2010 02:29 PM
Grease on brake magnets lbrodsky Brakes & Brake Controllers 43 11-25-2006 08:06 PM
Need a couple of old brake magnets Excella CM Brakes & Brake Controllers 1 07-02-2006 08:47 AM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:45 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.