Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-22-2013, 11:57 AM   #1
1 Rivet Member
 
gatewaygrip's Avatar
 
1963 28' Ambassador
1967 26' Overlander
St. Louis , Missouri
Join Date: Oct 2012
Posts: 16
Images: 7
Brake Controller

I'm having issues with my install of a P-3 brake control. When I first hook up to my AS, no problems until I mess with the manual lever or brake pedal. When I step on the brakes the AS brake lights go out. After checking functions and trying to test the brakes to see if they even work, brake control loses connection (no trailer warning).

Is this issue due to wrong wiring in the trailer or faulty brake control?
__________________

__________________
gatewaygrip is offline   Reply With Quote
Old 03-22-2013, 12:05 PM   #2
Wise Elder
 
Jammer's Avatar
 
2010 30' Classic
Vintage Kin Owner
South of the river , Minnesota
Join Date: Dec 2009
Posts: 4,119
Probably wiring. Unplug the P-3 and be sure all the trailer circuits work the way they should without it, and then be sure that the wires to the p-3 are properly connected - not mixed up with each other.
__________________
To learn to see below the surface, you must adjust your altitude
Jammer is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:39 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.