Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-19-2009, 03:55 PM   #1
Rivet Master
 
mustang's Avatar
 
1986 31' Sovereign
Kent , Ohio
Join Date: May 2006
Posts: 803
Sububan Furnace trouble, and more.

Hello.

I just purchased a 1986 31 ft soverign. The gentlmen I purchased it from didnt have it very long. He knows as much about it as I do at this point.

Here are my questions regarding the furnace. 1st, it is a Suburban model NF-30 S Serial # 1684167. I am assumeing it is original. I have always had vintage stuff so this electronic era of stuff has me a bit lost.

I simply cannot get this to work. I turn on the gas, turn on the switch under the thermostat, in the bedroom, then turn up the temp. Nothing.
Ussually when the temp is turned up, as the mercury switch makes contact, there is a spark. That is not happening so I am thinking no power to the thermostat. I cant find the fuses. I found the power supply ( Upfront under the couch) no access door.

My floor plan is a front couch, mid kitchen, curbside bath (USA) rear bedroom. ( full size bed).

I am also assuming that the only switch for the hot water heater is in the bathroom next to the water pump. correct??
__________________

__________________
mustang is offline   Reply With Quote
Old 04-19-2009, 04:16 PM   #2
Rivet Master
 
Tinsel Loaf's Avatar
 
Join Date: Jan 2003
Posts: 790
Does this unit have an electronic ignition? Any fuses should be on the main pcb if you can get to it. Does the furnance have a reset switch you can see? Have you checked if the furnace is getting 12 volts with a meter?
__________________

__________________
Tinsel Loaf is offline   Reply With Quote
Old 04-19-2009, 04:38 PM   #3
Rivet Master
 
HowieE's Avatar
 
1991 34' Excella
Princeton , New Jersey
Join Date: Aug 2003
Posts: 6,811
Images: 12
When you make the thermostat does the furnace fan come on? If so you have 12 volts. If not look for a reason you do not have 12 volts, fuse bad, or bad control board.

If the fan comes on count to 20. If you have not heard the gas valve click open by that time the unit has not lite. A very common problem with furnaces not lighting is air in the line. The pilot valve is so small it will not purge the air and thus the control times out.

To check this crack the flared gas fitting just before the heater enough that you can smell gas. Now tighten the flared nut and retry the heater.

Don't worry about blowing up the neighborhood with the amount of gas you will let out just don't do it with a lite cigarette in your mouth.
__________________
WBCCI 12156 AIR 3144 WACHUNG TAC NJ6
2004 Excursion 4x4
1991 34 ft. Excella +220,000 miles, new laminated flooring, new upholstery, new 3200 lbs axles

HowieE is offline   Reply With Quote
Old 04-19-2009, 04:42 PM   #4
Rivet Master
 
mustang's Avatar
 
1986 31' Sovereign
Kent , Ohio
Join Date: May 2006
Posts: 803
The fan does not come on at all. I am looking for fuses but cant find them. I found circuit breakers in the rear bedroom. They are on. Tanks are full, hot water tank is on and works fine, after I cleaned it up.

I agree, I dont think it is getting voltage. I am searching for fuses, anmd was hoping somebody new where they are at to save me from searching. I am thinking it is electronic, everything else seems to be
__________________
mustang is offline   Reply With Quote
Old 04-19-2009, 04:53 PM   #5
Rivet Master
 
HowieE's Avatar
 
1991 34' Excella
Princeton , New Jersey
Join Date: Aug 2003
Posts: 6,811
Images: 12
The 12 volt fuses will be in the front end of the trailer most often centered below the front window behind the coach back.
__________________
WBCCI 12156 AIR 3144 WACHUNG TAC NJ6
2004 Excursion 4x4
1991 34 ft. Excella +220,000 miles, new laminated flooring, new upholstery, new 3200 lbs axles

HowieE is offline   Reply With Quote
Old 04-19-2009, 05:01 PM   #6
Rivet Master
 
mustang's Avatar
 
1986 31' Sovereign
Kent , Ohio
Join Date: May 2006
Posts: 803
The only thing back there is a master ON / OFF switch, it is on. Under that is the battery compartment, and next to that is what used to be a univolt? It doesnt look like the old ones, maybe it is just simply the power inverter. It has no access door on it.

I do have a NEWTEC gas sensing device, when I turn it on the alarm goes off. BEEEEEEEEEP. It is mounted right by the furnace. I have all the windows open, and even with the trailer buttoned up for days. No smell of gas. Think maybe this thing is malfunctioning, and a override shut off??
__________________
mustang is offline   Reply With Quote
Old 04-19-2009, 05:16 PM   #7
Rivet Master
 
mustang's Avatar
 
1986 31' Sovereign
Kent , Ohio
Join Date: May 2006
Posts: 803
I found it. Thanks Howie. It was right behind the couch, a pad was in front of it, snapped to the wall. It would be to much to ask if they would have labled the circuits, instead they are numbered. My trouble light will let me know though. I am guessing these fuses are set to automatically reset, but they go bad in time.
__________________
mustang is offline   Reply With Quote
Old 04-19-2009, 06:13 PM   #8
Rivet Master

 
1986 31' Sovereign
Miami , Florida
Join Date: Feb 2004
Posts: 1,650
Blog Entries: 13
The switch in the side bath is the only one for the water heater on my Sovereign.

When you open the panel in front of the furnace, work your hand down the right side (as you are looking at it) of the furnace and feel for the plug to make sure it is plugged in tightly. Mine was looose and I had the same symptoms.

mike
__________________
n2916s is offline   Reply With Quote
Old 04-19-2009, 06:18 PM   #9
Rivet Master
 
mustang's Avatar
 
1986 31' Sovereign
Kent , Ohio
Join Date: May 2006
Posts: 803
Well here it is.

The little on/off switch on the thermostat had a coroded contact. I cleaned it up,

And Wala! let there be heat!

Thanks again for the help!!!
__________________
mustang is offline   Reply With Quote
Old 04-19-2009, 06:32 PM   #10
Rivet Master
 
mustang's Avatar
 
1986 31' Sovereign
Kent , Ohio
Join Date: May 2006
Posts: 803
N2916s,

I was wondering, since we have the same trailer. Do you have the NEWTEC device down low by the door that is supposed to alarm if there is a propane leak?

Mine goes off as soon as I turn it on. Where these units any good if you know?
__________________
mustang is offline   Reply With Quote
Old 04-19-2009, 07:55 PM   #11
Rivet Master

 
1986 31' Sovereign
Miami , Florida
Join Date: Feb 2004
Posts: 1,650
Blog Entries: 13
My NEWTEC was dead when I bought the trailer. I replaced it with a Safe Alert 40.

mike
__________________

__________________
n2916s is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
'75 Argosy 22' Sububan Furnace Question uniquemicro Furnaces, Heaters, Fireplaces & Air Conditioning 5 10-21-2008 10:49 AM
trouble with suburban furnace wayne.yl Furnaces, Heaters, Fireplaces & Air Conditioning 10 10-30-2007 12:13 AM
Trouble shooting Furnace/Heat Pump/Air C? Kistler Furnaces, Heaters, Fireplaces & Air Conditioning 8 01-07-2007 01:13 AM
Furnace Trouble In Vt elliottkatz LP Gas, Piping, Tanks & Regulators 1 12-31-2006 01:27 PM
NT22 furnace trouble wfdyer Furnaces, Heaters, Fireplaces & Air Conditioning 2 01-25-2004 08:00 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:54 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.