Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-09-2010, 07:39 PM   #1
3 Rivet Member
 
MTsafari's Avatar
 
1970 23' Safari
Columbia Falls , Montana
Join Date: Aug 2006
Posts: 107
Images: 28
Help! New Furnace; New Battery; Weird Combo.

We replaced our furnace in our '70 Safari a year ago. Has worked great with no problems. Over this past winter our existing battery went kaput, and we bought a new one today. As soon as we connected the new battery the fan on our furnace kicked on and stayed on. (no gas on to feed the furnace- just the fan), Even though the thermostat was off....

Any idea why this is happening?
__________________

__________________
MTsafari is offline   Reply With Quote
Old 05-09-2010, 07:41 PM   #2
Site Team
 
azflycaster's Avatar
 
1975 25' Tradewind
Dewey , Arizona
Join Date: Mar 2005
Posts: 12,125
Images: 62
Blog Entries: 1
Check the contacts in the thermostat, they may be shorted together. The cover will just pull off and you can see the contacts.
__________________

__________________

Richard

Wally Byam Airstream Club 7513
azflycaster is offline   Reply With Quote
Old 05-09-2010, 07:48 PM   #3
3 Rivet Member
 
MTsafari's Avatar
 
1970 23' Safari
Columbia Falls , Montana
Join Date: Aug 2006
Posts: 107
Images: 28
Thanks. So this is atypical? I will go pull off the cover now and take a look.
__________________
MTsafari is offline   Reply With Quote
Old 05-09-2010, 08:02 PM   #4
Rivet Master
 
garry's Avatar
 
1969 31' Sovereign
Broken Arrow , Oklahoma
Join Date: Jan 2003
Posts: 1,362
Images: 7
I would not call it typical but a good possibility on the cause of your problem since the thermostat starts the sequence to turn on the fan.
__________________
Garry
garry is offline   Reply With Quote
Old 05-09-2010, 08:02 PM   #5
3 Rivet Member
 
MTsafari's Avatar
 
1970 23' Safari
Columbia Falls , Montana
Join Date: Aug 2006
Posts: 107
Images: 28
I think the thermostat looks ok.
the connections still look like new.
__________________
MTsafari is offline   Reply With Quote
Old 05-09-2010, 08:09 PM   #6
3 Rivet Member
 
MTsafari's Avatar
 
1970 23' Safari
Columbia Falls , Montana
Join Date: Aug 2006
Posts: 107
Images: 28
Here's a picture:
Attached Thumbnails
Click image for larger version

Name:	mail.jpg
Views:	44
Size:	47.0 KB
ID:	102205  
__________________
MTsafari is offline   Reply With Quote
Old 05-09-2010, 08:27 PM   #7
Site Team
 
azflycaster's Avatar
 
1975 25' Tradewind
Dewey , Arizona
Join Date: Mar 2005
Posts: 12,125
Images: 62
Blog Entries: 1
Someone replaced the original, but it is just a switch anyway. Try removing one of the wires and see if the fan stops. One wire is 12 volts and the other returns the 12 volts to the furnace when the contacts are made.
__________________

Richard

Wally Byam Airstream Club 7513
azflycaster is offline   Reply With Quote
Old 05-09-2010, 08:33 PM   #8
3 Rivet Member
 
MTsafari's Avatar
 
1970 23' Safari
Columbia Falls , Montana
Join Date: Aug 2006
Posts: 107
Images: 28
We replaced the original furnace and thermostat a year ago. But all has worked perfectly up until today, when we replaced the battery with a new one... I'll undo the connections and see what happens...
__________________
MTsafari is offline   Reply With Quote
Old 05-09-2010, 08:41 PM   #9
Rivet Master
 
aircooled4's Avatar
 
1971 31' Sovereign
1967 22' Safari
1958 22' World Traveler
Pardeeville , Wisconsin
Join Date: Sep 2008
Posts: 569
Blog Entries: 6
Just a thought...unhook one or both of the wires going FROM the thermostat TO the furnace...that will eliminate the thermostat as the problem...THEN reconnect it...and unhook the wires AT the furnace coming FROM the thermostat...that will eliminate that and the wiring as the problem...
__________________

__________________
Jay (KB8VMO)
WBCCI #10917
AIR #32349
TAC #WI-2
aircooled4 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C - Heater combo photocodo Furnaces, Heaters, Fireplaces & Air Conditioning 12 09-22-2009 10:39 AM
Weird Discoloration evsjr Roof Vents, Skylights & Fans 3 08-03-2009 09:51 PM
Really Weird Bedspread SRW Upholstery, Blinds, Walls & Interior Finishes 11 06-24-2009 09:12 AM
water heater/furnace combo tracker Furnaces, Heaters, Fireplaces & Air Conditioning 11 11-02-2006 11:02 PM
weird!!! rebel beck Plumbing - Systems & Fixtures 8 06-29-2006 10:06 AM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:26 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.