Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-15-2016, 01:01 PM   #1
2 Rivet Member
 
1994 34' Excella
Kalamazoo , Michigan
Join Date: Mar 2014
Posts: 81
Furnace won't stay on...need help.

I tested the furnace about a month ago, and it worked perfectly.

Now, fans start normally, burner lights normally, burns for about 10 sec, then shuts off. On shore power, fresh lp tanks, all else working normally. I suspect that something like a safety system is shutting off the main gas valve.

Any ideas?

Thanks in advance...


Sent from my iPad using Airstream Forums
__________________

__________________
TomS is offline   Reply With Quote
Old 03-15-2016, 01:09 PM   #2
Rivet Master
 
HowieE's Avatar
 
1991 34' Excella
Princeton , New Jersey
Join Date: Aug 2003
Posts: 6,809
Images: 12
There is a proof of flame probe that is placed so it should feel the flame and signal the gas valve that there is a flame. That probe may have been moved out of the flame, not likely, or it may have failed.
__________________

__________________
WBCCI 12156 AIR 3144 WACHUNG TAC NJ6
2004 Excursion 4x4
1991 34 ft. Excella +220,000 miles, new laminated flooring, new upholstery, new 3200 lbs axles

HowieE is offline   Reply With Quote
Old 03-15-2016, 04:57 PM   #3
Rivet Master
 
1998 30' Excella 1000
Livingston , Texas
Join Date: Jan 2014
Posts: 546
With the age of your unit, it could be the board. Try cleaning all the connections. They are not cheap. I would inspect the condition of the combustion chamber before I replaced the board.
__________________
Siegmann is offline   Reply With Quote
Old 03-15-2016, 05:19 PM   #4
Rivet Master
 
1998 30' Excella 1000
Livingston , Texas
Join Date: Jan 2014
Posts: 546
For other things to check, try looking at the trouble shooting info starting on page 28 in this reference:

http://bryantrv.com/docs2/docs/hflameservice.pdf
__________________
Siegmann is offline   Reply With Quote
Old 03-16-2016, 12:18 PM   #5
2 Rivet Member
 
drftboat's Avatar
 
2012 16' Sport
2015 19' Flying Cloud
Seattle , Washington
Join Date: Oct 2014
Posts: 25
Drftboat

I was having the same issue a while back.... Everything worked but the heater. It turned out that there was a plumbing leak that dripped water onto the heater's circuit board.
__________________
drftboat is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bowen (Atwood) G10b won't stay lit. Help Top Water Heaters, Filters & Pumps 18 01-02-2011 10:00 AM
furnace won't stay on Coloradoair Furnaces, Heaters, Fireplaces & Air Conditioning 16 09-27-2010 02:09 PM
Water heater prob, pilot won't stay lit & heater won't fire. johnboy Water Heaters, Filters & Pumps 1 06-20-2006 05:24 PM
Shades won't stay up dreamin Upholstery, Blinds, Walls & Interior Finishes 5 04-19-2004 06:58 AM
Furnace won't light /stay lit Don Furnaces, Heaters, Fireplaces & Air Conditioning 9 06-29-2002 04:37 AM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:56 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.