Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-12-2019, 01:11 PM   #1
2 Rivet Member
 
2016 26' Flying Cloud
West linn , Oregon
Join Date: Nov 2016
Posts: 20
Furnace / thermostat problem

2016 FC 26U. No problems after 23 trips the first 2 years. The month after the warranty expired the thermostat stopped working. It appears to turn on and respond to the input buttons-see photo below, and the furnace will quickly bring the temp up to the desired temperature. But as the temp slowly falls over the following hours the furnace doesn't kick back on unless I turn the thermostat off and back on again several times. As this process is repeated, the blower will come on for a minute or so but the furnace doesn't light. If I repeat this turning off/on the furnace will finally come on after the 5th or 6th try. Tanks are full, valves open. Oven and stove work fine. All fuses and switches look fine. "Reset" procedure doesn't change anything. Opened the furnace compartment and blew it out with a compressor-no change. Any suggestions?

Baby it's cold outside!
Attached Thumbnails
Click image for larger version

Name:	IMG_1959.jpg
Views:	15
Size:	187.9 KB
ID:	333453  
__________________

Lab lover is offline   Reply With Quote
Old 02-12-2019, 01:48 PM   #2
Rivet Master
 
2014 20' Flying Cloud
Long Island , New York
Join Date: Jun 2015
Posts: 9,391
Sorry for your troubles! I would disconnect from shore power, and turn off the 12-volt circuit breaker for the furnace and stat if there are two breakers. There may also be a 12-volt breaker for the A/C and stat control circuit?

Wait 10 seconds and flip all breakers back on, and do the Dometic hard reboot of the stat again per Dometic manual that came with your AS paperwork. Make sure the date and time are set correctly +/-. Plug back in to shore power at any time.

"Dometic stat hard reboot" threads in case there are any new ideas there:

https://www.google.com/search?q=Dome...=airforums.com

Are your batteries fully charged? On shore power what is the battery voltage on your monitor? [should be 13.7 +/-] After unplugging and waiting an hour, what is the battery voltage percentage? [should be 12.7 +/-] Any chance your battery charger/converter is failing?

Are all the other 12-volt functions working correctly?

Good luck,

Peter
OTRA15 is online now   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Furnace / thermostat problem Lab lover General Repair Forum 2 02-13-2019 05:36 AM
Two Zone Thermostat Problem tooleshop 2016 - Current International 1 06-28-2017 01:43 PM
Thermostat for Heat Pump-switch problem A W Warn Furnaces, Heaters, Fireplaces & Air Conditioning 14 01-15-2014 09:29 PM
Dometic RM100 electric thermostat problem blickcd Refrigerators 0 08-31-2009 11:32 AM
77 Argosy thermostat problem vcu70 Furnaces, Heaters, Fireplaces & Air Conditioning 6 05-17-2009 10:26 AM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:03 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.