Thread Tools Search this Thread Display Modes
Old 05-14-2009, 11:07 PM   #1
2 Rivet Member
1974 25' Tradewind
Monument , Colorado
Join Date: Apr 2009
Posts: 41
Furnace Issues on 25' Tradewind

Need advice.

When I initially light my pilot and call for heat sometimes the burner fires and sometimes not. Appears something shuts gas off at the pilot. When it does work and cycles, pilot is still on at shut down, but goes out upon refire, fan blows but no heat. I can relight the burner with fan blowing by pushing the piezo and get heat.

Any suggestions?

seeflash is offline   Reply With Quote
Old 05-15-2009, 06:49 AM   #2
Rivet Master
Lumatic's Avatar

1971 25' Tradewind
1993 34' Excella
Currently Looking...
Estancia , New Mexico
Join Date: Feb 2005
Posts: 5,880
Images: 16
If the furnace is a NT22a you should be aware there is was safety recall on that furnace. I messed around with my original furnace too long. Replace it and save yourself time and hassle.

Sail on silver girl. Sail on by. Your time has come to shine.
Lumatic is offline   Reply With Quote
Old 05-15-2009, 11:42 PM   #3
2 Rivet Member
1974 25' Tradewind
Monument , Colorado
Join Date: Apr 2009
Posts: 41
Thanks. It is an N22a but has been serviced recently. Rubber boot on intake is OK plus I have a CO2 sensor inside. Have not had any alarms.
seeflash is offline   Reply With Quote
Old 05-16-2009, 05:54 AM   #4
Rivet Master
1976 25' Caravanner
Vintage Kin Owner
Campton , New Hampshire
Join Date: Feb 2006
Posts: 1,113
Sounds like the fan is not operating fast enough to open the sail switch which controls the gas valve. Are you plugged into shore power when this happens ? Is the battery charged ? You also may have a week pilot , try taking the tube off and cleaning . good luck
ticki2 is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
'69 AS Sovereign Furnace Issues Engtech05 Furnaces, Heaters, Fireplaces & Air Conditioning 12 03-16-2009 07:23 AM
1975 25' Tradewind Furnace and Refrigerator Questions craigr Refrigerators 12 08-01-2006 09:18 PM
1987 Sovereign 25' -Any Issues?? nukesul 1987 Sovereign 3 04-04-2004 08:29 AM
Safari 25' ss & CCD 25' - odor issues? darkStar Waste Systems, Tanks & Totes 15 09-29-2003 01:28 PM
Safari 25' Model A towing issues rtierney 2003 Safari 11 07-02-2003 10:15 AM

Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:09 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.