Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-15-2019, 02:55 PM   #1
4 Rivet Member
Commercial Member
 
Castaway's Avatar
 
2012 25' FB Flying Cloud
Celina , Ohio
Join Date: Jul 2010
Posts: 414
Images: 3
Blog Entries: 1
AC help needed

Our AC in our 2012 will not keep running, the compressor runs about 30 seconds then shuts off with an E7 error message in the control panel. The first time it happened the breaker in the unit tripped but that has not happened again. When I called our dealer( 5 hrs away) they thought it might be a control board in thermostat unit on wall. Living only 30 miles from Jackson Center I went and got a new control panel. The new panel did the same thing as the old. I have tried running on generator only since it is so hot here in Ohio thinking maybe not enough power was available, no difference. Any ideas?
__________________

Castaway is offline   Reply With Quote
Old 07-15-2019, 03:02 PM   #2
Overkill Specialist
 
GMFL's Avatar

 
2014 23' International
Dadeville , Alabama
Join Date: Oct 2015
Posts: 2,900
Images: 4
Blog Entries: 42
E7 error is power interruption. Do you have a surge protector installed?
__________________

__________________
Dept of “OverKill”
GMFL is offline   Reply With Quote
Old 07-15-2019, 03:15 PM   #3
4 Rivet Member
Commercial Member
 
Castaway's Avatar
 
2012 25' FB Flying Cloud
Celina , Ohio
Join Date: Jul 2010
Posts: 414
Images: 3
Blog Entries: 1
Quote:
Originally Posted by GMFL View Post
E7 error is power interruption. Do you have a surge protector installed?
The power is coming from our house or directly from a gennerator that has run the AC in the past.
Castaway is offline   Reply With Quote
Old 07-15-2019, 03:28 PM   #4
Overkill Specialist
 
GMFL's Avatar

 
2014 23' International
Dadeville , Alabama
Join Date: Oct 2015
Posts: 2,900
Images: 4
Blog Entries: 42
What about the 12 volt side. Converter working ok. Batts good. Thermostat is 12 volt.
__________________
Dept of “OverKill”
GMFL is offline   Reply With Quote
Old 07-15-2019, 03:39 PM   #5
Rivet Master
 
A W Warn's Avatar

 
2000 25' Safari
1999 34' Excella
Davidson County , North Carolina
Join Date: Aug 2006
Posts: 3,829
Would it give E7 code if the start capacitor is bad, not providing the proper boost to get the compressor going?
__________________
Alan
2014 Silverado 1500 Crew Cab 5.3L maximum trailering package
A W Warn is offline   Reply With Quote
Old 07-15-2019, 04:16 PM   #6
Overkill Specialist
 
GMFL's Avatar

 
2014 23' International
Dadeville , Alabama
Join Date: Oct 2015
Posts: 2,900
Images: 4
Blog Entries: 42
Probably not. Maybe the run cap, but in order to get an E7 error code there needs to be a power interruption to the main board.
__________________
Dept of “OverKill”
GMFL is offline   Reply With Quote
Old 07-15-2019, 05:38 PM   #7
Rivet Master
 
Al and Missy's Avatar

 
2002 30' Classic S/O
Melbourne Beach , Florida
Join Date: Nov 2013
Posts: 3,541
Could be a bad breaker. Cycle it several times. Check to see if it is warm right after the AC shuts off.



Also, measure the voltage in the trailer when the unit is running. Should be at least 110V for good operation. Anything under 100 is bad news.


Al
__________________

"You cannot reason someone out of a position they have not been reasoned into"

Al, K5TAN and Missy, N4RGO
2002 Classic 30 Slideout
S/OS #004
2013 Dodge 2500 Laramie 4x4 Megacab Cummins
2001 Safari 25 RB Twin (Gone, but not forgotten)
WBCCI 1322, TAC FL-39, AIR 82265

Al and Missy is offline   Reply With Quote
Old 07-15-2019, 07:33 PM   #8
4 Rivet Member
Commercial Member
 
Castaway's Avatar
 
2012 25' FB Flying Cloud
Celina , Ohio
Join Date: Jul 2010
Posts: 414
Images: 3
Blog Entries: 1
Well, after reading all of the advice I got here and Facebook I started troubleshooting the electrical pathway. The first thing I did was take emery cloth to the male plug ends. When I tried running again it WORKED!!!!!!! I will try tomorrow when the outside temp is over 90 again since a storm cooled the air to 74. Thanks for all of your help.
Castaway is offline   Reply With Quote
Old 07-15-2019, 07:40 PM   #9
Overkill Specialist
 
GMFL's Avatar

 
2014 23' International
Dadeville , Alabama
Join Date: Oct 2015
Posts: 2,900
Images: 4
Blog Entries: 42
After doing some research Sounds like run cap
__________________

__________________
Dept of “OverKill”
GMFL is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
help, help, help. new to it all. ohwally Member Introductions 5 08-24-2008 04:18 PM
HELP HELP HELP!! Lug nuts & Stems Chitown AirStreamers Wheels, Hubs & Bearings 4 08-18-2008 04:41 PM
Hot Water Heater HELP HELP HELP!!! Igor68 Water Heaters, Filters & Pumps 2 06-22-2006 08:07 PM
Help Help Help!!! rebel beck 1974 - 1979 Sovereign 9 01-07-2006 03:00 PM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:25 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.