Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-05-2015, 07:00 PM   #15
Rivet Master
 
urnmor's Avatar
 
2012 25' Flying Cloud
Berlin , Maryland
Join Date: Jun 2011
Posts: 1,220
I am concerned that it is more as I have been using the lights and fan together for four years without any issue. So I wonder y it is happening now.

Anyway if u remember the part number I would greatly appreciate it.

Thanks
John
__________________

__________________
urnmor is offline   Reply With Quote
Old 09-06-2015, 12:43 PM   #16
Rivet Master
 
Howard L.'s Avatar
 
2012 30' Flying Cloud
San Antonio , Texas
Join Date: Jul 2012
Posts: 591
Quote:
Originally Posted by urnmor View Post
Well I replaced the fuse but it did not fix the problem. The lights came on but when I turned the fan on the fuse blew. Not sure if I should go to a higher fuse like some of the older threads say to do.
What is the number of the replacement fuse you used?
__________________

__________________
Howard L. is offline   Reply With Quote
Old 09-07-2015, 05:26 PM   #17
Rivet Master
 
urnmor's Avatar
 
2012 25' Flying Cloud
Berlin , Maryland
Join Date: Jun 2011
Posts: 1,220
Not sure however they did not work. When I get back home I will look for a 5 amp and see if the fan works. If it does not then I believe I have a bad fan switch
__________________
urnmor is offline   Reply With Quote
Old 09-08-2015, 11:18 AM   #18
Rivet Master
 
Howard L.'s Avatar
 
2012 30' Flying Cloud
San Antonio , Texas
Join Date: Jul 2012
Posts: 591
Quote:
Originally Posted by urnmor View Post
Not sure however they did not work. When I get back home I will look for a 5 amp and see if the fan works. If it does not then I believe I have a bad fan switch
Try this one: mini GMC-5, time delay fuse
__________________
Howard L. is offline   Reply With Quote
Old 09-08-2015, 11:31 AM   #19
Rivet Master
 
urnmor's Avatar
 
2012 25' Flying Cloud
Berlin , Maryland
Join Date: Jun 2011
Posts: 1,220
Thank you I will go to Radio shack or HD to see if they have them.
__________________
urnmor is offline   Reply With Quote
Old 09-09-2015, 10:05 AM   #20
Rivet Master
 
Howard L.'s Avatar
 
2012 30' Flying Cloud
San Antonio , Texas
Join Date: Jul 2012
Posts: 591
GMC5 | GMC Time-Delay Fuse: 0.197 in x 0.788 in, 5A, 125VAC, glass, 5/pk

This is it on line.
__________________
Howard L. is offline   Reply With Quote
Old 09-09-2015, 10:11 AM   #21
Rivet Master
 
Howard L.'s Avatar
 
2012 30' Flying Cloud
San Antonio , Texas
Join Date: Jul 2012
Posts: 591
Quote:
Originally Posted by Howard L. View Post
or, ACE hardware has them--if you can find an ACE store.
__________________
Howard L. is offline   Reply With Quote
Old 09-09-2015, 10:19 AM   #22
Prairie Schooner II
 
Jim Flower's Avatar

 
2012 30' International
1997 25' Safari
1967 20' Globetrotter
Burlington , Ontario
Join Date: Jul 2009
Posts: 1,182
There is also a chance that the wiring is chaffing against the aluminum behind where the black fuse box is located above the filter. I had to put some tape on the chaffed wires on my 2012 Signature. I also replaced the fuse with a 5 amp and put in a LED light. All works perfectly now. No electrical jig required. Jim
__________________
Jim
Jim Flower is online now   Reply With Quote
Old 09-09-2015, 05:36 PM   #23
Rivet Master
 
urnmor's Avatar
 
2012 25' Flying Cloud
Berlin , Maryland
Join Date: Jun 2011
Posts: 1,220
Howard thnks for the Link. I went to my local electrical store and he is ordering me some will be here tomorrow. All of the others i have tried have failed lthought they were not time delayed.
__________________
urnmor is offline   Reply With Quote
Old 09-09-2015, 05:38 PM   #24
Rivet Master
 
urnmor's Avatar
 
2012 25' Flying Cloud
Berlin , Maryland
Join Date: Jun 2011
Posts: 1,220
Jim Thanks for the info. If the new fuses don't work that will be my next step.
__________________
urnmor is offline   Reply With Quote
Old 09-10-2015, 08:35 PM   #25
Rivet Master
 
urnmor's Avatar
 
2012 25' Flying Cloud
Berlin , Maryland
Join Date: Jun 2011
Posts: 1,220
Success. The new time delayed fuse solved teh problem
__________________
urnmor is offline   Reply With Quote
Old 09-11-2015, 09:54 AM   #26
Rivet Master
 
Howard L.'s Avatar
 
2012 30' Flying Cloud
San Antonio , Texas
Join Date: Jul 2012
Posts: 591
Quote:
Originally Posted by urnmor View Post
success. The new time delayed fuse solved the problem
__________________

__________________
Howard L. is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
'71 Tradewind vent fan help.Low speed quit. Wooden Rivet General Repair Forum 5 04-07-2014 05:47 PM
Bath exhaust fan quit TY PECK Sprinter and B-van Forum 3 10-17-2012 06:56 AM
Fan Wont Quit Running? Help! CalamityJane Electrical - Systems, Generators, Batteries & Solar 12 07-23-2012 06:19 AM
Lights quit working after plugging cell phone charger into cigarette lighter hagnik Lights - Interior & Exterior 6 06-20-2011 10:57 AM
Fantastic Fan quit - what should I check dufferin Roof Vents, Skylights & Fans 5 10-12-2007 07:25 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:29 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.