Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-07-2017, 01:31 PM   #1
2 Rivet Member
 
2005 25' Classic
SomeWhereIn , South Carolina
Join Date: Oct 2016
Posts: 21
Oven not working...

Anyone know why the oven in a 2005 25ft Classic won't work? I can't get the pilot to light, but on the other hand, the burners on the stovetop are working perfectly.

Thanks.
__________________

smokinjoe is offline   Reply With Quote
Old 01-07-2017, 02:56 PM   #2
Rivet Master
 
Wayne&Sam's Avatar
 
2014 25' Flying Cloud
Cuddebackville , New York
Join Date: May 2007
Posts: 3,315
Images: 21
Probably a bad thermo couple. An easy fix. The thermo couple is the thin rod that gets heated by the pilot flame. The pilot will not stay lit is if the thermo couple is bad.
__________________

__________________
2014 25' Flying Cloud Rear Twin
2012 Dodge Durango Hemi/AWD
Wayne&Sam is offline   Reply With Quote
Old 01-07-2017, 04:55 PM   #3
Rivet Master
 
2014 20' Flying Cloud
Long Island , New York
Join Date: Jun 2015
Posts: 7,580
smokinjoe, can you light the pilot at all? Usually there is a special instruction for lighting the pilot light [to override the thermocouple for 30 seconds or so], so you might want to check the manual for the oven which should have come with your AS paperwork.

If you are unable to light the pilot, following the mfg. instructions, then the gas valve may be bad IMO.

If the pilot lights and then goes out when you exit the short-term override, then yes the thermocouple may be bad, as W&S just said.

Good luck!

Peter

PS -- What mfg. gas oven model do you have?
OTRA15 is offline   Reply With Quote
Old 01-07-2017, 06:34 PM   #4
3 Rivet Member
 
brokeboater's Avatar
 
Currently Looking...
High Springs , Florida
Join Date: Jul 2006
Posts: 154
Possibility of a broken pilot light line. Check to make sure the small supply line to the pilot light, aluminum in my current rig, is intact. Not unusual for one to be broken. If it's broken the gas will leak out before reaching the pilot light.
brokeboater is offline   Reply With Quote
Old 01-07-2017, 07:27 PM   #5
Rivet Master
 
Wingeezer's Avatar
 
2005 30' Classic
Burlington , Ontario
Join Date: Sep 2008
Posts: 2,743
Have you used it previously without problem or is the trailer new to you?

The oven pilot light in our 2005 Classic is a bit fiddly to light but it will light. We rarely use the oven.

I use a butane gas lighter to light the pilot. When the pilot first lights, you need to hold the gas knob pushed in for 30-60 sec. to let it heat the thermocouple - it should stay lit at that point when you release the knob, and the main burner should then light up.

If it won't stay on when you release the gas control knob, there is likely a problem with the thermocouple.

If it won't light at all even with the valve knob pushed in, then probably an issue with the gas line or control valve. (Assuming your other gas appliances are working as they should.)

Brian.
__________________
Brian & Connie Mitchell

2005 Classic 30'
Hensley Arrow / Centramatics
2008 GMC Sierra SLT 2500HD,4x4,Crew Cab, Diesel, Leer cap.
Wingeezer is offline   Reply With Quote
Old 01-08-2017, 08:16 AM   #6
2 Rivet Member
 
2005 25' Classic
SomeWhereIn , South Carolina
Join Date: Oct 2016
Posts: 21
Trailer is new to me. As said, the stovetop works, but the oven does not. I'll try some of the suggestions given here. Thanks!
__________________

smokinjoe is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electic Jack not working - fuse good - manual not working ryandanz Jacks, Stabilizers, Lifting and Leveling 20 04-24-2016 10:04 AM
Front interior light not working, middle and rear working? jonnyo Lights - Interior & Exterior 4 04-03-2016 09:16 PM
Dometic heater zone 2 not working on furnace, not hot on HP sfgirl General Repair Forum 13 11-06-2015 01:21 PM
Help! Battery not charging, outlets not working when plugged in AirGal04 Electrical - Systems, Generators, Batteries & Solar 9 06-06-2014 09:15 PM
Oven not working fwiz General Motorhome Topics 1 09-16-2005 12:21 PM


Featured Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:49 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.