Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-13-2009, 10:12 AM   #1
2 Rivet Member
 
HankO's Avatar
 
1997 28' Excella
Eden , Utah
Join Date: Apr 2008
Posts: 70
RM 4872 problems

Hi all,

Currently having problem with the frig. I have a Dometic 4872 that is working on Gas but not AC. I am currently hooked up to 110 AC and when I put it in "AUTO" mode it kicks the gas mode on. Tried to turn gas off and can hear the ignitor trying to start the gas. I have had it in the electric mode once and it runs for a few minutes then the "CHECK" light comes on. It won't stay in "AC" mode.

Any suggestions,

Hank
__________________

__________________
HankO is offline   Reply With Quote
Old 10-13-2009, 10:42 AM   #2
Moderator
Commercial Member
 
eubank's Avatar
 
1967 30' Sovereign
Bosque Farms , New Mexico
Join Date: Jan 2004
Posts: 6,423
Humm. Check all of the electrical connections first. There's a cord on the back with a standard wall plug. If the recepacle is worn (as is the case on our rig), it could result in funky problems.

Lynn
__________________

__________________
WBCCI 21043
eubank is offline   Reply With Quote
Old 10-13-2009, 03:12 PM   #3
2 Rivet Member
 
HankO's Avatar
 
1997 28' Excella
Eden , Utah
Join Date: Apr 2008
Posts: 70
I unhooked the power lead to the wall plug outside and plugged in a hair dryer, seemed to work fine. Must be something else?
__________________
HankO is offline   Reply With Quote
Old 10-13-2009, 04:46 PM   #4
Moderator
Commercial Member
 
eubank's Avatar
 
1967 30' Sovereign
Bosque Farms , New Mexico
Join Date: Jan 2004
Posts: 6,423
Sounds kind of like it. I'll let others take over here, but basically you've got an electric heat-providing device to heat up the ammonia, just like the tiny propane flame does. Check to see if it's heating.

If it's heating, you've got cooling, but the electronics that sense what's going on may not be working.


Lynn
__________________
WBCCI 21043
eubank is offline   Reply With Quote
Old 10-13-2009, 07:32 PM   #5
Rivet Master
 
garry's Avatar
 
1969 31' Sovereign
Broken Arrow , Oklahoma
Join Date: Jan 2003
Posts: 1,362
Images: 7
I would suspect the control board or a short in the electrical (heater) element.

If you have a ohm meter you can check the electric element should read very low ohms also check the element to ground some times they come in contact with ground and appear to be shorted out when moving the element just a touch will fix it.

If it is the control board replace it with a Dino board.
__________________
Garry
garry is offline   Reply With Quote
Old 10-16-2009, 12:45 AM   #6
2 Rivet Member
 
HankO's Avatar
 
1997 28' Excella
Eden , Utah
Join Date: Apr 2008
Posts: 70
Whats going on

Ok, Yesterday i wake up and the frig says its running on
AC. Before I went to bed it was indicating it was running on GAS. It seems to switch from GAS to Electric and back. I checked it again tonight after being gone all day and it is in AUTO mode with the check light on. I turned off the frig and started it again and it switched to GAS. Seems the thing is cooling as the freezer compartment is cold. As I sit here writing this I can here a relay or something kicking off and on and just checked it and it had switched to AC again.

Hank
__________________
HankO is offline   Reply With Quote
Old 10-16-2009, 10:19 AM   #7
Iwannagocamping
 
Dakota's Dad's Avatar
 
1979 31' Sovereign
Rineyville , Kentucky
Join Date: Apr 2009
Posts: 262
It will clear up on it's own after the end of the month..

(couldn't find any better Halloween smiley.. sorry)
__________________

__________________
See our blog here on how two RV/AS rookies tackle a 1979 Sovereign resto!!

Just the photos.. (sometimes you don't need the blog, just a picture worth a thousand words..)

1979 Sovereign International
2004 Ford Expedition Eddie Bauer
2 Golden Retrievers

Air #36788
TAC#3179
WBCCI #1265
Dakota's Dad is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
JC With Problems, Same Problems Goin Home ncbambi 2008 Safari SE 3 06-23-2009 10:44 PM
Update on Problems Problems pjude General Motorhome Topics 4 09-04-2007 07:02 AM
AC Problems PhiDor Furnaces, Heaters, Fireplaces & Air Conditioning 7 01-11-2006 09:11 PM
ac problems wb13798 Furnaces, Heaters, Fireplaces & Air Conditioning 5 09-18-2003 07:53 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.