Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-25-2015, 10:35 PM   #1
camper collector
 
Currently Looking...
Currently Looking...
Americus , Georgia
Join Date: Oct 2006
Posts: 72
Blog Entries: 1
Refrigerator won't run on gas

I have a Servel model S 630
3-way refg and can't get it to lite on the LP gas side. I did as the owner manual instructed but the pilot lite won't lite. The elec igniter does not function Is there a way to short circuit the process or some way to lite it by bypassing the igniter? Any suggestions??
__________________

__________________
camper is offline   Reply With Quote
Old 10-26-2015, 05:57 AM   #2
Rivet Master
 
Lumatic's Avatar

 
1971 25' Tradewind
1993 34' Excella
Currently Looking...
Estancia , New Mexico
Join Date: Feb 2005
Posts: 6,642
Images: 16
Blog Entries: 1
I am not familiar with this model but there may be a way to light the pilot light with a long handle lighter with the burner control in the pilot position. Once the pilot is lit give a minute or so to warm up the thermocouple and then switch the control to the on position.
__________________

__________________
Sail on silver girl. Sail on by. Your time has come to shine.
Lumatic is offline   Reply With Quote
Old 10-27-2015, 07:11 AM   #3
camper collector
 
Currently Looking...
Currently Looking...
Americus , Georgia
Join Date: Oct 2006
Posts: 72
Blog Entries: 1
It is an automatic so you have to set the DC selector on and set to GAS then it should lite.
__________________
camper is offline   Reply With Quote
Old 10-27-2015, 07:16 AM   #4
Rivet Master
 
Lumatic's Avatar

 
1971 25' Tradewind
1993 34' Excella
Currently Looking...
Estancia , New Mexico
Join Date: Feb 2005
Posts: 6,642
Images: 16
Blog Entries: 1
Has this fridge worked on gas for you then quit? Is there a dedicated in line propane valve somewhere for the fridge?
__________________
Sail on silver girl. Sail on by. Your time has come to shine.
Lumatic is offline   Reply With Quote
Old 10-27-2015, 11:58 AM   #5
2 Rivet Member
 
Rocker66's Avatar
 
1965 24' Tradewind
Henderson , Nevada
Join Date: Jan 2015
Posts: 39
Images: 7
Mine did the same thing until I figured out that it NEEDS a full 12 VOLT's to start the ignition for the gas. Make sure your batteries are charged and connected properly in the back of the fridge. I had a low battery but my lights and fans worked , I never thought it would have been the 12 volt but it was. Once I plugged into shore power and got the volts back up to 12, I heard the clicking noise and it started
__________________
Rocker66 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Refrigerator won't light on gas jetjocky LP Gas, Piping, Tanks & Regulators 10 07-04-2014 12:12 PM
Refrigerator issue.. won't run when switched to LP ? Focusfactor1 General Repair Forum 6 07-25-2013 10:18 AM
Refrig Won't Run On Gas SteveH Refrigerators 4 03-30-2010 11:18 AM
Gas Refrigerator won't light Emh142 Refrigerators 11 07-07-2008 10:09 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.