Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-27-2014, 08:58 PM   #1
2 Rivet Member
 
2013 16' Sport
Boulder , Colorado
Join Date: Dec 2012
Posts: 37
Refridgerator not working on gas

Hi, I need some diagnostic help if anyone has any to offer:

I have a Bambi, Dometic 2351 fridge. Runs fine on electicity, but not firing up on gas. I have:

recycled ignition sequence
replaced 1A inline fuse and 3A circuit board fuse

The gas canister full
The lines are clean (stove and water heater working)
No gas or flame coming into cylinder

Thoughts, oh wise ones?

Thanks
Caroline
__________________

__________________
Seecue is offline   Reply With Quote
Old 05-27-2014, 09:48 PM   #2
2 Rivet Member
 
2013 16' Sport
Boulder , Colorado
Join Date: Dec 2012
Posts: 37
Refrigerator not running on gas
(just correcting my typo!)
__________________

__________________
Seecue is offline   Reply With Quote
Old 05-27-2014, 09:59 PM   #3
Agent 86
 
J. Morgan's Avatar

 
1972 31' Sovereign
1975 31' Excella 500
Currently Looking...
Benton , Arkansas
Join Date: Mar 2013
Posts: 1,952
Does it light or try to light? Does it make a spark?
__________________
1/2 Ton Truck, Big Trailer,
Hensley Hitch,
Yea Baby!
J. Morgan is offline   Reply With Quote
Old 05-27-2014, 10:02 PM   #4
Rivet Master
 
DaveFL's Avatar
 
2000 31' Land Yacht
2000 Land Yacht 30(31') , Inverness, between the Withlachochee River and the Gulf of Mexico, Fl
Join Date: Aug 2007
Posts: 1,297
Images: 15
Last time mine didn't work on gas, flame was not right, took it apart and cleaned orifice. Spiders love to hang out in small places.
__________________
DaveFL is offline   Reply With Quote
Old 05-27-2014, 10:06 PM   #5
2 Rivet Member
 
2013 16' Sport
Boulder , Colorado
Join Date: Dec 2012
Posts: 37
No spark or attempt to spark. Just a short, quiet click, sounds like coming from the circuit board.
__________________
Seecue is offline   Reply With Quote
Old 05-27-2014, 10:14 PM   #6
2 Rivet Member
 
2013 16' Sport
Boulder , Colorado
Join Date: Dec 2012
Posts: 37
Waited for it to re-cycle ignition sequence. Could hear a very quiet thunk before check light came on (I'm right there looking in the bottom compartment, not in the trailer)
__________________
Seecue is offline   Reply With Quote
Old 05-27-2014, 10:19 PM   #7
Agent 86
 
J. Morgan's Avatar

 
1972 31' Sovereign
1975 31' Excella 500
Currently Looking...
Benton , Arkansas
Join Date: Mar 2013
Posts: 1,952
Mine is a different brand, but the first thing it tries to do is spark, then gas comes on.

I am thinking it is either a loose connection or a failed circuit board.

Unfortunately, of the two, it is probably the later.
__________________
1/2 Ton Truck, Big Trailer,
Hensley Hitch,
Yea Baby!
J. Morgan is offline   Reply With Quote
Old 05-27-2014, 10:26 PM   #8
Agent 86
 
J. Morgan's Avatar

 
1972 31' Sovereign
1975 31' Excella 500
Currently Looking...
Benton , Arkansas
Join Date: Mar 2013
Posts: 1,952
It could be an ignition system failure too.
__________________
1/2 Ton Truck, Big Trailer,
Hensley Hitch,
Yea Baby!
J. Morgan is offline   Reply With Quote
Old 05-27-2014, 10:32 PM   #9
2 Rivet Member
 
2013 16' Sport
Boulder , Colorado
Join Date: Dec 2012
Posts: 37
Thanks for your help. Looks like I gotta take it in. Until then, it's just a nice cooler with shelves!
__________________
Seecue is offline   Reply With Quote
Old 05-27-2014, 10:46 PM   #10
Agent 86
 
J. Morgan's Avatar

 
1972 31' Sovereign
1975 31' Excella 500
Currently Looking...
Benton , Arkansas
Join Date: Mar 2013
Posts: 1,952
Sorry it couldn't have been something simple.
__________________
1/2 Ton Truck, Big Trailer,
Hensley Hitch,
Yea Baby!
J. Morgan is offline   Reply With Quote
Old 06-25-2014, 10:58 AM   #11
3 Rivet Member
 
2006 19' Safari SE
Hayes , Virginia
Join Date: Dec 2011
Posts: 241
2351 Refrigerator

Seacue,

Bambi 2351 Refrigerator no gas operation
I see that we have the exact problem with the gas operation of our Fefrig, and I was just wondering if you ever fixed yours, and what you did. I have one more problem than you; I cannot move the gas shutoff valve. It is on but will not turn. I am being very careful when attempting (she froze tight--any suggestions on how to "unfreeze"). I posted my problem but no one wanted to tackle it is the reason I am asking you. Many thanks. Tom

If this goes to the wrong place again, s o r r y(however, I am trying)...
__________________
mocus is offline   Reply With Quote
Old 06-25-2014, 11:06 AM   #12
Agent 86
 
J. Morgan's Avatar

 
1972 31' Sovereign
1975 31' Excella 500
Currently Looking...
Benton , Arkansas
Join Date: Mar 2013
Posts: 1,952
Which gas valve? The one on the unit itself or an in line valve?


Sent from my iPhone using Airstream Forums
__________________
1/2 Ton Truck, Big Trailer,
Hensley Hitch,
Yea Baby!
J. Morgan is offline   Reply With Quote
Old 06-25-2014, 11:10 AM   #13
2 Rivet Member
 
2013 16' Sport
Boulder , Colorado
Join Date: Dec 2012
Posts: 37
Tom, we have not yet fixed our fridge. We believe it is the ignition system, because when the fridge turns on we can smell gas -- just no spark. We are taking it in to the RV dealer next week: will report back!
I will defer to those more knowledgeable regarding your frozen valve!

caroline
__________________
Seecue is offline   Reply With Quote
Old 06-26-2014, 02:44 PM   #14
3 Rivet Member
 
2006 19' Safari SE
Hayes , Virginia
Join Date: Dec 2011
Posts: 241
Afraid you would say that....I have pushed,pulled, tried turning, and nothing works. Oh well, don't need it this next trip anyway so will leave it until we return from the Keys. Many thanks, Tom
__________________

__________________
mocus is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Humphrey gas light not working properly bmklawt LP Gas, Piping, Tanks & Regulators 6 12-05-2011 10:58 AM
Dometic not working on 12V, ok Elec & Gas afordjones Refrigerators 1 08-16-2011 07:02 AM
My Gas Detector is not working, at all J5MM LP Gas, Piping, Tanks & Regulators 13 07-22-2011 08:04 PM
refridgerator on gas FireFighter Refrigerators 1 08-31-2004 11:55 AM
Refridgerator was working Just Fine,...til I started messing with it MileHigh Refrigerators 2 06-12-2004 01:56 PM





All times are GMT -6. The time now is 09:15 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.
Modal Click