Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-06-2013, 12:35 PM   #1
2 Rivet Member
 
Tdcraw's Avatar
 
1974 31' Sovereign
Yukon , Oklahoma
Join Date: Jun 2012
Posts: 71
Fridge drivee crazy !!!

Okay so fridge worked great in Nov., Feb, and March in my 1974. Sometimes to well. Now in April it won't do anything. Anyone have any ideas? Made sure it was level, won't work on gas or elec. any idea what is wrong or am I missing a fuse some where? Really don't want to rebuild but very annoyed at the moment.
__________________

__________________
Tdcraw is offline   Reply With Quote
Old 05-06-2013, 12:41 PM   #2
Rivet Master
 
1981 31' Excella II
New Market , Alabama
Join Date: Sep 2011
Posts: 5,648
Check the back of it and see if it is getting warm. If not look for electrical faults.

Perry
__________________

__________________
perryg114 is offline   Reply With Quote
Old 05-06-2013, 01:47 PM   #3
Rivet Master
 
Join Date: Jan 2005
Posts: 811
Does the front light up or the light go on inside the fridge? The control is 12 volts. You have to have 12v for it to work on either gas or electricity. If it died suddenly, you might have an electrical problem. That is better than a worn out cooling unit.
I replaced my fridge on my 2004 Safari last year. All the lights went on but it didn't cool. It was the cooling unit. If your fridge is original, you are on borrowed time as the evaporative ones don't last very long.
__________________
handn is offline   Reply With Quote
Old 05-06-2013, 01:49 PM   #4
Rivet Master
 
TG Twinkie's Avatar
 
1974 Argosy 26
Morrill , Nebraska
Join Date: Nov 2009
Posts: 5,140
Images: 2
Blog Entries: 5
Have you checked to see if the burner is lit? If it is like the one in my '74. You must select either gas or electric, then set the thermostat (separate for each)
I have to light ours initially from the outside access door. Then most of the time, not always, I can light it from inside.
Check for evidence of yellow dust or the smell of ammonia when looking thru the outside hatch. If either exists. Get out your wallet. Time for a new refer.
If it is the original model. There is no 12 volt DC involved. It is either gas or 120 volts AC.
__________________
Knowledge: "A gift to be shared. A treasure to receive."
TG Twinkie is offline   Reply With Quote
Old 05-06-2013, 03:00 PM   #5
4 Rivet Member
 
blickcd's Avatar
 
1979 31' Sovereign
Milford , Ohio
Join Date: Jan 2005
Posts: 478
Images: 1
Blog Entries: 29
Is this the original fridge, perhaps a Dometic RM-100? If not, let us know the make and model number.
__________________
Christopher

Its a camper, therefore it leaks.
blickcd is offline   Reply With Quote
Old 05-26-2013, 12:47 PM   #6
2 Rivet Member
 
Tdcraw's Avatar
 
1974 31' Sovereign
Yukon , Oklahoma
Join Date: Jun 2012
Posts: 71
Okay sorry for the delay, end of the school year crazy time. Mine is RM 77 think it may be original. Just odd no ammonia smell or residue.
__________________
Tdcraw is offline   Reply With Quote
Old 06-17-2013, 02:06 PM   #7
2 Rivet Member
 
Tdcraw's Avatar
 
1974 31' Sovereign
Yukon , Oklahoma
Join Date: Jun 2012
Posts: 71
Can someone tell me where the fuse for this fridge might be?
__________________
Tdcraw is offline   Reply With Quote
Old 06-17-2013, 03:19 PM   #8
Moderator
 
DKB_SATX's Avatar

 
2017 26' Flying Cloud
1976 Argosy 28
Alamo Heights , Texas
Join Date: Aug 2006
Posts: 6,401
Images: 1
Blog Entries: 7
Quote:
Originally Posted by Tdcraw View Post
Can someone tell me where the fuse for this fridge might be?
If it's the original fridge, it doesn't have any 12v system to it at all. It'll be plugged into a 120v socket that is on one of the breakers in the 120v panel and that's about it.

Test to make sure you have 120v there (at the plug) then start checking things with the fridge. You should have continuity across the electric heating element, and I'm sure somewhere you can find instructions for testing the thermistor and controls.

When you say it "won't work on gas" do you mean the flame burns but the fridge doesn't cool? Or you can't get it to light?
__________________
David

Zero Gravitas 2017 Flying Cloud 26U | Il Progetto 1976 Argosy 28 Center Bath | WBCCI# 15566

He has all of the virtues I dislike and none of the vices I admire. Sir Winston Churchill
DKB_SATX is offline   Reply With Quote
Old 06-27-2013, 07:35 AM   #9
2 Rivet Member
 
Tdcraw's Avatar
 
1974 31' Sovereign
Yukon , Oklahoma
Join Date: Jun 2012
Posts: 71
Ok. Sorry for delay. Tried gas and althought it heats up it is hotter in box not cooler. As for electric. I tested something else's in plug no problem there. For giggle I the elec cord from house to fridge and got nada. Any suggestions?
__________________
Tdcraw is offline   Reply With Quote
Old 06-30-2013, 04:32 PM   #10
2 Rivet Member
 
pdvasquez's Avatar
 
2007 25' Safari SS SE
Hico , Texas
Join Date: Jun 2013
Posts: 59
im trying to find the fuses as well. My refrig stopped working on my 2007 International.

Im new to airstreaming and cannot locate them. Please help anybody!!!
__________________

__________________
pdvasquez is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:40 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.