Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-05-2016, 08:08 PM   #1
2 Rivet Member
 
firstwave's Avatar
 
2006 30' Classic
Santa Fe , New Mexico
Join Date: Jun 2014
Posts: 91
Electrical Help

Stopped in Santa Fe this evening and my furnace,fridge and exhaust fans have no power. I've checked breakers and seem ok. Anyone have any idea what could be the problem? It's going to be a cold night with no heat
__________________

__________________
firstwave is offline   Reply With Quote
Old 03-05-2016, 08:28 PM   #2
Prairie Schooner II
 
Jim Flower's Avatar

 
2012 30' International
1997 25' Safari
1967 20' Globetrotter
Burlington , Ontario
Join Date: Jul 2009
Posts: 1,182
I thought the breakers are for your 110 items. The stuff that is not working are on fuses so I would look at your panel again and check the fuses. If they appear ok, pull them in and out in case they are corroded. Jim


Sent from my iPad using Airstream Forums
__________________

__________________
Jim
Jim Flower is offline   Reply With Quote
Old 03-05-2016, 08:54 PM   #3
2 Rivet Member
 
firstwave's Avatar
 
2006 30' Classic
Santa Fe , New Mexico
Join Date: Jun 2014
Posts: 91
Thanks Jim. One of the 12 volt breakers had tripped. Thanks to you we'll be warm tonight.
__________________
firstwave is offline   Reply With Quote
Old 03-05-2016, 08:59 PM   #4
Rivet Master
 
dbj216's Avatar

 
1986 34' Limited
1966 24' Tradewind
Conifer , Colorado
Join Date: Jun 2009
Posts: 3,127
Do you have any 12v power at all? Lights, water pump, tongue jack?

Make sure your batteries are delivering 12.5 volts up to 12.9. Maybe you have low batteries for some reason. I hope you have a volt meter handy.

If you are connected to shore power, make sure your batteries are receiving about 13.3 volts and even up to 15 volts charging from the converter.

Make sure the cables to the batteries are not loose.

If the batteries are charged, and the converter is delivering voltage to the batteries and thus the 12v system in the trailer, then you have to dive into the 12v fuse panel and verify every fuse is ok, not blown. If you find a bad fuse, replace it with the same amperage fuse.

David
__________________
dbj216 is offline   Reply With Quote
Old 03-05-2016, 09:35 PM   #5
Rivet Master
 
Al and Missy's Avatar

 
2002 30' Classic S/O
Melbourne Beach , Florida
Join Date: Nov 2013
Posts: 2,321
Quote:
Originally Posted by Jim Flower View Post
I thought the breakers are for your 110 items. The stuff that is not working are on fuses so I would look at your panel again and check the fuses. If they appear ok, pull them in and out in case they are corroded. Jim


Sent from my iPad using Airstream Forums
My 2001 Safari had fuses. My 2002 Classic has breakers for 12 V.

Al
__________________

"You cannot reason someone out of a position they have not been reasoned into"

Al, K5TAN and Missy, N4RGO
2002 Classic 30 Slideout
S/OS #004
2013 Dodge 2500 Laramie 4x4 Megacab Cummins
2001 Safari 25 RB Twin (Gone, but not forgotten)
WBCCI 1322, TAC FL-39, AIR 82265

Al and Missy is offline   Reply With Quote
Old 03-06-2016, 07:16 AM   #6
Prairie Schooner II
 
Jim Flower's Avatar

 
2012 30' International
1997 25' Safari
1967 20' Globetrotter
Burlington , Ontario
Join Date: Jul 2009
Posts: 1,182
Quote:
Originally Posted by Al and Missy View Post
My 2001 Safari had fuses. My 2002 Classic has breakers for 12 V.

Al

Clearly, one should not assume. My 2012 has breakers for the 110 v and fuses for the 12 v. It would appear that the problem was found and the op had a warm night. All is good. Jim


Sent from my iPad using Airstream Forums
__________________

__________________
Jim
Jim Flower is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical probs w electrical to new fridge cooling unit. Surfairstrea Batteries, Univolts, Converters & Inverters 2 05-23-2012 08:24 PM
HELP! Electrical problem FranceyS Electrical - Systems, Generators, Batteries & Solar 6 08-03-2010 03:57 PM
IVOLT?electrical questions. Please help! chasgould Electrical - Systems, Generators, Batteries & Solar 4 12-04-2003 07:01 AM
electrical help. poorboycjs Electrical - Systems, Generators, Batteries & Solar 1 09-16-2003 09:53 PM
Need help!-Finding thread about electrical cord. WayWard Wind Our Community 5 03-25-2003 08:37 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:41 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.