Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-02-2015, 09:12 PM   #15
Don't forget your cat nap
 
Ag&Au's Avatar
 
Port Orchard , Washington
Join Date: May 2009
Posts: 4,464
Images: 1
If all the posts that say the red led means reversed polarity are correct them my cord must be defective. The red light has always been lit my cord since new. I have reverse polarity detection both on my external surge protector and also on an outlet in the trailer which both show normal polarity. I always assumed the red light was a "power on" indicator.

Ken
__________________

__________________
Ag&Au is offline   Reply With Quote
Old 01-03-2015, 07:03 AM   #16
Rivet Master
 
chaseav's Avatar
 
2015 25' FB International
Join Date: Nov 2014
Posts: 514
Ken, well your post is the most comforting... I think. The red light definitely indicates a fault but maybe it's indicating that the fault is within the head and it cannot guarantee that it's sensing a polarity reversal. How big of a problem is reverse polarity though... are campgrounds electrical systems that shoddy? Wouldn't a polarity reversal be indicative only of a really lousy electrician?
__________________

__________________
chaseav is offline   Reply With Quote
Old 01-07-2015, 09:38 PM   #17
Rivet Master
 
chaseav's Avatar
 
2015 25' FB International
Join Date: Nov 2014
Posts: 514
The dealer says its a faulty cord. There is a recall on it and they will inspect and likely replace the cord and anything else that is associated with it. They have been fantastic to work with so far.
__________________
chaseav is offline   Reply With Quote
Old 01-07-2015, 10:55 PM   #18
Don't forget your cat nap
 
Ag&Au's Avatar
 
Port Orchard , Washington
Join Date: May 2009
Posts: 4,464
Images: 1
Quote:
Originally Posted by chaseav View Post
The dealer says its a faulty cord. There is a recall on it and they will inspect and likely replace the cord and anything else that is associated with it. They have been fantastic to work with so far.
What year and model trailer do you have? Perhaps I also have a defective cord. Although in my case it's not hurting any thing.

Ken
__________________
Ag&Au is offline   Reply With Quote
Old 01-08-2015, 03:50 AM   #19
Vintage Kin
 
slowmover's Avatar
 
Fort Worth , Texas
Join Date: Nov 2006
Posts: 7,598
Images: 1
Only men believe their defects aren't hurting anything. This is the reason for wives.
__________________
1990 35' Silver Streak Sterling; 9k GVWR.
2004 DODGE Cummins 305/555; 6-manual; 9k GVWR.
Hensley Arrow. 9-cpm solo, 15-cpm towing
Sold: Silver Streak Model 3411
slowmover is offline   Reply With Quote
Old 01-10-2015, 10:45 PM   #20
Rivet Master
 
chaseav's Avatar
 
2015 25' FB International
Join Date: Nov 2014
Posts: 514
I have a 2015 Intl Signature 25FB. Took it to the dealer, they tested it using a different cord and determined it was a faulty cord. There is a recall on the Furion system but mine was fixed prior to delivery. This is unrelated. I didn't bother to get a new cord... If a false red condition is so common, what's the point in having an indicator? I might take it up with Furion direct at some point.
__________________
chaseav is offline   Reply With Quote
Old 01-10-2015, 10:54 PM   #21
Don't forget your cat nap
 
Ag&Au's Avatar
 
Port Orchard , Washington
Join Date: May 2009
Posts: 4,464
Images: 1
Quote:
Originally Posted by chaseav View Post
I have a 2015 Intl Signature 25FB. Took it to the dealer, they tested it using a different cord and determined it was a faulty cord. There is a recall on the Furion system but mine was fixed prior to delivery. This is unrelated. I didn't bother to get a new cord... If a false red condition is so common, what's the point in having an indicator? I might take it up with Furion direct at some point.
I'll probably go back to believing it's a light to tell me when the power is on.

Ken
__________________
Ag&Au is offline   Reply With Quote
Old 01-11-2015, 09:17 PM   #22
Rivet Master
 
chaseav's Avatar
 
2015 25' FB International
Join Date: Nov 2014
Posts: 514
Sounds good to me! Red is right! Errr something.
__________________
chaseav is offline   Reply With Quote
Old 01-19-2015, 08:28 PM   #23
2 Rivet Member
 
ODSCS's Avatar
 
2013 22' FB Sport
Seal Rock , Oregon
Join Date: Sep 2013
Posts: 26
Images: 8
I've noticed over the last 5 months that the blue light on my cord has ceased to work. I have never seen a red light on my cord. Is there a fix to get the blue light back on? My cord is 1 1/2 years old now.
__________________
ODSCS is offline   Reply With Quote
Old 01-19-2015, 09:50 PM   #24
Rivet Master
 
chaseav's Avatar
 
2015 25' FB International
Join Date: Nov 2014
Posts: 514
Get in touch with Furion direct. That's my advice. That's probably outside of their warranty but I'm not sure. I think the light is pretty worthless and for as many problems as I'm hearing of with them, they may end up facing a class action lawsuit over it eventually. Maybe mention that when you call and they'll probably send you a couple cords. .
__________________
chaseav is offline   Reply With Quote
Old 01-24-2015, 09:32 PM   #25
Rivet Master
 
chaseav's Avatar
 
2015 25' FB International
Join Date: Nov 2014
Posts: 514
Update on my cord: it now shows neither light. Completely gone. The blue light at the receptacle on the RV side does work though.
__________________

__________________
chaseav is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Blue Light on Power Cord--is this sucker grounded? CalamityJane Electrical - Systems, Generators, Batteries & Solar 14 09-10-2012 10:45 PM
Red! Red! Red! Can Anyone Tell Me What This is About Now? Fly at Night Batteries, Univolts, Converters & Inverters 23 11-06-2011 02:18 PM
30 amp power cord trouble davidz71 Electrical - Systems, Generators, Batteries & Solar 1 03-12-2003 06:29 PM
External Power Cord Replacement jstaad Electrical - Systems, Generators, Batteries & Solar 3 01-23-2003 07:16 AM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:33 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.