Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-08-2016, 01:30 AM   #15
Rivet Master

 
2014 20' Flying Cloud
Long Island , New York
Join Date: Jun 2015
Posts: 5,880
waldosgone, I see you replied on that older thread, so I have multi-quoted some of the earlier posters there [so they will receive email notifications about being quoted]. Hopefully they will be able to help out here. Good luck on the push north with Chinook!

Have you all been happy with your PD4655, and could you all comment on the noise issue being raised here? We are also considering this upgrade, but want to make sure the noise issue is resolved first.

Thanks,

Peter



Quote:
Originally Posted by Steamy1 View Post
I had purchased and installed a PD4655 for our Bambi several years ago. it worked great with the two-6 volt Lifeline batteries. we could go almost 5-days boon docking, using the furnace in the morning, taking showers, LED reading lights at night, listening to Sirius satellite radio. I had purchased the PD and batteries from Randy at Best converter. The cooling fan hardly ever runs. Maybe just in boost mode after usage with the volts down to 12.06 of so.
we just recently purchased a 2015 23FB, and I wanted to replicate the Bambi system, so I purchased a PD4655, again from Best, and installed it. As soon as I connected it, the cooling fan came on and has run continuously as long as we are plugged it. Thinking the Interstates were shot from sitting on the dealers lot, I installed my Lifelines from the Bambi, which I know are good, and the fan continues to run. Called the PD tech, and they said it was a defective unit, and to return to the retailer for an exchange. Waiting on shipping and return instructions from Best. They gave me the address but no info on the shipping expense. I certainly hope that they would not expect me to pay to return a defective unit.
Quote:
Originally Posted by Al and Missy View Post
With no AC power, mine was flashing. Flash rate may depend on state of charge. I don't remember what mine was doing, but it may have been flashing at a rate other than those defined in the manual.

Al
Quote:
Originally Posted by mrprez View Post
I'll have to check mine to see what is going on when not on shore power.

Sorry, yes it is in Use mode all the time.
Quote:
Originally Posted by KJRitchie View Post
Now that I have a 3 stage converter I leave the Use/Store switch to Use all the time except in storage. I also disconnect the battery while in storage.

So all you PD4655 owners let me know if the Charge Wizard LED is lit when not connected to shore power.

Thanks

Kelvin
Quote:
Originally Posted by Arcticfox View Post
Thanks for the link and answer. When you say you never touch the "use/store Switch" I'm assuming you just leave it in "USE"?
Thanks

Doug
Quote:
Originally Posted by switz View Post
The single stage OEM Parallax converter unit was on my list of things to replace on our new 2013 25FB International Serenity along with the GYM tires as soon as I got the unit home from the dealership in October of 2012.

While the replacement multistage unit fit as advertised, the relocation of the incoming wire connection posts on the new board required some creative efforts to gain several more inches of "loose" wire in order to make those connections under the cross frame queen bed.
Quote:
Originally Posted by waldosgone View Post
Is yours silent or does it make some noise?
__________________

__________________
OTRA15 is offline   Reply With Quote
Old 06-08-2016, 08:59 AM   #16
2 Rivet Member
 
waldosgone's Avatar
 
2015 20' Flying Cloud
Eagle River , Alaska
Join Date: Mar 2016
Posts: 54
Thanks Peter, I didn't know they would get notifications if they were quoted. I'll keep that in my proverbial bag of tricks from now on.

James
__________________

__________________
waldosgone is offline   Reply With Quote
Old 06-08-2016, 09:34 AM   #17
Rivet Master

 
2014 20' Flying Cloud
Long Island , New York
Join Date: Jun 2015
Posts: 5,880
Yes James that trick works even years later, unless they have toggled off their notifications in the User Control Panel. [under Quick Links at top right menu bar] Or unless they have stopped being active here obviously.

You can shorten the quotes by deleting text inside the brackets, and add ellipses to indicate . . . the deletions. This cleans up the look, but I did not have time this morning to do that, so I put my comment above all the quotes.

Also the multi-quote button to the right of the Quote button is helpful in collecting disparate people into one thread. When you multi-quote from different threads, however, you have to look under your text composition box for the site's query about including quotes from other threads. Hard to describe but pretty obvious if you try it a time or two.

Good luck.

Peter
__________________
OTRA15 is offline   Reply With Quote
Old 06-13-2016, 03:43 AM   #18
Rivet Master

 
2014 20' Flying Cloud
Long Island , New York
Join Date: Jun 2015
Posts: 5,880
FYI another PD4655 installation, where I linked this thread for comment.

http://www.airforums.com/forums/f449...-a-152200.html

Hope Chinook is finding favorable winds heading north!

Peter
__________________
OTRA15 is offline   Reply With Quote
Old 06-13-2016, 05:42 AM   #19
Rivet Master

 
2014 20' Flying Cloud
Long Island , New York
Join Date: Jun 2015
Posts: 5,880
Quote:
Originally Posted by waldosgone View Post
Thanks Peter, I didn't know they would get notifications if they were quoted. I'll keep that in my proverbial bag of tricks from now on.

James
Michael reports in that other thread that the mfg. has fixed the problem FWIW.

Hope that Chinook is finding favorable winds on the way North!

Peter
__________________
OTRA15 is offline   Reply With Quote
Old 07-10-2016, 04:24 AM   #20
Rivet Master

 
2014 20' Flying Cloud
Long Island , New York
Join Date: Jun 2015
Posts: 5,880
Quote:
Originally Posted by waldosgone View Post
Is yours silent or does it make some noise?
Wondering if you got this noise sorted out, and how your trip north is going? We are considering the Progressive upgrade.

Thanks,

Peter
__________________
OTRA15 is offline   Reply With Quote
Old 07-31-2016, 12:08 PM   #21
2 Rivet Member
 
waldosgone's Avatar
 
2015 20' Flying Cloud
Eagle River , Alaska
Join Date: Mar 2016
Posts: 54
Quote:
Originally Posted by OTRA15 View Post
Wondering if you got this noise sorted out, and how your trip north is going? We are considering the Progressive upgrade.

Thanks,

Peter
Peter,

To close out my portion of the thread. I installed the replacement unit PD sent to me while I was stopped in Seattle. The noise was still there when I plugged the trailer in but we had to press north for timing...

The more we used the trailer the noise stopped and now appears occasionally. As we're using Chinook quite a bit in Alaska during the summer this may wait to the fall/winter to remove/replace (R2 from my flying days) the PD with another unit under warranty.

I do like that we've been able to keep Chinook plugged in, in our driveway, for the last several weeks. It's nice to have the fridge ready to go after work on Friday!

I'll keep this thread in mind as I shake out the PD unit. Of note, I just sold my Parallax 7355 for $200 on eBay... effectively making this a $12.97 (plus my time) upgrade. I'd say it's well worth it to learn more about the electrical system on the trailer.

James
__________________
waldosgone is offline   Reply With Quote
Old 07-31-2016, 01:43 PM   #22
Rivet Master
 
2005 19' Safari
GLENDALE , AZ
Join Date: Aug 2004
Posts: 2,436
Power supplies use "magnetics" in the form of transformers, toroid coils, etc., which can draw a lot of current. If the magnet wire is not securely bonded in place (called potting or varnishing), individual wire strands can vibrate due magnetic field fluctuation. The resultant sound can be humming, hissing, etc., with the frequency varying according to the the circuitry on the printed circuit board.

It's possible that there are some defective magnetics in the converter.
__________________
Phoenix is offline   Reply With Quote
Old 08-03-2016, 08:20 AM   #23
TahoeStream'n
 
subfan1's Avatar
 
2012 20' Flying Cloud
La Habra , California
Join Date: Jul 2007
Posts: 827
Images: 3
Thanks For the description. My charger was ok until Sunday when after I unplugged it from shore power the blinking LED charging light indicator still kept blinking. I'm in Yosemite right now dry camping and the light is still blinking. Has anyone experienced this?
__________________
subfan1 is offline   Reply With Quote
Old 08-03-2016, 12:20 PM   #24
Rivet Master

 
2014 20' Flying Cloud
Long Island , New York
Join Date: Jun 2015
Posts: 5,880
Thanks James, I have been out of town and just saw this reply. Sounds like a good plan, and yes your net cost would be hard to pass up!

subfan1, hope your charger is OK, and that you are having fun in . Do you have the intstruction manual with you? Wondering what the yellow light means . . .

Happy Trails,

Peter


Quote:
Originally Posted by waldosgone View Post
Peter,

To close out my portion of the thread. I installed the replacement unit PD sent to me while I was stopped in Seattle. The noise was still there when I plugged the trailer in but we had to press north for timing...

The more we used the trailer the noise stopped and now appears occasionally. As we're using Chinook quite a bit in Alaska during the summer this may wait to the fall/winter to remove/replace (R2 from my flying days) the PD with another unit under warranty.

I do like that we've been able to keep Chinook plugged in, in our driveway, for the last several weeks. It's nice to have the fridge ready to go after work on Friday!

I'll keep this thread in mind as I shake out the PD unit. Of note, I just sold my Parallax 7355 for $200 on eBay... effectively making this a $12.97 (plus my time) upgrade. I'd say it's well worth it to learn more about the electrical system on the trailer.

James
Quote:
Originally Posted by subfan1 View Post
Thanks For the description. My charger was ok until Sunday when after I unplugged it from shore power the blinking LED charging light indicator still kept blinking. I'm in Yosemite right now dry camping and the light is still blinking. Has anyone experienced this?
__________________
OTRA15 is offline   Reply With Quote
Old 08-03-2016, 12:36 PM   #25
4 Rivet Member
 
steverino's Avatar
 
2010 27' FB Flying Cloud
Ivins , Utah
Join Date: Aug 2009
Posts: 275
Images: 3
V


Sent from my iPhone using Airstream Forums
steverino is offline   Reply With Quote
Old 08-03-2016, 10:26 PM   #26
TahoeStream'n
 
subfan1's Avatar
 
2012 20' Flying Cloud
La Habra , California
Join Date: Jul 2007
Posts: 827
Images: 3
Thanks for the suggestion on the manual yes I have the user guide but is of little help in terms of troubleshooting. The blinking LED light is only supposed to blink when connected to shore power and is off when dry camping.
__________________
subfan1 is offline   Reply With Quote
Old 08-05-2016, 03:00 PM   #27
TahoeStream'n
 
subfan1's Avatar
 
2012 20' Flying Cloud
La Habra , California
Join Date: Jul 2007
Posts: 827
Images: 3
Just an update to my previous comment. I called customer service at PD this morning and asked service rep regarding blinking green LED without shore power and they told me that was normal. The part that still puzzles me is that same indicator light is used to determine charge rates when connected to shore power. Again she said it was normal.
__________________
subfan1 is offline   Reply With Quote
Old 08-05-2016, 05:23 PM   #28
Rivet Master

 
2014 20' Flying Cloud
Long Island , New York
Join Date: Jun 2015
Posts: 5,880
Thanks for the update.
__________________

__________________
OTRA15 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Progressive Dynamics PD4655 Converter/Charger thinairflyer Airstream Classifieds 0 04-23-2016 05:42 PM
Progressive Dynamics 4045 Converter soldiermedic Batteries, Univolts, Converters & Inverters 18 07-15-2011 06:10 AM
Progressive Dynamics Inteli-Power 4060 Power Center 68 Overlander Commercial Listings 0 01-21-2011 11:24 PM
Bad PROGRESSIVE DYNAMICS INTELI POWER 45A mountainman1 Batteries, Univolts, Converters & Inverters 5 09-08-2010 05:54 AM
New Progressive Dynamics convertor, AGM battery, and Pendant questions wacnstac Batteries, Univolts, Converters & Inverters 16 05-09-2007 09:12 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:47 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.