Thread Tools Search this Thread Display Modes
Old 08-28-2010, 08:32 AM   #1
1 Rivet Member
Hendrick2488's Avatar
1966 26' Overlander
Cedar Falls , Iowa
Join Date: Aug 2010
Posts: 13
Images: 5
Outside outlets

I have a 28ft 1966 Overlander Twin. While checking to see if the outlets outside were working I plugged in a device, it worked, I heard a pop and both outlets outside are now dead. Everything else inside the trailer works except maybe the fridge. I noticed that the fridge and something else are actually plugged into an outlet inside the access panel. I can't find any blown fuses but don't know much about the unit because we just got it.

Can someone offer advice on what to look for or how to fix?

Thanks in advance.

Hendrick2488 is offline   Reply With Quote
Old 08-28-2010, 01:30 PM   #2
Join Date: Jun 2010
Posts: 2,601
It sounds like a GFI ( Ground Fault Interupter) has tripped. Look at the outlet outside and in the bathroom. If the PO had installed a new outlet in either location it may have tripped. There should be two little buttons in between the two outlets. One is marked TEST and theother is marked RESET. Push the reset and you should have power.

wasagachris is offline   Reply With Quote
Old 08-29-2010, 05:00 AM   #3
1 Rivet Member
Hendrick2488's Avatar
1966 26' Overlander
Cedar Falls , Iowa
Join Date: Aug 2010
Posts: 13
Images: 5
Thanks for the reply. My father-in-law, and electrician, came to see the camper and looked into the problem.

He found the circuit breakers inside the box in the bathroom, weren't tightened down in the box correctly. Although they were in the proper position, they were loose and not making a good enough connection. Problem solved.

Thanks again for your reply. Now that the electrical system works, its off to the water system. Cross your fingers. :-)
Hendrick2488 is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
All outlets not working NicheVintage Lights - Interior & Exterior 11 09-16-2011 10:42 AM
Where have all the outlets gone - 2003 Classic. wxbuoy 2001 - 2005 Classic 8 12-07-2009 02:45 PM
12-volt outlets Steve & Susan Lights - Interior & Exterior 1 09-17-2008 06:21 AM
110V outlets cookeville34 Electrical - Systems, Generators, Batteries & Solar 2 09-17-2006 07:15 AM
warm outlets markus Electrical - Systems, Generators, Batteries & Solar 5 11-29-2003 04:06 PM

Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:24 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.