Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-09-2013, 04:34 PM   #1
New Member
 
1972 29' Ambassador
Waverly , Ohio
Join Date: Jan 2013
Posts: 2
no shore power through Univolt

I have 115 volts going into my univolt at the bottom, the univolt is humming, I have power to my lights inside with the trailer battery but the battery runs dead when plugged into shore power. Bad Univolt?? Any suggestions on what else to check if anything? Thanks
__________________

Horsley1 is offline   Reply With Quote
Old 01-09-2013, 04:40 PM   #2
Well Preserved

 
1993 21' Sovereign
Colfax , North Carolina
Join Date: Jun 2003
Posts: 20,358
Fuses, especially the 50 amp ground fuse.
__________________

__________________
Meddle not in the affairs of dragons, for you are crunchy, and taste good with ketchup.
Terry
overlander63 is offline   Reply With Quote
Old 01-10-2013, 08:54 AM   #3
New Member
 
1972 29' Ambassador
Waverly , Ohio
Join Date: Jan 2013
Posts: 2
Quote:
Originally Posted by Horsley1 View Post
I have 115 volts going into my univolt at the bottom, the univolt is humming, I have power to my lights inside with the trailer battery but the battery runs dead when plugged into shore power. Bad Univolt?? Any suggestions on what else to check if anything? Thanks
It's hard to get to that fuse but I will check it this evening but if I have power from my battery running my 12 volt system wouldn't that fuse be ok? I'm not sure... Everything works as it should except when plugged into shore power it's not charging the battery or running the 12 volt system. It continues to work just off the battery until I unhook the battery then I lose all 12 volt power.
Horsley1 is offline   Reply With Quote
Old 01-10-2013, 10:31 AM   #4
Rivet Master
 
TG Twinkie's Avatar
 
1974 Argosy 26
Morrill , Nebraska
Join Date: Nov 2009
Posts: 5,265
Images: 2
Blog Entries: 5
If it is the original Univolt. It may be a good time to upgrade.
__________________
Knowledge: "A gift to be shared. A treasure to receive."
TG Twinkie is online now   Reply With Quote
Old 01-10-2013, 01:38 PM   #5
Site Team
 
azflycaster's Avatar
 
2002 25' Safari
Dewey , Arizona
Join Date: Mar 2005
Posts: 12,400
Images: 62
Blog Entries: 1
Quote:
Originally Posted by TG Twinkie View Post
If it is the original Univolt. It may be a good time to upgrade.
If it is the original Univolt, it is always a good time to upgrade...
__________________

Richard

Wally Byam Airstream Club 7513
azflycaster is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shore power requirments for trailers Mrcrowley Generators & Solar Power 21 08-02-2017 05:20 AM
Electrical: Shore power wont work SteveandSam Classic Motorhomes 3 01-15-2012 07:31 PM
Weird Univolt noise (no not the hum) and power flicker ovrteakettle Batteries, Univolts, Converters & Inverters 12 12-07-2011 11:31 PM
Complacency In Today’s Economy Spells Vanishing Tanks and/or Shore Power Cords! overlander64 Our Community 34 08-18-2011 11:58 AM
HUM from radio when hooked to shore power The Driver Audio, Video & TV 5 07-12-2011 05:42 AM


Featured Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.