Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-18-2013, 05:01 PM   #1
janeinthemtns
 
1985 31' Excella
near Chama , New Mexico
Join Date: Jun 2013
Posts: 163
Images: 5
Blog Entries: 2
Loud buzzer when plugged in

I just plugged in my 85 Excella for the first time. A very loud buzzer went off inside the trailer. I could see the overhead light was on, but I unplugged it until I can figure out what is going on. The batteries are properly connected and I'm plugging it into a 20 amp outlet in the house. I don't need the microwave or AC. The 30 amp plug coming out of the back of the trailer is plugged into a converter, then into the same extension cord both the PO and Holiday Trailer in Albuquerque used. Everything worked perfectly with no deafening and scarey buzzing sound.

Help please!
__________________

__________________
janeinthemtns is offline   Reply With Quote
Old 08-18-2013, 05:26 PM   #2
4 Rivet Member
 
KeithC's Avatar
 
1994 34' Excella
1978 31' Sovereign
Mansfield , Georgia
Join Date: Mar 2007
Posts: 261
I have a 1994 34' Excella and have not encountered the buzzing you described. The only thing I can think of is that a previous owner direct wired a smoke alarm, that the back-up battery is dead, yet when you plug in to power, it activates the alarm to let you know the battery needs replacement. I would suggest you plug in and letting it buzz while you search the interior of the trailer to identify the source.
__________________

__________________
Tac GA-20
Air Forums 20320
KeithC is offline   Reply With Quote
Old 08-19-2013, 06:49 AM   #3
janeinthemtns
 
1985 31' Excella
near Chama , New Mexico
Join Date: Jun 2013
Posts: 163
Images: 5
Blog Entries: 2
Good idea. It does sound like it might be a smoke alarm sound. I've got the covers off of everything because I'm painting. Maybe that's it.
__________________
janeinthemtns is offline   Reply With Quote
Old 08-19-2013, 11:08 AM   #4
janeinthemtns
 
1985 31' Excella
near Chama , New Mexico
Join Date: Jun 2013
Posts: 163
Images: 5
Blog Entries: 2
It was the gas and pollution alarm! I guess the paint set it off.
__________________
janeinthemtns is offline   Reply With Quote
Old 08-19-2013, 02:49 PM   #5
4 Rivet Member
 
KeithC's Avatar
 
1994 34' Excella
1978 31' Sovereign
Mansfield , Georgia
Join Date: Mar 2007
Posts: 261
Quote:
Originally Posted by janeinthemtns View Post
It was the gas and pollution alarm! I guess the paint set it off.
Great. I'm glad you found the culprit
__________________
Tac GA-20
Air Forums 20320
KeithC is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:46 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.