Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-24-2014, 05:38 PM   #1
http://airstreamorama.com
 
Ljsydney's Avatar
 
2013 27' FB International
Palm Springs , California
Join Date: Oct 2012
Posts: 61
Inverter Switches Off After a Couple of Minutes

I've just pulled into a site with no shore power and as I was setting up I switched on the inverter (via the remote button in in the galley) and ran the auto program of the TV(s). Midway, the TV's turned off and although the remote button LED remained lit and green, I could hear the inverter was no longer operating. I tested it on a lamp and it did the same then again with nothing drawing on the inverter. Each time it stopped operating after about two minutes. I'd used the inverter about two weeks ago for a week with no issues. Does anyone have any insight as to what the problem may be? Thanks.
__________________

__________________
Ljsydney is offline   Reply With Quote
Old 03-24-2014, 06:48 PM   #2
Rivet Master
 
richw46's Avatar
 
2006 23' Safari SE
Lexington , Kentucky
Join Date: Dec 2012
Posts: 2,175
Images: 6
Check all connections, make sure everything is tight, especially the heavy gauge wires from the battery to the inverter. Check the battery connections for the inverters, make sure they are not corroded and are tight. Make sure the inverter air intake isn't blocked and that the inverter cooling fan is running when it's turned on. Make sure nothing else is plugged into the inverter outlets that could be pulling more wattage than the inverter's capacity.
__________________

__________________
-Rich

Rich & Yvonne
2006 Safari SE -Dora-
2004 4Runner SE

richw46 is offline   Reply With Quote
Old 03-24-2014, 06:53 PM   #3
Rivet Master
 
GeocamperAS's Avatar
 
1974 Argosy 28
1978 Argosy Minuet 6.0 Metre
Wauwatosa , Wisconsin
Join Date: Oct 2010
Posts: 725
Images: 37
What Rich said.
Also if the supply voltage to the inverter (the battery) is low, the inverter will shut down.
__________________
Judging a person does not define who they are, it defines who YOU are.
GeocamperAS is offline   Reply With Quote
Old 03-24-2014, 07:01 PM   #4
Rivet Master
 
dkottum's Avatar
 
2012 25' Flying Cloud
Battle Lake , Minnesota
Join Date: Jun 2009
Posts: 7,716
First ensure the batteries are not run down.

Some inverters will shut down if they get too hot to protect themselves. Mine is located behind the converter which has a fan to cool itself, but not the compartment that it and the converter are mounted in. If it's pretty warm there today and the sun is shining on that side of the trailer, maybe. It is here in southern AZ today. There may be an access door under a seat cushion to open and cool things.
__________________
Doug and Cheryl
2012 FC RB, Michelin 16, ProPride 1400
2016 Ram 1500 Laramie Crew Cab 4X4 Ecodiesel 3.92 axles

The Truth is More Important Than the Facts
dkottum is offline   Reply With Quote
Old 03-24-2014, 07:04 PM   #5
Don't forget your cat nap
 
Ag&Au's Avatar
 
Port Orchard , Washington
Join Date: May 2009
Posts: 4,464
Images: 1
Do you know for sure that your tow vehicle is keeping the trailer batteries charged sufficiently while you are driving? If not there can be many factors causing that, so the campground is probably not a good place to trouble shoot it. I had a tow vehicle once that had a charging wire to the trailer connector that was not large enough to keep up with the normal trailer battery use while driving.

Ken
__________________
Ag&Au is offline   Reply With Quote
Old 03-24-2014, 08:08 PM   #6
Rivet Master
 
1974 Argosy 20
2014 20' Flying Cloud
Kooskia , Idaho
Join Date: Jul 2009
Posts: 4,591
I also suspect shutdown due to low battery voltage. Discharged batteries that is.
__________________
idroba is offline   Reply With Quote
Old 03-24-2014, 08:56 PM   #7
http://airstreamorama.com
 
Ljsydney's Avatar
 
2013 27' FB International
Palm Springs , California
Join Date: Oct 2012
Posts: 61
Thanks all…I tried it about an hour ago and it is mysteriously working now. The batteries were fully charged…I have solar panels and had just been plugged in to shore power and drove 1.5 hours. It could have been the heat issue…the inverter is mounted inside the front storage compartment of my 27FB (I had a battery upgrade and the inverter added and that's where the dealer placed it)…that side was getting the Western sun and it was mid-70's. I'll keep monitoring it and do a test tomorrow in the afternoon to see if at some point it cuts out again.
__________________
Ljsydney is offline   Reply With Quote
Old 03-24-2014, 10:18 PM   #8
Don't forget your cat nap
 
Ag&Au's Avatar
 
Port Orchard , Washington
Join Date: May 2009
Posts: 4,464
Images: 1
Quote:
Originally Posted by Ljsydney View Post
Thanks all…I tried it about an hour ago and it is mysteriously working now. The batteries were fully charged…I have solar panels and had just been plugged in to shore power and drove 1.5 hours. It could have been the heat issue…the inverter is mounted inside the front storage compartment of my 27FB (I had a battery upgrade and the inverter added and that's where the dealer placed it)…that side was getting the Western sun and it was mid-70's. I'll keep monitoring it and do a test tomorrow in the afternoon to see if at some point it cuts out again.
Aw, c'mon, you can't spoil all the fun we were having coming up with electronic conspiracy theories. At least you could have lied about it and said you were following all our leads and it still wasn't working.

Anyway, enjoy your camping trip.

Ken
__________________
Ag&Au is offline   Reply With Quote
Old 03-24-2014, 10:23 PM   #9
Rivet Master
 
mefly2's Avatar
 
2015 25' FB Eddie Bauer
Western , ** Big Sky Country ** Montana
Join Date: Feb 2010
Posts: 2,283
Let us know what you find out ... if the dealer did the install ... check with them ??? Are you sure of the wiring from the inverter to the receptacle feeding the gear that is shutting down?
__________________
mefly2 is offline   Reply With Quote
Old 03-25-2014, 10:28 AM   #10
Rivet Master
 
richw46's Avatar
 
2006 23' Safari SE
Lexington , Kentucky
Join Date: Dec 2012
Posts: 2,175
Images: 6
Quote:
Originally Posted by Ljsydney View Post
Thanks all…I tried it about an hour ago and it is mysteriously working now. The batteries were fully charged…I have solar panels and had just been plugged in to shore power and drove 1.5 hours. It could have been the heat issue…the inverter is mounted inside the front storage compartment of my 27FB (I had a battery upgrade and the inverter added and that's where the dealer placed it)…that side was getting the Western sun and it was mid-70's. I'll keep monitoring it and do a test tomorrow in the afternoon to see if at some point it cuts out again.
It sounds to me that you have a loose connection. It's possible that it got overheated and reset itself but you said that after only a few minutes it shut down. That sounds more like a low battery symptom and that can be caused by a loose connection. I think you should check all the connections on the inverter, the in-line fuse and the battery cables.
__________________

__________________
-Rich

Rich & Yvonne
2006 Safari SE -Dora-
2004 4Runner SE

richw46 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bedroom Lights Don't Turn On/Turn Off and turn back on after a couple minutes. alecg Lights - Interior & Exterior 9 09-01-2010 03:01 PM
Dometic fix took 35 minutes :) Kistler Refrigerators 12 06-15-2007 07:21 PM
Using OnStar phone with Family Share minutes Airstream25 On The Road... 2 07-01-2006 09:32 AM
It take 5 minutes to get the gas flowing to my fridge, water heater, etc. TBKP's Overlander LP Gas, Piping, Tanks & Regulators 8 04-15-2003 11:00 PM
help!!! i just typed for 20 minutes and my post was lost vbob Airstream Motorhome Forums 4 03-02-2003 09:03 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:25 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.