Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-03-2005, 11:45 PM   #1
Van
4 Rivet Member
 
1977 23' Safari
Hillsboro , Oregon
Join Date: Aug 2003
Posts: 348
Images: 25
GFI breaker keeps tripping.

For some reason now when i plug in the power to the trailer, the GFI breaker in the circuit box keeps tripping. No clue why it would be doing this. It was working fine last time i checked. All the fuses are in good condition, no corrosion anywhere. There may be some fraying inside the plug to the power cord, but nothing major.

Anyone have an suggestions i could take a look at?
__________________

__________________
Van
2009 F-350 FX4 Crewcab 4x4 6.4l
former '78 Argosy 20' Minuet owner
former '77 23' Safari owner
former 25' Fun Finder X-250BHS SOB owner
current 26' Komfort Trailblazer 262BSLE SOB owner
Van is offline   Reply With Quote
Old 08-04-2005, 05:01 AM   #2
3 Rivet Member
 
1993 29' Excella
Jonesboro , Louisiana
Join Date: Apr 2002
Posts: 125
Van,
The problem is most likely in the circuit being fed by the GFI. If the breaker itself is good then you have a short or a ground in this circuit. A process of elimination might find the problem. First check the breaker itself by disconnecting the load wire from it and then turn the power back on. If the breaker trips then it is probably bad. If not go on to the recepticles and disconnect them and/or inspect them , one by one, to see if you can find a wire that has been rubbed or is in the wrong place.
If you don't feel comfortable working with electricity-get someone who is qualified to do it for you as you are messing around with energized circuitry!!!!
__________________

__________________
James Schmidt
29 ft Excello 1000
97 Expedition/Hensley Hitch/
McKesh mirrors
James Schmidt is offline   Reply With Quote
Old 08-04-2005, 05:09 PM   #3
Van
4 Rivet Member
 
1977 23' Safari
Hillsboro , Oregon
Join Date: Aug 2003
Posts: 348
Images: 25
Something mighty weird is going on it seems. Now it isnt doing anything. No power to any part of the trailer when going through the plug. The GFI circuit breaker doesnt trip. Completely dead. However if i hook the battery back up those things that will run off the battery do so.

Could it be as simple as the head of the power cord has somehow gone bad?
__________________
Van
2009 F-350 FX4 Crewcab 4x4 6.4l
former '78 Argosy 20' Minuet owner
former '77 23' Safari owner
former 25' Fun Finder X-250BHS SOB owner
current 26' Komfort Trailblazer 262BSLE SOB owner
Van is offline   Reply With Quote
Old 08-04-2005, 07:17 PM   #4
Rivet Master
 
davidz71's Avatar
 
1986 25' Sovereign
Southern Middle , Tennessee
Join Date: Mar 2002
Posts: 3,150
Images: 23
That is what happened to the power cord plug in mine. The blades were loose and tripping the campground GFCI and the one in my garage. Replacement of the head cured the problem.
__________________
Craig

AIR #0078
'01 2500hd ext. cab, 8.1 litre gas, 5 sp. Allison auto
3.73 rear end
Mag-Hytec rear diff cover
Amsoil Dual by-pass oil filtration system
Amsoil synthetics all around
265 watt AM Solar, Inc. system
davidz71 is offline   Reply With Quote
Old 08-04-2005, 10:05 PM   #5
2 Rivet Member
 
Join Date: May 2005
Posts: 24
GFCI problems

When my voltage goes to none there shuold be an electrical owl somewhere who goes WHOOO. But all in all, symptoms you talk about are exactly signs of a poor circuit that first pops a breaker and then is non-existent because the short burned through and won't conduct. If changing the cord-cap, (plug end) on the plug-in works I would also check the other end or perhaps buy a new cord because one end going signifies some poor condition in the cord. Cords cost 10-20 bucks and a new airstream costs??????
__________________
bdlwet is offline   Reply With Quote
Old 08-04-2005, 10:19 PM   #6
Really Cheap
 
tmcdougald's Avatar
 
Join Date: Nov 2004
Posts: 37
Images: 7
Most likely a bad ground thatís how those things work they detect the slightest millivolt on the ground and cut the circuit.
When I worked for a company that built mobile command vehicles we had a heck of a time trying to figure out why the GFCIs were constantly tripping. It turns out that the when the police radios we installed were keyed the radio energy was strong enough to trip all of the GFCI all at once.
__________________
Jevons paradox: Increases in efficiency lead to even larger increases in demand.(Basically means that there is no hope for the energy and resource problems on this planet.)
tmcdougald is offline   Reply With Quote
Old 08-05-2005, 12:45 AM   #7
3 Rivet Member
 
desi arnaz's Avatar
 
Join Date: Jun 2005
Posts: 183
mine trips when i plug the fridge in?
__________________
desi arnaz is offline   Reply With Quote
Old 08-05-2005, 04:37 AM   #8
3 Rivet Member
 
1993 29' Excella
Jonesboro , Louisiana
Join Date: Apr 2002
Posts: 125
This may help---A GFI breaker measures (exactly) the amps going into it via the hot leg and the amps going out of it via the ground leg. When they are equal, eveything works fine. When they do not equal, the breaker trips. This indicates that a leak(short or bad part) is making a circuit to the ground and bypassing the ground wire. This creates a shock hazard and should be corrected. Therefore the GFI is working properly to trip under these conditions. It does not have to be a large leak and is most often intermittent and can be hard to find. Isolating the circuits one at a time and then testing usually is the best way to narrow it down. If it is your trailer GFI that is tripping, the problem is downstream(electrically) from the GFI and most probably not your main cord. If it is the campground GFI that is tripping, then it could be the trailer cord. Nothing working on AC could be a cord problem, a campground supply problem or a problem in the trailer AC panel(Main breaker tripped, etc). Again, be extra careful when trouble shooting energized circuitry-get some help if you are not comfortable with it and good luck--let us know what you find.
__________________
James Schmidt
29 ft Excello 1000
97 Expedition/Hensley Hitch/
McKesh mirrors
James Schmidt is offline   Reply With Quote
Old 08-06-2005, 11:52 AM   #9
Van
4 Rivet Member
 
1977 23' Safari
Hillsboro , Oregon
Join Date: Aug 2003
Posts: 348
Images: 25
Well, here is where it stands now.


Replaced the head of the cord and then i reset all the circuit breakers and plugged the cord back in after making sure everything in the trailer was turned off.

Overhead fan works
Overhead light works
Waterpump works
Waterheater fires up
Refrig in electric mode......

pops the breaker.


Refrig is in poor shape anyway. It will run on gas just fine it seems.

Furthermore the overhead fan is slower and the overhead light is dimmer than if they were running on battery power. Leads me to think the converter is going bad.

So, what does the assembled Airstreamforums hive mind make of this?


My course of action is thus:

Have a 4 day trip planned next week and very little time to work on the trailer after my work day. I am planning on just leaving the refrig on gas during our trip and then on our return replacing the converter and the refrig, which should have been done long before we aquired the trailer.

Thanks for the replies, been a big help.
__________________
Van
2009 F-350 FX4 Crewcab 4x4 6.4l
former '78 Argosy 20' Minuet owner
former '77 23' Safari owner
former 25' Fun Finder X-250BHS SOB owner
current 26' Komfort Trailblazer 262BSLE SOB owner
Van is offline   Reply With Quote
Old 08-06-2005, 12:20 PM   #10
Just a member
 
thenewkid64's Avatar
 
1978 28' Argosy 28
Tampa Bay , Florida
Join Date: Mar 2002
Posts: 4,539
Images: 21
Send a message via AIM to thenewkid64 Send a message via Yahoo to thenewkid64 Send a message via Skype™ to thenewkid64
Sounds like the electric heating element on the refer is a goner. If the exterior casing on the heater element is gone(corrosion, rust, wear) and is contacting the coolant tube you will have a short to ground. The GFI pops to save you from a possible lethal voltage hit.

The heating elements are not hard to replace per say. The refer normally has to be de-installed to make this repair so it becomes the case of the $25 part costing $300 to install. If you are handy this can be a DIY repair.

Before tossing the univolt I would have the battery checked. The newer intellipowers are great and they make no hum.
__________________
Brett G
WBCCI #5501 AIR # 49
-------------------------
1978 Argosy 28 foot Motorhome

Wise men talk because they have something to say; fools, because they have to say something. -- Plato


thenewkid64 is offline   Reply With Quote
Old 08-07-2005, 12:33 AM   #11
Van
4 Rivet Member
 
1977 23' Safari
Hillsboro , Oregon
Join Date: Aug 2003
Posts: 348
Images: 25
Quote:
Originally Posted by thenewkid64
Sounds like the electric heating element on the refer is a goner. If the exterior casing on the heater element is gone(corrosion, rust, wear) and is contacting the coolant tube you will have a short to ground. The GFI pops to save you from a possible lethal voltage hit.

The heating elements are not hard to replace per say. The refer normally has to be de-installed to make this repair so it becomes the case of the $25 part costing $300 to install. If you are handy this can be a DIY repair.

Before tossing the univolt I would have the battery checked. The newer intellipowers are great and they make no hum.

Thanks for the info. I am somewhat handy and have done all the work on the trailer so far, but... i have no clue as to the removal and install of the refrig. I certainly dont want to fork out for a shop to do it but am not afraid to admit if something is beyond my skills.

As for the battery and converter, i decided to toss the battery and get a new one. The old one had no date marks to tell me how old it was and was looking pretty old. I just decided to get a new one that way i had yet one more piece that i knew exactly how old it was and there was no question to its reliability.
__________________

__________________
Van
2009 F-350 FX4 Crewcab 4x4 6.4l
former '78 Argosy 20' Minuet owner
former '77 23' Safari owner
former 25' Fun Finder X-250BHS SOB owner
current 26' Komfort Trailblazer 262BSLE SOB owner
Van is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C blowing the breaker Chuck Furnaces, Heaters, Fireplaces & Air Conditioning 13 07-08-2003 11:52 AM
Rallies for M - F working class in SoCal GoldFever Forum Rallies & Meet Ups 54 12-10-2002 12:54 PM
Converter Breaker? Sav'h Steve Electrical - Systems, Generators, Batteries & Solar 7 11-18-2002 09:45 AM
Should I replace the fuse box with a breaker panel? Andy R Electrical - Systems, Generators, Batteries & Solar 2 09-13-2002 11:21 PM
New circuit breaker strip FrankR Electrical - Systems, Generators, Batteries & Solar 0 03-27-2002 11:25 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:33 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.