Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-03-2005, 01:22 PM   #1
1 Rivet Member
 
1976 31' Excella 500
1976 Argosy 20
Flagstaff , Arizona
Join Date: Sep 2005
Posts: 9
Electrical Receptacles don't work now

Am owner of a 76 Airstream International for less than a month. For inane reasons, not worth an explanation, I had to unplug and replug in the power cord from the trailer to the house several times this weekend. After one of these unplugging and replugging events, I noticed the Bathroom receptacle (rear bath) and Bedroom receptacle were not working although the overhead lights in both rooms were working, and receptacles in the forward quarters were working. After a subsequent unplugging and replugging, none of the receptacles worked but the overhead lights in the entire trailer and refrid were working. Can any one figure out what is wrong and how to fix it?? I did check the fuses (none were blown) and the switch box (none were tripped)
P.S. The power cord from the trailer is at present connected to the house by means of a 3 pronged receptable from the house, an adaptor and then the power cord. Thank you for any help. Am an older single woman and dont know much about this stuff. Hope I didnt seriously mess up!
__________________

__________________
goldenlily is offline   Reply With Quote
Old 10-03-2005, 01:39 PM   #2
Patriotic
 
Chuck's Avatar

 
1973 23' Safari
North of Boston , Massachusetts
Join Date: May 2002
Posts: 4,533
Images: 260
the overhead lights are on the 12v circuit, so their power is coming from the battery.

the 110v receptacles work via the circuit breaker panel. one of those circuits has tripped...or, the breaker that governs the circuit on which your external extension cord that is providing power to the trailer has tripped. (not hard to do with a long extension cord).

Its hard to tell if a circuit breaker has tripped just by looking at it. best to switch it all the way in one direction, then all the way back to the other to make sure its re-set properly.
__________________
Air:291
Wbcci: 3752
'73 Safari 23'
'00 Dodge Ram 1500 4x4 QC
Chuck is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical problem--99 safari Andrew Carey Electrical - Systems, Generators, Batteries & Solar 2 11-16-2002 03:04 PM
marker lights dont work wb13798 Mechanics Corner - Engines, Transmission & More... 6 11-09-2002 12:40 PM
electrical system 67 tradewind boardsander Electrical - Systems, Generators, Batteries & Solar 3 10-14-2002 05:32 PM
Wiring for electrical horn on 310 shelocta Airstream Motorhome Forums 3 09-03-2002 10:40 PM
Electrical problem resolved davidz71 Electrical - Systems, Generators, Batteries & Solar 5 08-12-2002 09:21 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.