Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-08-2012, 07:50 AM   #1
New Member
 
2012 16' Sport
Fairbanks , Alaska
Join Date: Jun 2012
Posts: 2
Electrical outlets not working 16' Sport

We've got a new 16' sport and the 3 sets of electrical outlets are not working. All other electrical parts are working, including fridge, lights, and solar panel. Any ideas?

Thanks
__________________

__________________
TonyAlaska is offline   Reply With Quote
Old 06-08-2012, 08:01 AM   #2
Rivet Master
 
Bruce B's Avatar

 
2012 16' International
Jamestown , Rhode Island
Join Date: Mar 2012
Posts: 1,387
Images: 1
Quote:
Originally Posted by TonyAlaska View Post
We've got a new 16' sport and the 3 sets of electrical outlets are not working. All other electrical parts are working, including fridge, lights, and solar panel. Any ideas?

Thanks
Tony,

There are breakers behind the cover of the converter. The converter is located on the right side just above the floor next to the storage doors beneath the rear bunk. It has two plastic fasteners that need to be turned 90 degrees to unlock. Check the breaker first.

This may be a silly question but you are plugged into shore power right? The AC side of the trailer does not run from the batteries and even if you have a factory installed inverter that uses seperate outlets.

Bruce
__________________

__________________
Bruce B is offline   Reply With Quote
Old 06-08-2012, 08:06 AM   #3
2 Rivet Member
 
2011 27' FB Classic
Masontown , West Virginia
Join Date: Oct 2010
Posts: 62
Ground Fault

While not certain on your unit, check the outlet that has the ground fault mechanism. This usually feeds several other outlets.
Goodluck
Bill
__________________
Bill & Dorothy Reeves
Betsy the Beagle
2011 27FB
2016 F250 6.2L
TAC # WV-2
MountaineerStreamer is offline   Reply With Quote
Old 06-08-2012, 07:42 PM   #4
Rivet Master
 
TBRich's Avatar

 
2006 19' Safari SE
Tucson , Arizona
Join Date: Jun 2007
Posts: 4,483
Images: 64
Has a GFCI been triggered? Sometime if ours gets triggered half the outlets on that circuit are affected. You have to turn the GFCI breaker in the panel off all the way and turn it back on to reset it.
__________________
TB & Greg and Abbey Schnauzer
AirForums #21900 . Membership Chair, 4C
Unit #3954
Travel Log: AZBambi...On the Road Again
TBRich is offline   Reply With Quote
Old 06-09-2012, 02:16 PM   #5
New Member
 
2012 16' Sport
Fairbanks , Alaska
Join Date: Jun 2012
Posts: 2
Thumbs up Thanks

Thanks everyone for the fast and helpful replies! Bruce called it - we didn't have the trailer plugged in, so that is obviously the problem. Newbie problem I guess...
__________________
TonyAlaska is offline   Reply With Quote
Reply

Tags
16' sport


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:47 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.