Thread Tools Search this Thread Display Modes
Old 04-22-2012, 04:31 PM   #1
1 Rivet Member
1986 32' Excella
Bellaire , Texas
Join Date: Mar 2012
Posts: 9
Unhappy Electrical issue

I've got a 1986 Excella center bath. For some reason I'm not getting current from my breaker box to my roof mounted A/C. There is current at the junction box....but the line is dead at the A/C. The A/c worked fine when I bought it in Oct....I moved it 5 miles away to a storage facility to do some some cosmetic work on it. I turned it on the other day for the first time and there is no juice at the A/C. Am I missing something? Any help would be appreciated since I live in Texas....and we can't survive here without A/C.

Many thanks-Vic

vicn2000 is offline   Reply With Quote
Old 04-22-2012, 04:51 PM   #2
Rivet Master
garry's Avatar
1969 31' Sovereign
Broken Arrow , Oklahoma
Join Date: Jan 2003
Posts: 1,331
Images: 7
What junction box are you referring to??
Where did you check for power at a junction box or at the circuit breaker panel?

Not sure about your unit but mine has a "junction box" inside the AC.

Check the circuit breaker turn it all the way "off and back on" to reset, the AC is on a circuit breaker by itself.

garry is offline   Reply With Quote
Old 04-23-2012, 05:27 AM   #3
Rivet Master
Skater's Avatar
1995 30' Excella
Bowie , Maryland
Join Date: Apr 2005
Posts: 2,343
Look for a standard household light switch that doesn't seem to do anything. My parents' '87 (and my '91 B190) had a switch to select between the A/C and the microwave - you couldn't use both at the same time. In my parents' trailer (a 34'), it's mounted in a cabinet above the sinks or counter.
1995 Airstream Classic 30' Excella 1000
2014 Ram 2500 Crew Cab with Cummins 6.7L Diesel

Sold but not forgotten: 1991 Airstream B190
Sold: 2006 F-250 6.0L Powerstroke Supercab
Skater is offline   Reply With Quote
Old 04-23-2012, 06:14 AM   #4
Rivet Master
1981 31' Excella II
New Market , Alabama
Join Date: Sep 2011
Posts: 5,287
That switch is to the right above the sink on my trailer. I removed the switch and hooked the two wires together. The few times I use the microwave I can remember to turn the compressor off. You need to check to see if the breaker in the box is working. Sometimes they go bad and won't turn on.

perryg114 is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:54 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.