Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-03-2012, 06:52 AM   #1
Rivet Master
 
paiceman's Avatar
 
2017 30' Classic
Upper St Clair, PA/Titusville, FL , PA-Summer/FL-Winter
Join Date: Aug 2011
Posts: 2,851
Images: 1
Bath Exhaust Fans

Wehave a 2011 25' FB Flying Cloud. This unit has a sink and toilet on one side and shower on the other side of the unit. The exhaust fans worked fine before we left, now neither fan functions at all. They are both the fans that have a handle which one pushes up, then pushes a small red on off push pin. I've checked the fuses, all look good, and all other electrical power works fine. We are hooked up to a 20amp house circuit so we have not tried the A/C or Micro Wave but everthing else works. Lights, fantastic fans etc.

Any ideas or help would be appreciated the moisture build up with two showers is significant.

Travel Safe
__________________
SAFE TRAVELS

Bud
2017 30' Classic - F350 6.7 Diesel Crew
USAF - Military Training Instructor (TI) - 68-72
paiceman is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:12 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.