Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-27-2014, 10:14 PM   #1
3 Rivet Member
 
2012 25' FB Flying Cloud
Grand Rapids , Michigan
Join Date: Sep 2012
Posts: 163
2012 Flying Cloud 25FB electrical?

In the past two days the 120 volt service through the rear connector has been going on and off. I thought it was an issue at the pedestal but today we switched parks 120 came on for a brief time and then quit entirely. When I switched to the front connection everything is fine. Some where I have a loose connection to the rear 120. Any ideas where I should start looking?
__________________

__________________
Jwestman is offline   Reply With Quote
Old 06-27-2014, 10:35 PM   #2
Rivet Master
 
Roadtoaster's Avatar
 
2015 30' Flying Cloud
Currently Looking...
Byhalia , Mississippi
Join Date: Apr 2006
Posts: 807
I experienced the same thing 3 years ago on my 28'. Took the entire male section out and had to replace the guts because of one or more loose wires. Pull the guts out and check for the same thing. Hope this helps.
__________________

__________________
Greg
Roadtoaster is offline   Reply With Quote
Old 06-28-2014, 05:38 AM   #3
Well Preserved

 
1993 21' Sovereign
Colfax , North Carolina
Join Date: Jun 2003
Posts: 20,193
It may be the Marinco connector, or it could be the transfer switch.
__________________
Meddle not in the affairs of dragons, for you are crunchy, and taste good with ketchup.
Terry
overlander63 is offline   Reply With Quote
Old 06-28-2014, 09:05 AM   #4
3 Rivet Member
 
2012 25' FB Flying Cloud
Grand Rapids , Michigan
Join Date: Sep 2012
Posts: 163
It is not the cable from the pillar to the trailer because that works fine when plugged into the front trailer connection. It is in the trailer from the rear connection forward.
__________________
Jwestman is offline   Reply With Quote
Old 06-28-2014, 11:43 AM   #5
Home of Vortex tuning
 
CDONA's Avatar
 
2013 27' FB Eddie Bauer
Spearfish , South Dakota
Join Date: Dec 2009
Posts: 523
Images: 9
Known issue
http://www.airforums.com/forums/f37/...ry-104803.html
__________________
"Chip Tank" is in Paso Robles Ca..
CDONA is offline   Reply With Quote
Old 06-28-2014, 02:42 PM   #6
3 Rivet Member
 
2012 25' FB Flying Cloud
Grand Rapids , Michigan
Join Date: Sep 2012
Posts: 163
If this is an Automatic Transfer Switch issue, would this be solved and also upgraded by swapping out the parallax with a progressive dynamics 4655?
__________________
Jwestman is offline   Reply With Quote
Old 06-28-2014, 03:00 PM   #7
Rivet Master
 
lsbrodsky's Avatar
 
2012 25' FB International
Trent Woods , North Carolina
Join Date: May 2013
Posts: 1,687
No the transfer switch is a separate box.
Larry
__________________

__________________
lsbrodsky is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Two Ton Toaster :: 2012 Airstream Flying Cloud 25FB JCEaton Airstream Registry Discussions 0 06-16-2012 04:06 PM
25FB Flying Cloud :: 2012 Airstream gbelcastro Airstream Registry Discussions 0 05-22-2012 08:17 PM
Warranty work on new 2012 25fb Flying Cloud danlehosky General Repair Forum 8 02-04-2012 09:55 PM
Centramatics for 2012 Flying Cloud 25FB wlanford Wheels, Hubs & Bearings 14 08-25-2011 10:06 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:15 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.