Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-26-2007, 11:53 AM   #1
4 Rivet Member
 
1969 31' Sovereign
1951 21' Flying Cloud
Alex , Oklahoma
Join Date: Jan 2007
Posts: 356
Images: 10
12v & 110 1969 Sov 31'

OK here goes, I am doing this for hubby who doesn't type. We went on a trip a few weeks ago and our 110 worked at the camp ground then a day and a half later the lights went out so we had to use the 12v. We got home and the 110 still doesn't work. The AC works as it is on a different 110 line. We have electricity going into the converter and coming out but it isn't making it to the rest of the trailer. Does any have wiring diagrams for the 1969 Sov?
The fuses are all good, he says! There is an Off and On switch box up front in a cabinet (breaker box) he has turned them on and off. There is a switch box in the bathroom in the cabinet above the hotwater heater, he has turned it on and off. He seems to think if he has a wiring diagram he can follow it around the trailer. Any help would be appreciated.

CJ of Okla
__________________

__________________
1969 Sovereign
1951 Flying Cloud SS#7062
AIR #18751
CJ of Okla is offline   Reply With Quote
Old 09-26-2007, 05:13 PM   #2
Rivet Master
 
TomW's Avatar
 
1967 26' Overlander
Huntsville , Alabama
Join Date: Dec 2003
Posts: 2,918
Images: 2
Sixties' diagrams are fairly general

Quote:
Originally Posted by CJ of Okla
... Does any have wiring diagrams for the 1969 Sov?
The fuses are all good, he says! ... He seems to think if he has a wiring diagram he can follow it around the trailer. ...
Sounds like a bad breaker. If not, each 120 vac outlet cover should be removed to check the voltages entering & leaving each outlet.

Attached is a diagram from 1967. I doubt 1969's diagram looks that much different. But I think the problem can be located without a diagram.

Good luck,
Tom
Attached Thumbnails
Click image for larger version

Name:	ElectricalDiagram.jpg
Views:	8834
Size:	46.2 KB
ID:	46097  
__________________

TomW is offline   Reply With Quote
Old 09-27-2007, 06:43 AM   #3
4 Rivet Member
 
1969 31' Sovereign
1951 21' Flying Cloud
Alex , Oklahoma
Join Date: Jan 2007
Posts: 356
Images: 10
Quote:
Originally Posted by TomW
Sounds like a bad breaker. If not, each 120 vac outlet cover should be removed to check the voltages entering & leaving each outlet.

Attached is a diagram from 1967. I doubt 1969's diagram looks that much different. But I think the problem can be located without a diagram.

Good luck,
Tom
Tom Thanks for the diagram, I will give to hubby to see if it helps. He went to A/S dealer yesterday and the guy thinks it is the converter. So hubby is going to do some testing this weekend to see if he can pin point the problem. Thank you again for taking the time to send me your diagram.

CJ of Okla
__________________
1969 Sovereign
1951 Flying Cloud SS#7062
AIR #18751
CJ of Okla is offline   Reply With Quote
Old 10-02-2007, 11:50 AM   #4
New Member
 
1976 31' Sovereign
leesburg , Florida
Join Date: Oct 2007
Posts: 2
Hello CJ. I just joined this forum and found your post. I have a 76 sovereign that has an electrical problem as well. I saw the diagram that Riveter sent you, but it's very hard to read. I have AC to some of my trailer, but nothing in the center bath, the two outlets in the rear bedroom and the outside outlet.
__________________
billyeag is offline   Reply With Quote
Reply

Tags
12v


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1969 31' window screens CJ of Okla Windows & Screens 7 02-22-2007 05:41 PM
1969 Sovereign 31' CJ of Okla Doors & Locks 8 02-08-2007 07:33 AM
Our 1977 31' Sov. Midbath Marvel klayman Member Introductions 2 05-27-2006 08:15 AM
lights 12v and 110 v moe146 Electrical - Systems, Generators, Batteries & Solar 5 05-16-2004 07:37 AM
New Radio/CD works on 12V but not 110 Austin Runner Electrical - Systems, Generators, Batteries & Solar 3 04-25-2004 08:20 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:36 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.