Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-03-2015, 09:56 AM   #1
3 Rivet Member
 
ILOVESALLY's Avatar
 
2007 25' Safari SS SE
Sarasota , Florida
Join Date: Sep 2012
Posts: 152
Water heater and furnace not working

Water heater light is on but doesn't want to fire up. I can here it clicking to start. I've started the gas stove to bleed the gas through but still doesn't fire up. Do I need to turn the pump on to draw water into tank?
And I'm wondering why the furnace only blows for a minute or so and only cold then shuts off. What am I missing and not doing right?
__________________

__________________
LoveSally
ILOVESALLY is offline   Reply With Quote
Old 02-03-2015, 10:10 AM   #2
Rivet Master
 
TinShack's Avatar

 
2005 28' Safari S/O
Paradise , California
Join Date: Jul 2006
Posts: 3,438
Images: 28
Quote:
Originally Posted by ILOVESALLY View Post
Water heater light is on but doesn't want to fire up. I can here it clicking to start. I've started the gas stove to bleed the gas through but still doesn't fire up. Do I need to turn the pump on to draw water into tank?
And I'm wondering why the furnace only blows for a minute or so and only cold then shuts off. What am I missing and not doing right?
It sounds like you are either out of propane, or your propane is turned off. Have you checked the tanks? Is the flow switch at the tank pointed to a full tank with the tank knob turned on? Is the indicator bulb at the tank showing green? These are all things to check first.
__________________

__________________
Steve
"THE OLDER I GET, THE BETTER I WAS"
TinShack is offline   Reply With Quote
Old 02-03-2015, 10:12 AM   #3
Rivet Master
 
1988 25' Excella
1987 32' Excella
Knoxville , Tennessee
Join Date: Oct 2010
Posts: 2,163
Blog Entries: 1
I assune you have just switched gas cylinders? I have had that happen. Make sure the pigtail is really screwed into the cylinder tight. It has to open the safety valve. Let the whole system sit for an hour. Then try again, The gas pressure is very low, The stove is near the cylinder and will light on little gas. The furnace and WH need a full dose to ignite,
__________________
Bill M. is offline   Reply With Quote
Old 02-03-2015, 10:21 AM   #4
4 Rivet Member
Commercial Member
 
acstokes's Avatar
 
2009 30' Classic
Melbourne, FL , Searsport, ME
Join Date: Jul 2013
Posts: 309
Quote:
And I'm wondering why the furnace only blows for a minute or so and only cold then shuts off.
This is because the thermocouples on the WH and furnace are not sensing a flame and so turnoff any gas flow. The clicking is the igniter trying to ignite, but no gas is getting to the igniter. The fact that neither WH or furnace are igniting means propane is not flowing from your tank. Try what the above posters have recommended.
__________________
Fred Stokes
RV Rearview Camera Systems, LLC
WBCCI #2810
acstokes is offline   Reply With Quote
Old 02-03-2015, 12:04 PM   #5
2 Rivet Member
 
oldfulltimer's Avatar
 
1993 34' Excella
Randolph , Vermont
Join Date: Jun 2013
Posts: 32
Agree with all the above but if you have a manometer, you could hook it up to a stove burner jet and check that your regulator is allowing 11" of Water Column pressure. If someone has been messing with the regulator or it is bad than neither your furnace nor water heater will ignite and stay lit.

Dave
__________________
oldfulltimer is offline   Reply With Quote
Old 02-03-2015, 12:14 PM   #6
Rivet Master
 
mayco's Avatar

 
1982 31' Airstream 310
champaign , Illinois
Join Date: Jun 2013
Posts: 2,760
Sounds like a bad regulator, I had a similar situation. My final test was to light all my stove burners and then tried to light the gas oven all at the same time. There wasnt enough gas flow. Replaced the regulator and all appliances worked at the same time.
__________________
mayco is online now   Reply With Quote
Old 02-04-2015, 06:39 PM   #7
3 Rivet Member
 
ILOVESALLY's Avatar
 
2007 25' Safari SS SE
Sarasota , Florida
Join Date: Sep 2012
Posts: 152
Thanks all, looks like a bad regulator. I'll change it out this weekend. Love the forum.
__________________
LoveSally
ILOVESALLY is offline   Reply With Quote
Old 02-04-2015, 08:22 PM   #8
cwf
Rivet Master
 
cwf's Avatar
 
1999 34' Excella
Currently Looking...
Hillsboro , Texas
Join Date: Feb 2013
Posts: 5,928
Images: 2
Quote:
Originally Posted by oldfulltimer View Post
Agree with all the above but if you have a manometer, you could hook it up to a stove burner jet and check that your regulator is allowing 11" of Water Column pressure. If someone has been messing with the regulator or it is bad than neither your furnace nor water heater will ignite and stay lit.

Dave
DING DING DING!!! I think this is the winner! We had similar on our 1999... replaced it last year. Workie fine now!
__________________
Peace and Blessings..
Channing
WBCCI# 30676
cwf is offline   Reply With Quote
Old 02-07-2015, 06:32 PM   #9
3 Rivet Member
 
ILOVESALLY's Avatar
 
2007 25' Safari SS SE
Sarasota , Florida
Join Date: Sep 2012
Posts: 152
Confused. Changed out regulator and the stove works great but furnace and hot water heater still not working. Furnace kicks on for 2 minutes, blows cold and water heater still clicking trying to light. Help. Wife needs hot shower
__________________
LoveSally
ILOVESALLY is offline   Reply With Quote
Old 02-07-2015, 06:44 PM   #10
4 Rivet Member
Commercial Member
 
acstokes's Avatar
 
2009 30' Classic
Melbourne, FL , Searsport, ME
Join Date: Jul 2013
Posts: 309
Could still be air in the line. Keep trying WH and furnace several times to bleed air.
__________________
Fred Stokes
RV Rearview Camera Systems, LLC
WBCCI #2810
acstokes is offline   Reply With Quote
Old 02-07-2015, 08:52 PM   #11
Prairie Schooner II
 
Jim Flower's Avatar

 
2012 30' International
1997 25' Safari
1967 20' Globetrotter
Burlington , Ontario
Join Date: Jul 2009
Posts: 1,182
I had the same issue and followed the same course. It turned out to be a pinched exposed gas line under the Airstream. I think the pinch was caused by road debris. I worked on the line a bit with some pliers and nursed it back to its original diameter. The fix worked. Jim


Sent from my iPad using Airstream Forums
__________________
Jim
Jim Flower is offline   Reply With Quote
Old 02-07-2015, 09:18 PM   #12
3 Rivet Member
 
ILOVESALLY's Avatar
 
2007 25' Safari SS SE
Sarasota , Florida
Join Date: Sep 2012
Posts: 152
I'll keep trying. Thanks all
__________________
LoveSally
ILOVESALLY is offline   Reply With Quote
Old 02-08-2015, 07:15 PM   #13
3 Rivet Member
 
ILOVESALLY's Avatar
 
2007 25' Safari SS SE
Sarasota , Florida
Join Date: Sep 2012
Posts: 152
Trying all day today after changing out regulator. Still no hot water or furnace kicking on. Keep bleeding gas through stove but to no avail.
Anyone got any other suggestions? I've been through all above suggestions.
__________________
LoveSally
ILOVESALLY is offline   Reply With Quote
Old 02-08-2015, 08:06 PM   #14
Rivet Master
 
A W Warn's Avatar
 
2000 25' Safari
1999 34' Excella
Davidson County, NC , Highlands County, FL
Join Date: Aug 2006
Posts: 2,567
Will the cook top burner flame light normally? If the stove will light you have proven that: (1) you have fuel, and (2) that the fuel is flowing through the regulator.

If the cooktop burner works, try wiggling (unplug and re-plug a few times) the wires to clean the contacts on the water heater. Then loosen the ground wire at the water heater, clean and re-tighten.

If you get the water heater going, the furnace may be a totally different problem.

edit:
I am an hour east of you, so I know about the lightning last week. Is it possible an electric surge might have affected the electronics in your trailer?
__________________

__________________
Alan
2014 Silverado 1500 Crew Cab 5.3L maximum trailering package (yes, I'm towing the 34')
A W Warn is online now   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Water heater not working nilesrob General Repair Forum 16 11-21-2012 09:37 AM
Water heater is not working Densin E. LP Gas, Piping, Tanks & Regulators 5 08-26-2012 09:53 AM
Trailer Atwood Water Heater not working? silverback Water Heaters, Filters & Pumps 2 06-01-2010 09:52 AM
New Water Heater Not Working Properly BobbyWhitit Water Heaters, Filters & Pumps 8 04-18-2010 02:10 PM
Water heater bypass not working Rob30044 Winterizing, Storage, Carports & Covers 7 12-05-2005 07:33 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:07 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.