Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-09-2009, 08:08 AM   #1
New Member
 
Join Date: Jan 2005
Posts: 2
workhorse auto park

I have a problem with this auto park system, twice the relay and switch assy. had gone bad within 1000k. Does anyone have any answers to this? It was repaired by Airstream and GMC dealer and they do not know why this is happening. Luck has had it that it decided to go when I was stopped. They tell me it can also go bad while travelling, think that is a little scary. Thanks to all that apply.

2003 Airstream Land Yacht 30'
__________________
didi is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 LY Workhorse Alternator museumdude Mechanics Corner - Engines, Transmission & More... 8 12-04-2008 03:23 PM
Workhorse brake rotors harold1946 Land Yacht/Legacy Motorhomes 8 07-09-2008 08:49 PM
Auto Park jim8860 Mechanics Corner - Engines, Transmission & More... 9 07-13-2005 09:07 PM
Auto Park jim8860 General Motorhome Topics 5 01-22-2004 06:28 AM
New P-3X series Workhorse Chassis evan Airstream Motorhome Forums 6 04-19-2003 09:00 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:34 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.